К. В. Новиков лабораторный практикум по курсу «системы управления медицинскими базами данных» icon

К. В. Новиков лабораторный практикум по курсу «системы управления медицинскими базами данных»



Смотрите также:
Экзаменационные билеты по курсу «информатика»...
Системы управления базами данных...
Тема Базы данных. Системы управления базами даннях...
Лабораторный практикум по курсу радиоэкология...
Учебное пособие Введение...
Базовая учебная программа дисциплины «системы управления базами данных» для студентов...
Ы включенные в пособие Разделы не вошедшие в пособие Тип пособия...
Электронный лабораторный практикум по вычислительной математике...
Прикладное программное обеспечение и его эффективное использование: системы управления базами...
Урок Тема урока: Базы данных и системы управления базами данных...
Следует из требований к организации базы данных...
Лабораторный практикум по микробиологии...



скачать
ФЕДЕРАЛЬНОЕ АГЕНТСТВО ПО ОБРАЗОВАНИЮ

Государственное образовательное учреждение
высшего профессионального образования


ВЛАДИМИРСКИЙ ГОСУДАРСТВЕННЫЙ УНИВЕРСИТЕТ

Факультет радиофизики, электроники и медицинской техники


К.В. Новиков


ЛАБОРАТОРНЫЙ ПРАКТИКУМ
ПО КУРСУ


«СИСТЕМЫ УПРАВЛЕНИЯ МЕДИЦИНСКИМИ БАЗАМИ ДАННЫХ»


(для студентов специальностей 200401, 200402)


Владимир 2007

УДК 681.3.016(07)

Новиков К.В. Лабораторный практикум по курсу «Системы управления медицинскими базами данных» (для студентов специальностей 200401, 200402). – Владимир: ВлГУ. 2007. – 28 с.

Лабораторный практикум предназначен для лучшего усвоения материала по курсу «Системы управления медицинскими базами данных», более детального и глубокого изучения предмета. Практикум должен помочь студентам в выполнении лабораторных работ.

Илл.29. Библиограф. 11 назв.

Рецензенты:


 Владимирский государственный университет, 2007 г.

 К.В. Новиков, 2007 г.


СОДЕРЖАНИЕ


^ ЛАБОРАТОРНАЯ РАБОТА №1. Проектирование и создание

реляционной БД в СУБД Microsoft Access……………………………………..


4

^ ЛАБОРАТОРНАЯ РАБОТА №2. Создание экранных форм в СУБД

Microsoft Access………………………………………………………………….


9

^ ЛАБОРАТОРНАЯ РАБОТА №3. Создание SQL-запросов в СУБД

Microsoft Access………………………………………………………………….


18

^ ЛАБОРАТОРНАЯ РАБОТА №4. Создание отчетов в СУБД Microsoft

Access……………………………………………………………………………...


19

^ СПИСОК РЕКОМЕНДУЕМОЙ ЛИТЕРАТУРЫ…………………………

28

ПРИЛОЖЕНИЕ 1. Варианты описаний предметных областей……………..

29


^ ЛАБОРАТОРНАЯ РАБОТА №1

Проектирование и создание реляционной БД в СУБД Microsoft Access


Цель работы. Получение навыков проектирования и создания реляционной БД в СУБД Microsoft Access.


^ Домашняя подготовка

1. Изучите порядок проектирования реляционной базы данных (РБД), принципы нормализации РБД, методы обеспечения ссылочной целостности РБД.

2. Изучите словесное описание предметной области (см. Приложение 1).

3. Создайте концептуальную модель “сущность-связь”, отражающую структуру данных заданной Вам предметной области.

4. На основе концептуальной модели постройте физическую модель “сущность-связь”.

5. Определите реляционные таблицы.

6. Нормализуйте таблицы до формы не ниже нормальной формы Бойса-Кодда.

Выполнение работы

1. Запустите Microsoft Access.

2. Создайте новую БД.

Чтобы создать базу данных необходимо выбрать из меню Файл команду Создать. В появившейся области задач Создание файла выбрать элемент Новая база данных. Появится диалоговое окно Файл новой базы данных с содержимым папки Мои документы. В раскрывающемся списке Папка открыть папку, в которой будет храниться создаваемая база данных. В поле ввода Имя файла указать имя создаваемого файла и нажать кнопку Создать. После нажатия кнопки появится окно новой базы данных.

3. Создайте реляционные таблицы

В Access используются три способа создания таблиц: путем ввода данных, с помощью Конструктора таблиц и с помощью Мастера создания таблиц. Для каждого из этих способов существует специальный ярлык новых объектов в списке таблиц. Если вы создали новый файл базы данных, то, кроме этих ярлыков, в списке таблиц больше ничего нет.

Для создания новой таблицы нужно раскрыть список таблиц, щелкнув по ярлыку Таблицы на панели объектов окна базы данных, и затем нажать кнопку Создать. Тогда появится диалоговое окно Новая таблица, в котором вы и должны выбрать способ создания таблицы (рис. 1.1).



Рис. 1.1. Диалоговое окно Новая таблица


Режим Конструктора дает больше всего возможностей при описании таблиц., поэтому рекомендуется использовать именно его. В режиме Конструктора таблицы создаются путем задания имен полей, их типов и свойств.

Создание таблицу в режиме Конструктора выполняется следующим образом. Дважды щелкните левой кнопкой мыши на ярлыке ^ Создание таблицы с помощью конструктора или нажмите на кнопку Создать в верхней части окна базы данных, выберите из списка в окне Новая таблица элемент Конструктор и нажмите кнопку ОК. В том и в другом случае откроется пустое окно Конструктора таблиц (рис. 1.2).



Рис. 1.2. Окно новой таблицы в режиме Конструктора


В окне Конструктора таблиц в столбец Имя поля ввести имена полей создаваемой таблицы. В столбце ^ Тип данных для каждого поля таблицы выбрать из раскрывающегося списка тип данных, которые будут содержаться в этом поле. В столбце Описание можно ввести описание данного поля. В нижней части окна Конструктора таблиц на вкладке Общие ввести свойства каждого поля или оставить значения свойств, установленные по умолчанию. На вкладке Подстановка можно настроить выбор значения поля из другой таблицы или запроса.

После описания всех полей будущей таблицы необходимо выделить поля, составляющие первичный ключ, и нажать кнопку ^ Ключевое поле. Далее следует нажать кнопку Сохранить. В окне Сохранить как в поле Имя таблицы ввести имя создаваемой таблицы и нажать кнопку ОК.

После указанных действий в списке таблиц в окне базы данных появятся имя и значок новой таблицы. Ввести данные в созданную таблицу можно, открыв таблицу в режиме Таблицы.

4. Определите связи между таблицами

Для того чтобы было удобно просматривать, создавать, удалять и модифицировать связи между таблицами, в Microsoft Access используется схема данных (рис. 1.3).



Рис. 1.3. Пример схемы данных


Чтобы открыть схему данных, необходимо выполнить команду Сервис, Схема данных. Чтобы добавить в схему таблицу, необходимо щелкнуть правой кнопкой мыши на свободном пространстве схемы данных и из контекстного меню выбрать команду Добавить таблицу. В диалоговом окне Добавление таблицы раскрыть вкладку Таблицы, выбрать из списка таблицы, которые необходимо добавить в схему, и нажать кнопку Добавить (рис. 1.4).



Рис. 1.4. Диалоговое окно Добавление таблицы


Нажмите кнопку Закрыть, чтобы закрыть диалоговое окно Добавление таблицы. Cвязи можно создать следующим образом. Следует выбрать в главной таблице поле для связи, нажать левую кнопку мыши и перетащить поле во вторую таблицу. Отпустить левую кнопку мыши над тем полем подчиненной таблицы, с которым устанавливается связь. После этого появится диалоговое окно Изменение связей (рис. 1.5).

В диалоговом окне Изменение связей можно выбрать из списков названия связанных таблиц и полей для связывания. Если отношение между таблицами "один-ко-многим", то слева из списка Таблица/запрос выбирается главная таблица и поле в этой таблице, а справа из списка Связанная таблица/запрос — подчиненная и соответственно поле в ней. Если отношение "один-к-одному", то порядок таблиц значения не имеет. Если вы устанавливали связь графически, то все поля в списках уже выбраны, и нужно только определить правила ссылочной целостности.



Рис. 1.5. Окно Изменение связей


Для этого устанавливают флажок ^ Обеспечение целостности данных и один или оба флажка: каскадное обновление связанных полей и каскадное удаление связанных записей.

После установки всех параметров связи необходимо нажать кнопку ОК в окне Параметры объединения и закрыть окно Схема данных, нажав на кнопку Закрыть в правом верхнем углу окна.

5. Сохраните БД.


Содержание отчета

1. Цель работы

2. Словесное описание предметной области

3. Концептуальная модель “сущность-связь”

4. Физическая модель “сущность-связь”

5. Доказательство, что БД находится в номальной форме Бойса-Кодда.

6. Схема данных, созданная в Microsoft Access

7. Краткие выводы о навыках, приобретенных в ходе выполнения работы.


^ ЛАБОРАТОРНАЯ РАБОТА №2

Создание экранных форм в СУБД Microsoft Access


Цель работы. Получение навыков создания экранных форм для управления данными в СУБД Microsoft Access.


^ Домашняя подготовка

1. Изучите требования к проектированию интерфейса медицинской информационной системы.

2. Нарисуйте эскизы экранных форм и определите порядок их вызова.


Выполнение работы

1. Создайте экранные формы для управления данными в режиме мастера.

С помощью мастера можно создавать формы на основе одной таблицы и более сложные формы на основе нескольких таблиц и запросов, имеющие подчиненные формы.

Мастер форм разбивает процесс создания формы на несколько этапов. На каждом этапе требуется установить определенные параметры в одном из диалоговых окон мастера, каждое из которых определяет один шаг создания формы. Если на каком-нибудь шаге была допущена ошибка или возникла необходимость изменения каких-либо установленных параметров, для возвращения к предыдущему шагу нажмите кнопку Назад. Кроме того, в любой момент можно нажать кнопку Отмена для отказа от создания формы и возвращения к окну базы данных.

Чтобы лучше представить, как создавать простые формы с помощью Мастера форм, опишем процедуру создания формы карточки медицинского учета "КМУ" . Источником данных для этой формы будет таблица "КМУ". Чтобы с помощью мастера создать простую форму, не содержащую подчиненных форм:

Щелкните по ярлыку ^ Формы в окне базы данных.

Нажмите кнопку Создать на панели инструментов окна базы данных. В списке вариантов в появившемся диалоговом окне Новая форма выделите элемент Мастер форм и нажмите кнопку ОК. То же самое можно сделать, дважды щелкнув по ярлыку Создание формы с помощью мастера, находящемуся перед списком существующих форм в базе данных.

Появится первое диалоговое окно Мастера форм (рис. 2.1). В поле со списком ^ Таблицы и запросы, как и в раскрывающемся списке в окне Новая форма, будут отображены имена всех таблиц и запросов базы данных, которые могут использоваться в качестве источника данных для формы. Раскройте этот список и выберите имя таблицы или запроса. В нашем примере – это таблица "КМУ".



Рис. 2.1. Первое диалоговое окно Мастера форм


В списке Доступные поля этого диалогового окна отображаются все поля выбранной таблицы или запроса. Добавление полей в форму позволит просматривать и редактировать данные выбранной таблицы. Чтобы добавить в создаваемую форму только некоторые поля, выделите каждое из этих полей и нажмите кнопку ">". Выделенное поле будет перемещено из списка Доступные поля в список Выбранные поля. Чтобы добавить в создаваемую форму сразу все поля из выбранной таблицы или запроса, нажмите кнопку ">>". Нажмите кнопку Далее для отображения второго диалогового окна Мастера форм.

Во втором диалоговом окне мастера (рис. 2.2) можно определить вид формы. Чтобы задать внешний вид формы, выберите один из переключателей: в один столбец, ленточный, табличный, выровненный, сводная таблица или сводная диаграмма.

После выбора подходящего режима отображения данных в форме нажмите кнопку Далее для отображения следующего диалогового окна Мастера форм.




Рис. 2.2. Второе диалоговое окно Мастера форм


Третье диалоговое окно Мастера форм (рис. 2.3) предназначено для выбора стиля оформления новой формы. Мастер предлагает несколько стандартных стилей оформления. Выберите один из предлагаемых стилей и нажмите кнопку Далее.

В последнем диалоговом окне Мастера форм (рис. 2.4) требуется указать название формы. В поле ввода этого диалогового окна введите название формы: КМУ. Чтобы отобразить созданную мастером форму в режиме Формы, выберите переключатель Открыть форму для просмотра и ввода данных, после чего нажмите кнопку Готово.



Рис. 2.3. Третье диалоговое окно Мастера форм




Рис. 2.4. Последнее диалоговое окно Мастера форм


В результате мастером будет создана форма в соответствии с выбранными параметрами и сохранена с указанным именем, затем эта форма будет открыта в заданном режиме. На рис. 2.5 представлена созданная форма, открытая в режиме Формы.




Рис. 2.5. Форма "КМУ", созданная с помощью Мастера форм


Созданная с помощью мастера форма "КМУ " готова к использованию. Однако можно улучшить ее внешний вид, изменив некоторые параметры оформления.

2. Доработайте экранные формы в режиме конструктора.

Выберите форму из списка и нажмите кнопу Конструктор на панели инструментов. Доработаем форму «КМУ» таким образом, чтобы на карточке отображались медицинские услуги, оказанные пациенту.

Создайте форму «Оказанные медицинские услуги» в режиме мастера (рис. 2.6).




Рис. 2.6. Форма «Оказанные медицинские услуги в режиме Конструктора


Откройте форму «Оказание медицинских услуг» в режиме Конструктора. Наведите указатель мыши в квадрат, расположенный в левом верхнем углу формы и нажмите правую кнопку мыши. В появившемся меню выберите пункт Свойства. Установите свойство Режим по умолчанию в состояние Режим таблицы (рис. 2.7). И сохраните форму «Оказание медицинских услуг».




Рис. 2.7. Свойства формы «Оказанные медицинские услуги»


Откройте форму «КМУ» в режиме конструктора (рис. 2.8).




Рис. 2.8. Форма «КМУ» в режиме конструктора


С помощью мыши увеличьте область данных и расположите элементы управления, находящиеся на форме так, как показано на рис. 2.9.




Рис. 2.9. Формы «КМУ» после изменения расположения элементов управления в режиме Конструктора


Отобразите панель элементов нажатием кнопки . На панели элементов выберите элемент «Подчиненная форма/отчет». Мышью укажите на форме область, в которой будет располагаться таблица оказанных медицинских услуг. При этом на экране появится диалог изображенный на рис. 2.10.



Рис. 2.10. Первое окно мастера подчиненных форм.


Выберите из списка форму «Оказанные медицинские услуги». Нажмите кнопку Далее. Определите связь между главной и подчиненной формой так как показано на рис. 2.11




Рис. 2.11. Второе окно мастера подчиненных форм.


Нажмите кнопку Далее. Задайте имя подчиненной формы и нажмите кнопку Готово (рис. 2.12).




Рис.2.12. Третье окно мастера подчиненных форм.


В результате получится форма, изображенная на рис. 2.13.



Рис. 2.13. Форма «КМУ» с табличной частью


В верхней части отображается и редактируется шапка КМУ, а в нижней – табличная часть.

Содержание отчета

1. Цель работы

2. Описание процесса создания интерфейса.

3. Рисунки с изображением форм в режиме Конструктора и в режиме работы с данными.

4. Краткие выводы о навыках, приобретенных в ходе выполнения работы.


^ ЛАБОРАТОРНАЯ РАБОТА №3

Создание SQL-запросов в СУБД Microsoft Access


Цель работы. Получение навыков создания SQL-запросов в СУБД Microsoft Access.


^ Домашняя подготовка

1. Изучите синтаксис операторов select, insert, update, delete языка SQL.

2. Составьте запросы на выборку данных (select) из БД созданной в ходе выполнения лабораторной работы №1 с использованием конструкций left join, inner join, full join, where, and, or, not, like, between, exists, in, sum, min, max, group by, having, order by, union.

3. Составьте запрос вида

insert into [Таблица] select … from ….

4. Составьте запрос вида

update [Таблица] set … where …

5. Составьте запрос вида

delete from [Таблица] where …


Выполнение работы

Введите созданные в процессе домашней подготовки запросы SQL в СУБД Access.

Для создания нового запроса в Microsoft Access раскройте список запросов окна базы данных и нажмите кнопку ^ Создать. В списке диалогового окна Новый запрос выберите Конструктор и нажмите кнопку ОК. Выберите команду меню Вид, Режим SQL или щелкните по стрелке на кнопке Вид на панели управления и выберите элемент Режим SQL. Откроется диалоговое окно, в котором необходимо написать предложение SQL. Нажмите кнопку Запуск. На экране отобразится результат запроса.


Содержание отчета

1. Цель работы

2. Схема БД

3. Содержимое таблиц БД.

4. SQL-запросы и результаты их выполнения

3. Краткие выводы о навыках, приобретенных в ходе выполнения работы.


^ ЛАБОРАТОРНАЯ РАБОТА №4

Создание отчетов в СУБД Microsoft Access


Цель работы. Получение навыков создания отчетов в СУБД Microsoft Access.


Домашняя подготовка

Нарисуйте эскизы отчетов, которые можно сформировать на основе запросов на выборку созданных в процессе выполнения лабораторной работы №3.

^ Выполнение работы

1. Создайте отчеты, эскизы которых вы нарисовали в процессе домашней подготовки.

Простым и быстрым способом создания отчетов является использование Мастера отчетов. С его помощью можно создавать отчеты, содержащие поля из одной или более таблиц или запросов. Чтобы более наглядно представить процесс создания отчета с помощью мастера, опишем процедуру создания отчета на основе запроса «Услуги по сотрудникам за период»:


SELECT Сотрудники.Код, Сотрудники.Фамилия, Сотрудники.Имя,

Сотрудники.Отчество, МедицинскиеУслуги.Наименование,

Sum(ОказанныеМедицинскиеУслуги.Количество) AS Количество

FROM Сотрудники INNER JOIN

(МедицинскиеУслуги INNER JOIN

ОказанныеМедицинскиеУслуги

ON МедицинскиеУслуги.Код=ОказанныеМедицинскиеУслуги.КодУслуги)

ON Сотрудники.Код=ОказанныеМедицинскиеУслуги.КодСпециалиста

WHERE Дата Between ’01.01.2006’ And ’31.12.2006’

GROUP BY Сотрудники.Код, Сотрудники.Фамилия, Сотрудники.Имя,

Сотрудники.Отчество, МедицинскиеУслуги.Наименование

ORDER BY Сотрудники.Фамилия, Сотрудники.Имя, Сотрудники.Отчество,

МедицинскиеУслуги.Наименование


На панели объектов окна базы данных щелкните по ярлыку ^ Отчеты и нажмите кнопку Создать. Появится диалоговое окно Новый отчет (см. рис. 4.1). В списке диалогового окна Новый отчет выделите элемент Мастер отчетов. В поле со списком, находящемся в нижней части диалогового окна Новый отчет, содержатся имена всех таблиц и запросов базы данных, которые могут быть использованы в качестве источника данных для отчета. Раскройте этот список и выделите в нем запрос «Услуги по сотрудникам за период». Нажмите кнопку ОК. Появится первое диалоговое окно Мастера отчетов (рис. 4.2).



Рис. 4.1. Первое диалоговое окно Мастера отчетов

Прежде всего нужно определить, какие поля включить в отчет. Из запроса «Услуги по сотрудникам за период» в отчете будут использоваться все поля. С помощью кнопки ">>" переместите поля из списка Доступные поля в список Выбранные поля. В отчете поля появляются слева направо, в соответствии с последовательностью их расположения в списке Выбранные поля.



Рис. 4.2. Второе диалоговое окно Мастера отчетов

Во втором диалоговом окне необходимо указать, каким образом будут структурированы данные в отчете. Чтобы осуществить группировку по кодам сотрудников, выделите в списке элемент Код.

Access 2002 позволяет сортировать записи в пределах группы по значению произвольного поля, при этом сортировка проводится не более чем по четырем полям (рис. 4.3). Выберите в первом раскрывающемся списке поле "Наименование". По умолчанию принят порядок сортировки по возрастанию; если вы хотите выбрать порядок сортировки по убыванию, то нажмите на кнопку справа от раскрывающегося списка. Для возврата к сортировке по возрастанию снова нажмите на эту кнопку.



Рис. 4.3. Третье диалоговое окно Мастера отчетов


Нажмите кнопку Далее (Next), чтобы перейти к четвертому диалоговому окну Мастера отчетов, изображенному на рис. 4.4. Мастер отчетов предложит на выбор шесть вариантов оформления сгруппированных данных. В левой части диалогового окна Мастера отображается эскиз выбранного макета. Выберите в группе Макет переключатель ступенчатый. Чтобы перейти к пятому диалоговому окну Мастера отчетов, нажмите кнопку Далее.



Рис. 4.4. Четвертое диалоговое окно Мастера отчетов


В пятом диалоговом окне Мастера отчетов выберите один из предложенных стилей оформления отчета. В левой части диалогового окна Мастера отображается эскиз отчета выбранного стиля (рис. 4.5). Для создаваемого отчета выберите стиль Деловой, а затем нажмите кнопку Далее для перехода к последнему диалоговому окну Мастера отчетов.



Рис. 4.5. Шестое диалоговое окно Мастера отчетов


В последнем диалоговом окне Мастера (рис. 4.6) отчетов в качестве заголовка отчета введите: «Услуги по сотрудникам за период». Мастер отчетов сохранит созданный отчет под этим же именем. Выберите переключатель Просмотреть отчет и нажмите кнопку Готово для завершения создания отчета. Мастер отчетов создаст отчет и отобразит его в режиме Предварительного просмотра.

На рис. 4.7 изображен отчет, созданный мастером. Для просмотра всех частей отчета воспользуйтесь вертикальной и горизонтальной полосами прокрутки. Этот отчет можно использовать непосредственно в том виде, как его создал мастер, или применить его как основу для разработки более сложного отчета.



Рис. 4.6. Последнее диалоговое окно Мастера отчетов



Рис. 4.7. Отчет "Услуги по сотрудникам за период", созданный Мастером отчетов

 

2. Доработайте отчет в режиме конструктора

Более гибко настраивать вид отчета позволяет Конструктор отчетов. Отчет состоит из нескольких частей, называемых разделами. Разделы отчета включают заголовок отчета, примечание отчета, область данных отчета, а также верхний и нижний колонтитулы страниц отчета. Заголовок и примечание отчета, верхний и нижний колонтитулы страницы не являются обязательными элементами структуры отчета. Эти разделы можно добавить или удалить из отчета с помощью соответствующей команды меню Вид в режиме Конструктора.

Раздел заголовка отчета определяет высоту области заголовка отчета. Этот раздел может содержать текст, графику и другие элементы управления, которые будут выводиться в верхней части отчета. В многостраничном отчете раздел заголовка отображается только на первой странице.

Раздел области данных предназначен для отображения записей источника данных отчета. Этот раздел может содержать элементы управления для отображения данных из каждой записи в источнике — таблице и запросе.

Перетащите поля Код, Фамилия, Имя, отчество из области данных в заголовок группы код, измените расположение полей, шрифт, текст надписей.

Для изменения параметров элементов отчета необходимо щелкнуть на элементе правой кнопкой мыши и выбрать из появившегося меню пункт Свойства. На экране отобразится редактор свойств (рис. 4.8).



Рис. 4.8. Редактор свойств элемента отчета

На панели элементов (рис. 4.9) выберите элемент прямоугольник и с помощью мыши разместите прямоугольники в верхнем колонтитуле, заголовке группы и области данных таким образом, чтобы в результате отчет приобрел вид таблицы.



Рис. 4.9. Панель элементов отчета


Отчет который получился в результате модификации исходного в режиме Конструктора приведен на рис. 4.10. Сформированный отчет приведен на рис. 4.11.



Рис. 4.10. Отчет в режиме конструктора после модификации



Рис. 4.11. Отчет, полученный после доработки в режиме Конструктора


Содержание отчета

1. Цель работы

2. Описание процесса создания отчетов в режиме Мастера.

3. Описание процесса создания отчетов в режиме Конструктора.

4. Краткие выводы о навыках, приобретенных в ходе выполнения работы.

^ СПИСОК РЕКОМЕНДУЕМОЙ ЛИТЕРАТУРЫ

1. Дейт, К., Дж.. Введение в системы баз данных, 7-е издание.: Пер. с англ.– М.: Издательский дом «Вильямс», 2001. – 7012 с.: ил.

2. http://computerbooks.ru/books/Office/Book-Access-2002/

3. Бекаревич Ю.Б., Пушкина М.В. Самоучитель Microsoft Access 2003 – СПб., БХВ-Петербург, 2004. – 752 с.

ПРИЛОЖЕНИЕ 1.

Варианты описаний предметных областей

Ниже приведены словесные описания предметных областей, имеющих отношение к медицине. Предложенные описания сильно упрощены. В реальной жизни, описанные предметные области намного сложнее, содержат большое количество сущностей, атрибутов и связей между сущностями.

1. Клиническая лаборатория. Врачи дают пациентам направления на анализы. В клинической лаборатории лаборанты выполняют анализы и оформляют результаты на специальных бланках. Бланк содержит дату анализа, вид анализа, имя врача, давшего направление, имя пациента, имя лаборанта, наименования и значения измеренных параметров.

2. Аптека. Поставщики поставляют лекарства в аптеку. Товар сдается в аптеку по накладной. В накладной указана дата поставки, поставщик лекарства, наименования поставленных лекарств, их количество, оптовая цена и стоимость. При получении товара определяется розничная цена лекарства, по которой оно должно продаваться. Для управления аптекой важно знать, сколько каких лекарств есть на складе аптеки. При продаже лекарств оформляются чеки, содержащие дату продажи, наименование продаваемого лекарства, розничную цену, количество и стоимость.

3. Учет коечного фонда. В стационаре есть несколько отделений. В каждом отделении есть определенное количество мест (коек). Места расположены в различных палатах. В каждый определенный период времени койка может быть свободна или занята одним пациентом. При госпитализации пациента делается запись в журнале, содержащая дату и время госпитализации, имя пациента, диагноз, номер отделения, номер палаты, номер койки. При выписке в журнале делается запись, содержащая дату и время выписки, имя пациента, номер отделения, номер палаты, номер койки, причину выписки. При госпитализации больного необходимо знать, есть ли свободные места в нужном отделении в настоящий момент.

4. Расписание работы врачей в поликлинике. В поликлинике есть несколько отделений. В каждом отделении есть несколько кабинетов. В каждый определенный момент времени кабинет может быть свободен или в нем может идти прием одного врача. Расписание составляется по дням недели. Расписание может изменяться и необходимо хранить историю изменения расписания.

5. Медицинские карты пациентов. На каждого пациента поликлиники заведена медицинская карта. В медицинской карте содержатся имя, дата рождения, пол, адрес, профессия, место работы пациента. В медицинской карте фиксируются все обращения пациента. При обращении пациента в медицинской карте делается запись, содержащая дату обращения, имя врача, жалобы и результаты различных диагностических процедур, диагноз, назначенное лечение. Обращение может быть первичным, повторным. В записи о повторном обращении есть ссылка на первичное обращение.

6. Справочник лекарственных средств. Существует множество лекарственных средств. Каждое лекарственное средство имеет регистрационный номер, торговое название, международное название, лекарственную форму (таблетки, раствор и т.д.), состав, описание. Каждое лекарство принадлежит к определенной группе. Лекарство имеет показания к применению (список заболеваний). Лекарство имеет ряд противопоказаний. Лекарство имеет побочные эффекты. Лекарство может взаимодействовать с другими лекарствами с различными результатами. Лекарство выпускается рядом производителем, имеет срок годности. Должно храниться в определенных условиях.

7. Учет измерительных приборов. В медицинском учреждении имеется множество измерительных приборов. При вводе измерительного прибора в эксплуатацию составляется акт, в котором указывается дата ввода в эксплуатацию, место, где установлен прибор, сотрудник материально ответственный за сохранность прибора, тип, модель, балансовая стоимость, дата ввода в эксплуатацию. Различные модели приборов имеют различные сроки службы и должны поверяться с определенной периодичностью. Приборы периодически поверяются. При этом важно знать, когда поверялся каждый прибор, и какие приборы нуждаются в поверке. Прибор может быть списан. При списании прибора оформляется акт, в котором указывается дата и причина списания. Важно знать какие приборы в настоящее время эксплуатируются в медицинском учреждении. За какие приборы отвечает каждый сотрудник.


ЛР № 020275 от 13.11.96. Подписано в печать 20.10.01.

Формат 60х84/16. Бумага для множит. техники. Гарнитура Таймс.

Печать офсетная. Усл. печ. л. 1,16. Уч.-изд. л. 1,23. Тираж 100 экз.

Заказ

Владимирский государственный университет.

Подразделение оперативной полиграфии

Владимирского государственного университета.

Адрес университета и подразделения оперативной полиграфии:

600000, Владимир, ул. Горького, 87




Скачать 209,83 Kb.
оставить комментарий
Дата29.09.2011
Размер209,83 Kb.
ТипЛабораторная работа, Образовательные материалы
Добавить документ в свой блог или на сайт

Ваша оценка этого документа будет первой.
Ваша оценка:
Разместите кнопку на своём сайте или блоге:
rudocs.exdat.com

Загрузка...
База данных защищена авторским правом ©exdat 2000-2017
При копировании материала укажите ссылку
обратиться к администрации
Анализ
Справочники
Сценарии
Рефераты
Курсовые работы
Авторефераты
Программы
Методички
Документы
Понятия

опубликовать
Документы

наверх