Конспект лекций н. Новгород 2002 Министерство транспорта Российской федерации Государственное образовательное учреждение высшего профессионального образования icon

Конспект лекций н. Новгород 2002 Министерство транспорта Российской федерации Государственное образовательное учреждение высшего профессионального образования



Смотрите также:
Программа по дисциплине...
Программа по дисциплине...
Программа по дисциплине...
Программа по дисциплине...
Программа по дисциплине...
Программа по дисциплине...
Программа по дисциплине...
Программа по дисциплине...
Федеральное агентство морского и речного транспорта РФ федеральное государственное...
Федеральное агентство морского и речного транспорта РФ федеральное государственное...
Основная образовательная программа высшего профессионального образования Направление подготовки...
Рабочей программы учебной исциплины...



страницы: 1   2   3   4   5   6   7
вернуться в начало
скачать

Обозреватель Internet Explorer

Начало работы с обозревателем Internet Explorer


Подключившись к Интернету и используя Microsoft Internet Explorer вы можете найти и просмотреть любую информацию.

Если Internet Explorer был установлен на вашем компьютере сетевым администратором или вы установили программу, предоставленную поставщиком услуг Интернета, то вы уже готовы подключиться к Интернету. В противном случае установить соединение с Интернетом вам поможет мастер подключения к Интернету. Для этого вам будут необходимы следующие сведения, предоставляемые поставщиком услуг Интернета или сетевым администратором.

Для соединения с помощью поставщика услуг Интернета — ваше имя и пароль доступа.

Для соединения по локальной сети — имя вашего прокси-сервера и номер порта. Кроме того, ваш сетевой администратор может предоставить вам специальные настройки для использования вашего обозревателя в корпоративной сети.

Когда у вас все установлено, посмотрите, что вы можете делать в Интернете. А можете вы все: от просмотра и поиска, до подписки на каналы. Internet Explorer — это не только лучший, но и самый простой обозреватель.

Установка соединения с Интернетом.


  1. В меню «Вид» обозревателя укажите на Свойства обозревателя.

  2. Выберите вкладку Подключение и щелкните Подключение.

  3. Следуйте инструкциям, появляющимся на экране.


Настройка Microsoft Internet Explorer для использования в корпоративных сетях и для внутренней сети (интранет)

Специальные возможности Internet Explorer для внутренних сетей используются многими организациями. Настройка настолько проста, что сводится к указанию прокси-сервера для обеспечения доступа к Интернету. Прокси-сервер действует в качестве защитного барьера между внутренней сетью и Интернетом, не позволяя другим пользователям Интернета получить доступ к конфиденциальным сведениям внутренней сети.

Допускается использование автоматической настройки через файл, созданный системным администратором. Файл может включать в себя как параметры работы обозревателя Internet Explorer, например, адрес начальной страницы, так и настройки прокси-сервера.

Настройка компьютера при использовании прокси-сервера для доступа в Интернет


  1. Получите адрес прокси-сервера от вашего системного администратора.

  2. В меню «Вид» обозревателя выберите Свойства обозревателя.

  3. Выберите вкладку «Подключение».

  4. В поле Прокси-сервер, установите флажок Подключаться к Интернету через прокси-сервер.

  5. Выберите Дополнительно и введите адрес или адреса соответствующих прокси-серверов.

Автоматическая настройка Internet Explorer на компьютере предприятия.


  1. В меню «Вид» обозревателя выберите Свойства обозревателя.

  2. Выберите вкладку «Подключение».

  3. В группе «Автоматическая настройка» щелкните кнопку «Настроить».

  4. В строке Адрес (URL) напечатайте адрес или файл, предоставленный вашим сетевым администратором для автоматической настройки Internet Explorer.

  5. Если вы хотите использовать параметры настройки сразу, щелкните «Обновить».

Путешествие по сети.

Посещение Web-узлов. Просмотр Web-страниц.


Существует несколько способов перехода с одной активной страницы на другие. Предусмотрена также возможность поиска страницы при отсутствии точного адреса или ссылки.

В адресной строке укажите адрес страницы, на которую хотите перейти, или, щелкнув стрелку вниз, выберите его из списка и нажмите ENTER.

  • Для отображения страницы в новом окне, прежде чем ввести ее адрес, в меню Файл щелкните Создать и выберите Окно.

  • Щелкните любую ссылку на вашей основной странице. Ссылкой может быть картинка, объемное изображение или цветной текст, который обычно подчеркивается.

  • Для перехода на предыдущую страницу, нажмите на панели инструментов кнопку Назад. Можно вернуться назад сразу на несколько страниц, нажав небольшую стрелку рядом с этой кнопкой и выбрав в открывшемся списке необходимую страницу.

  • Для перехода на страницу вперед (если вы ее уже смотрели) нажмите на панели инструментов кнопку Вперед. Можно перейти вперед сразу на несколько страниц, нажав небольшую стрелку рядом с этой кнопкой и выбрав в открывшемся списке необходимую страницу.

Совет: другой способ открыть страницу — это в меню Файл выбрать Открыть и в появившемся диалоговом окне указать адрес страницы.

Просмотр Web-страниц, написанных на других языках


Некоторые Web-узлы предоставляют данные на других языках. Чтобы иметь возможность просмотра таких данных, вы можете добавить другие языки в ваш список языков в Internet Explorer. Для этого выполните следующее.

  1. В меню «Вид» обозревателя выберите Свойства обозревателя.

  2. На вкладке «Общие» щелкните кнопку «Языки».

  3. Щелкните «Добавить».

  4. Выберите язык, который хотите добавить.

Повторное посещение недавно просмотренной Web-страницы. Просмотр часто посещаемых страниц.


  1. На панели инструментов нажмите кнопку Журнал.

  2. Появится список папок, содержащих ссылки на недавно просмотренные страницы.

  3. Чтобы просмотреть какую-либо страницу, выберите ее из этого списка.

Чтобы задать число дней, в течение которых страницы будут храниться в журнале и как определить количество сохраняемых страниц в дневнике:

  1. В меню «Вид» обозревателя выберите Свойства обозревателя.

  2. Выберите «Общие».

  3. В поле «Журнал» измените количество дней хранения ссылок.

Совет: чтобы очистить папку «Журнал» щелкните кнопку «Стереть». Это освободит место на вашем жестком диске.

Просмотр избранного Web-узла. Посещение избранных узлов


  1. На панели инструментов нажмите кнопку Избранное.

  2. Для просмотра необходимой страницы выберите на панели обозревателя соответствующую папку или ссылку.

Добавление страницы в папку «Избранное»


  1. Перейдите на страницу, которую нужно добавить в папку «Избранное».

  2. В меню Избранное выберите пункт Добавить в «Избранное».

  3. Укажите название для данной страницы.

Сохранение информации, получаемой с Web-страниц


По мере просмотра Web-страниц вам будет встречаться информация, которую вы захотите сохранить, чтобы в дальнейшем иметь возможность обращаться к ней без подключения к соответствующему узлу. Можно сохранить страницу как полностью, так и частично — текст, изображения или ссылки. Сохраненную информацию вы сможете использовать в своих документах, а изображения — в качестве фонового рисунка. Можно отправлять по электронной почте страницы или ссылки на них другим пользователям, имеющим доступ к Web, а для тех, кто не имеет к ней доступа или даже компьютера, страницы можно распечатать.

Сохранение активной страницы на вашем компьютере


  1. В меню Файл выберите Сохранить как.

  2. Дважды щелкните папку, в которую хотите поместить страницу.

  3. В строке Имя файла укажите название страницы и щелкните Сохранить.

Сохранение страницы или изображения, не открывая их для просмотра


  1. Щелкните правой кнопкой мыши ссылку на сохраняемый элемент.

  2. Выберите Сохранить объект как.

  3. В строке Имя файла укажите имя, под которым вы хотите сохранить данное содержимое, и щелкните Сохранить.

Копирование информации со страницы в документ


  1. Выделите информацию, которую хотите скопировать.

  2. Чтобы скопировать всю страницу, в меню Правка выберите Выделить все.

  3. Затем в меню Правка выберите Копировать.

  4. Перейдите в документ, в который необходимо вставить скопированный текст, и установите курсор в место вставки.

  5. В меню Правка этого документа выберите пункт Вставить.

Примечание

  • Невозможно скопировать информацию с одной Web-страницы на другую.

Отображение исходного файла HTML для текущей страницы


  • В меню Вид выберите В виде HTML.


Совет: если вы сами создаете Web-страницы, то это замечательный способ ознакомиться с технологией создания других страниц. Страницу можно сохранить на диске вашего компьютера, а затем отредактировать по своему вкусу. После внесения изменений загрузите ее в Internet Explorer и посмотрите, что получилось в результате.

Использование изображения из Web-страницы в качестве фонового для рабочего стола


  • Щелкните правой кнопкой мыши изображение на Web-странице и выберите Сделать рисунком рабочего стола.

Пересылка страниц по электронной почте


  1. Перейдите на отправляемую страницу.

  2. В меню Файл укажите пункт Отправить и выберите Ссылку по почте или Эту страницу по почте.

  3. Введите адрес места назначения и нажмите кнопку Отправить на панели инструментов.

Поиск в сети.

Поиск в Web


Существует несколько способов поиска информации в Web. Если нажать кнопку Поиск в левой части окна панели инструментов, появится панель обозревателя. С ее помощью вы сможете получить доступ к многочисленным информационно-поисковым службам, предоставляющим различные возможности поиска. Чтобы понять их специфику, попробуйте воспользоваться некоторыми из них.

Для быстрого поиска текста удобно применить «автопоиск». Введите в адресную строку команды go, find или ? и далее через пробел — слово или фразу. Этот вид поиска осуществляется заранее определенной поисковой службой.

Переключившись на страницу, полученную в результате поиска, вы обнаружите на ней искомый текст.

Для получения дополнительных сведений о возможностях поиска см. следующие разделы.

Поиск в Интернете


  1. На панели инструментов выберите Поиск.

  2. В появившейся строке укажите слово или фразу для поиска и щелкните Найти.

  3. В списке полученных результатов щелкните необходимую ссылку, чтобы соответствующая страница отобразилась в правой части окна обозревателя.

Примечание

  • Чтобы скрыть панель обозревателя, на панели инструментов еще раз нажмите кнопку Поиск.

Поиск в Интернете с помощью адресной строки


  1. В адресную строку введите команды go, find или ? и через пробел — слово или выражение для поиска.

  2. Из списка найденных страниц выберите необходимую.

Поиск текста на активной странице


  1. В меню Правка выберите пункт Найти на этой странице.

  2. Введите текст, который вы хотите найти.

  3. Задайте условия поиска.

  4. Нажмите кнопку Поиск далее.

Поиск узла в случае неверно заданного адреса


Если в адресной строке или на странице неверно задан адрес, вы получите сообщение о том, что узел не найден, также по этому вопросу имеется справка. В Internet Explorer предусмотрена возможность автоматического поиска ряда подобных адресов. Например, если вы ввели panorama, то Internet Explorer попробует найти Web-узел с названием www.panorama.com. Если такой узел не будет найден, то будет произведен поиск адресов, имеющих подобный вид или частично совпадающий с этим именем.

  1. В меню Вид выберите пункт Свойства обозревателя.

  2. Перейдите на вкладку Дополнительно.

  3. Затем в группе Поиск при неправильном адресе Интернет (URL) выберите Никогда. Или выполните одно из следующих действий:

  • Чтобы каждый раз при нахождении неверного адреса задавался вопрос, продолжать ли поиск, выберите Всегда спрашивать.

  • Чтобы дальнейший поиск осуществлялся без предупреждений, выберите Всегда искать.

  • Если вы хотите, чтобы при поиске варьировались адресные суффиксы, установите флажок Автоматический поиск корневых доменов.

Получение избранной информации.


Microsoft Internet Explorer предоставляет новые возможности просмотра данных в сети. С их помощью вы сможете настроить Internet Explorer для получения обновлений ваших любимых Web-узлов по заданному вами графику. Вы также можете выбрать уведомление об обновлениях или получение обновлений автоматически на ваш жесткий диск (например, ночью или когда компьютер не занят), и просматривать полученные страницы в ваше свободное время. Данный процесс называется «подпиской на Web-узел». Подписка не обязательно означает выплату денег поставщику услуг.

Вы можете установить ежедневную, еженедельную или ежемесячную проверку обновлений на всех или на одном из узлов.

Настроив систему подписки, вы сможете просматривать ваши любимые Web-узлы в режиме автономной работы.

Подписка на Web-узел


  1. Откройте Web-страницу, на которую вы хотите подписаться.

  2. В меню «Избранное» выберите Добавить в «Избранное».

  3. Щелкните Да, но лишь уведомлять об обновлениях страницы или Да, уведомлять об обновлениях и доставлять страницу для автономного просмотра.

  4. Если вы хотите настроить доставку и уведомление, выберите Настройка для запуска мастера подписки на Web-узлы.

Изменение настройки подписки


  1. В меню «Избранное» выберите «Управление подпиской».

  2. Щелкните правой кнопкой мыши подписку, которую хотите обновить, и выберите «Свойства».

  3. Задайте необходимые параметры получения и расписание подписки.

Каналы


Каналы — это другая форма подписки. Каналы — это Web-узлы, которые автоматически обновляются на вашем компьютере согласно графику, определенному вашим поставщиком услуг. Каналы можно просматривать в обозревателе, как и любые другие Web-страницы, в окне на весь экран или на рабочем столе. Некоторые каналы разработаны для использования в качестве экранной заставки.

Итак, канал — это Web-узел, предназначенный для доставки содержимого Интернета на ваш компьютер, схожий с подпиской на избранный Web-узел. Вы не должны подписываться на канал для просмотра его содержимого, но с помощью каналов поставщик услуг может предложить вам расписание вашей подписки, или вы можете настроить свое собственное. Также, с каналом вы видите не просто Web-страницу, а большую карту всего Web-узла, которая позволяет быстро выбрать и просмотреть нужные вам данные.

Работа каналов


  • Воспользуйтесь «Путеводителем по каналам» на вашем рабочем столе или в обозревателе для просмотра списка каналов, доступных через Web-узел Microsoft. Этот список регулярно пополняется свежими предложениями от новых и уже существующих поставщиков. В дополнение к путеводителю, поставщики могут также обеспечить доступ к каналам напрямую с их Web-узлов.

  • Добавьте каналы на вашу панель каналов. В ходе добавления канала, вы также можете на него подписаться, но это не обязательно.

  • Систематизируйте свои каналы теми же способами, что и избранные Web-страницы или любые другие папки. Панель каналов отображает все установленные на вашем компьютере каналы в не зависимости от того, подписаны вы на них или нет.

  • Просмотрите канал щелкнув его на панели каналов.

  • Просматривайте каналы так, как вы хотите — в обозревателе, в полном окне, как элемент рабочего стола, или как вашу экранную заставку.

Добавление канала.


  1. На панели инструментов щелкните кнопку «Каналы».

  2. На панели обозревателя щелкните «Путеводитель по каналам».

  3. Следуйте указаниям, которые будут появляться на экране.

Подписка на канал.


  1. На панели инструментов нажмите кнопку «Каналы».

  2. На панели обозревателя щелкните «Путеводитель по каналам» и следуйте указаниям, появляющимся на экране.

Панель обозревателя


Панель обозревателя позволяет одновременно просматривать список ссылок, таких как «Журнал» или каналы, и отображать страницы, открываемые по этим ссылкам, в правой части окна обозревателя. Например, если вы щелкните кнопку «Поиск» на панели инструментов, то панель обозревателя откроется, и вы сможете ее использовать для поиска нужного вам Web-узла.

Вы можете просматривать папку «Избранное», «Журнал», каналы, или поиск, выбирая соответствующий элемент на панели инструментов. Также вы можете добраться до этих элементов выбрав «Панель обозревателя» в меню «Вид».

Перечисленные ниже разделы описывают возможности использования панели обозревателя.

Просмотр каналов в обозревателе.


  1. На панели инструментов щелкните кнопку «Каналы».

  2. На панели обозревателя выберите канал или раздел, например, «Деловые решения», который вы хотите просмотреть.

Отображение канала на рабочем столе.


  1. Щелкните правой кнопкой мыши на рабочем столе и выберите «Свойства».

  2. Выберите вкладку «Web» и щелкните «Добавить».

  3. Если вы хотите открыть Web-узел «Коллекция элементов рабочего стола» и выбрать канал оттуда, то нажмите кнопку «Да». Если вы выбрали «Да», то это диалоговое окно закроется.

  4. Если вы хотите выбрать какой-либо другой канал, то нажмите кнопку «Нет».

  5. Введите адрес канала или нажмите кнопку «Обзор» для поиска канала.

Отображение панели каналов на рабочем столе


Используя панель каналов, можно получить доступ к узлам Web прямо с рабочего стола, не открывая обозреватель. Панель каналов можно отобразить на рабочем столе после установки обозревателя в двух вариантах: с обновленным рабочим столом и без него.

Если установлен только обозреватель

  • Нажмите кнопку Пуск, выберите команду Программы, затем Internet Explorer и щелкните Панель каналов.

Если вместе с обозревателем установлен новый рабочий стол

  1. Нажмите кнопку Пуск, выберите команду Программы, затем Active Desktop и щелкните Настроить рабочий стол.

  2. На вкладке Web установите флажок Представить Active Desktop как страницу Web.

  3. Установите флажок Панель каналов Internet Explorer.


Печать Web-страниц


Web-страницу можно распечатать в том виде, в котором она отображается на экране, или только отдельные ее фрагменты, например, кадры. Кроме того, можно включить в распечатку такие дополнительные сведения, как заголовок окна, адрес страницы, ее номер, дату и время.

Печать содержимого активного окна


  1. В меню Файл выберите Печать.

  2. Настройте параметры печати по своему усмотрению.

Печать кадра


  1. Щелкните в кадре правой кнопкой мыши.

  2. Выберите в меню Файл команду Печать.

  3. Настройте параметры печати по своему усмотрению.

Настройка параметров для печати страницы


  1. В меню Файл выберите Свойства обозревателя страницы.

  2. В группе Поля укажите размеры полей.

  3. Выберите один из способов размещения страницы в группе Ориентация. Для вертикального размещения страницы щелкните Книжная, для горизонтального — Альбомная.

  4. В группе Колонтитулы. В поля Верхний колонтитул и Нижний колонтитул введите текст колонтитулов, при необходимости, включив в него следующие символы.

  • Заголовок окна -- &w;

  • Адрес страницы (URL) -- &u;

  • Дата в кратком формате (как это задано в окне «Язык и стандарты» панели управления) -- &d;

  • Дата в полном формате (как это задано в окне «Язык и стандарты» панели управления) -- &D;

  • Время в формате, заданном в окне «Язык и стандарты» панели управления -- &t;

  • Время в 24-х часовом формате -- &T;

  • Текущий номер страницы -- &p;

  • Полное число страниц -- &P;

  • Центрированный текст, следующий сразу за указанными символами -- &b;

  • После первого символа «&b» — центрированный текст, после второго «&b» — выровненный по правому полю -- &b&b;

  • Одиночный амперсанд (&) -- &&.

Примечание

  • Чтобы изменить единицы измерения размеров полей, используйте настройки, выбрав на панели управления «Языки и стандарты».

Создание WEB – страниц прикладными программами


Для создания WEB – страниц можно использовать прикладные программы (например, Microsoft Office, Front Page Express, Visual Foxpro), а также простейшие текстовые документы и язык гипертекстовой разметки HTML.

Создание WEB – страниц средствами Microsoft Office


В трех основных приложениях Office технология создания собственных страниц Интернета отличается незначительно. Сложность этой технологии сопоставима со сложностью трюков, показываемых дрессированными приматами в цирковых представлениях.

Во – первых, надо в соответствующем приложении создать документ, наполнив его нужной информацией, как то – текстом, заголовками, рисунками, таблицами и т.п.

Затем (для приложений WORD и EXCEL) в меню ФАЙЛ выполнить команду СОХРАНИТЬ КАК. После чего в диалоговом окне СОХРАНЕНИЕ ДОКУМЕНТА определить тип файла, как WEB-страница, ввести имя будущей страницы и щелкнуть сохранить.

В программе Power Point в меню ФАЙЛ выполнить команду СОХРАНИТЬ КАК WEB-страницу. После чего в диалоговом окне СОХРАНЕНИЕ ДОКУМЕНТА ввести имя будущей страницы и щелкнуть сохранить.

Как видим, процесс несложный и доступный, даже для поколения next.

Создание WEB-страниц в Visual Foxpro


В этом приложении имеется мастер WEB Publishing, позволяющий формировать Web – страницы на основе баз данных. Технология немного сложнее, чем вышеизложенные, но все же для ее освоения достаточно очень среднего образования. Итак, выполните следующие действия в среде Visual Foxpro:

  1. Открыть базу данных проекта, содержащую таблицу, локальное или удаленное представление, информацию из которого надо разместить на Web- странице.

  2. В меню Tools выбрать команду Wizards. Затем опцию WEB Publishing.

  3. На первом шаге Мастера (Wizard) выбрать таблицу, а затем и поля, которые вы хотите расположить на Web- странице.

  4. На втором шаге задайте критерий сортировки данных (имя поля по котрому информация будет упорядочена).

  5. На третьем шаге определите каковы будут макет и стиль отображения Web-страницы. На этом же шаги кнопки Options и Advanced позволяют настроить параметры страницы и разместить на ней дополнительные элементы. Кнопка Preview служит для просмотра результата.

  6. На заключительном шаге надо выбрать вариант дальнейших действий со страницей. Здесь же можно, установив соответствующий флажок (Save Style), сохранить в файле стиль, определенный при создании страницы.

  7. Щелкнуть Finish(Готово) и сохранить файл на диске.

Для редактирования созданной страницы нужно в меню File выбрать команду Open, в списке Тип файлов указать: HTM. После чего выбрать необходимый файл и нажать ОК. Для грамотного редактирования страницы желательно знание языка гипертекстовой разметки документов HTML, рассмотрению которого и посвящены следующие разделы данного пособия.

Создание WEB-страниц на языке HTML


Для создания WEB-страниц на языке HTML, пусть даже с использованием языка сценариев, о котором речь пойдет ниже, настоятельно рекомендуется применять простейшие текстовые редакторы Windows, лучше всего – Блокнот. WEB-страницы следует сохранять в документах с расширением HTM(HTML). В Блокноте для этого надо при сохранении документа выбрать тип файла –Все файлы. Затем при вводе имени страницы указать после основного названия расширение HTM, отделив его точкой. Например, «first.htm»(для особо понятливых уточним, что кавычки набирать не надо). HTML – документы должны иметь особую структуру, которая будет описана ниже.

Структура HTML-документа.


HTML-документ – это текстовый файл в кодах ASCII, содержащий специальные коды разметки. Для создания его можно пользоваться любыми текстовыми редакторами.

Пример:

Simple page

Здравствуй, мир HTML!

Назовем документ Hello.html и запишем в папку «C:\Мои документы».

Возможно, что при открытии документа в рабочей области просмотра отобразится нечто вроде:

Здравствуй, мир HTML!

Тогда в документ нужно записать информацию о его кодировке:

Простейший документ



Здравствуй, мир HTML!

^ Основные части HTML-документа.
Описание типа документа

- Начало HTML-документа

- Заголовок

Содержимое заголовка

- Конец заголовка

- Начало тела

Содержимое тела

- Конец тела

- Конец HTML- документа

Введение в гиперссылки.

В Сети находится несчетное число документов, которые могут быть связаны между собой при помощи гиперссылок

Пример с гиперссылкой на первый пример:





<br /> <br /> Ссылка на документ по абсолютному адресу<br /> <br />





Щелчок мышью приведет к просмотру документа Hello.htm





оставить комментарий
страница7/7
Дата02.10.2011
Размер1,32 Mb.
ТипКонспект, Образовательные материалы
Добавить документ в свой блог или на сайт

страницы: 1   2   3   4   5   6   7
Ваша оценка этого документа будет первой.
Ваша оценка:
Разместите кнопку на своём сайте или блоге:
rudocs.exdat.com

Загрузка...
База данных защищена авторским правом ©exdat 2000-2017
При копировании материала укажите ссылку
обратиться к администрации
Анализ
Справочники
Сценарии
Рефераты
Курсовые работы
Авторефераты
Программы
Методички
Документы
Понятия

опубликовать
Документы

наверх