Лабораторная работа №5. Динамическая маршрутизация icon

Лабораторная работа №5. Динамическая маршрутизация


2 чел. помогло.
Смотрите также:
Изучение макрокоманд программы ms excel с выполнением контр...
Лабораторная работа №1...
«Интернет телефония. Протокол H. 323»...
«Интернет телефония. Протокол H. 323»...
Лабораторная работа №1. «Диоды в источниках питания»...
Лабораторная работа №1...
Лабораторная работа №4...
Лабораторная работа 9...
Лабораторная работа № топографические карты...
Лабораторная работа №1...
Контрольная работа Лабораторная работа №1 «Дольменная культура» Лабораторная работа №2 «Генуэзцы...
Лабораторная работа №1...



Загрузка...
скачать

Лабораторная работа №5. Динамическая маршрутизация


Теоретическая часть

Статическая маршрутизация не подходит для больших, сложных сетей потому, что обычно сети включают избыточные связи, многие протоколы и смешанные топологии. Маршрутизаторы в сложных сетях должны быстро адаптироваться к изменениям топологии и выбирать лучший маршрут из многих.

IP – сети имеют иерархическую структуру. С точки зрения маршрутизации сеть рассматривается как совокупность автономных систем. В автономных подсистемах больших сетей для маршрутизации на остальные автономные системы широко используются маршруты по умолчанию.

Динамическая маршрутизация может быть осуществлена с использованием одного и более протоколов. Эти протоколы часто группируются согласно того, где они используются. Протоколы для работы внутри автономных систем называют внутренними протоколами шлюзов (interior gateway protocols (IGP)), а протоколы для работы между автономными системами называют внешними протоколами шлюзов (exterior gateway protocols (EGP)). К протоколам IGP относятся RIP, RIP v2, IGRP, EIGRP, OSPF и IS-IS. Протоколы EGP3 и BGP4 относятся к EGP. Все эти протоколы могут быть разделены на два класса: дистанционно-векторные протоколы и протоколы состояния связи.

Маршрутизаторы используют метрики для оценки или измерения маршрутов. Когда от маршрутизатора к сети назначения существует много маршрутов, и все используют один протокол маршрутизации, то маршрут с наименьшей метрикой рассматривается как лучший. Если используются разные протоколы маршрутизации, то для выбора маршрута используется административные расстояния, которые назначаются маршрутам операционной системой маршрутизатора.

RIP использует в качестве метрики количество переходов (хопов). EIGRP использует сложную комбинацию факторов, включающую полосу пропускания канала и его надёжность.

Результаты работы маршрутизирующих протоколов заносятся в таблицу маршрутов, которая постоянно изменяется при смене ситуации в сети. Рассмотрим типичную строку в таблице маршрутов, относящуюся к динамической маршрутизации

R 192.168.14.0/24 [120/3] via 10.3.0.1 00:00:06 Serial0

R определяет протокол маршрутизации. R означает RIP, а O – OSPF и т.д. Запись [120/3] означает, маршрут имеет административное расстояние 120 и метрику 3. Эти числа маршрутизатор использует для выбора маршрута. Элемент 00:00:06 определяет время, когда обновилась строка. Serial0 это локальный интерфейс, через который маршрутизатор будет направлять пакеты к сети 192.168.14.0/24 через адрес 10.3.0.1.

Чтобы динамические протоколы маршрутизации обменивались информацией о статических маршрутах, следует осуществлять дополнительное конфигурирование.

Дистанционно-векторная маршрутизация

Базируется на алгоритме Белмана-Форда. Через определённые моменты времени маршрутизатор передаёт соседним маршрутизаторам всю свою таблицу маршрутизации. Такие простые протоколы как RIP и IGRP просто распространяют информацию о таблицах маршрутов через все интерфейсы маршрутизатора в широковещательном режиме без уточнения точного адреса конкретного соседнего маршрутизатора.

Соседний маршрутизатор, получая широковещание, сравнивает информацию со своей таблицей маршрутов. В неё добавляются маршруты к новым сетям или маршруты к известным сетям с лучшей метрикой. Происходит удаление несуществующих маршрутов. Маршрутизатор добавляет свои собственные значения к метрикам полученных маршрутов. Новая таблица маршрутизации снова распространяется по соседним маршрутизаторам (рис.1).



Рис.1. Дистанционно-векторная маршрутизация.

^ Протоколы состояния связи

Эти протоколы предлагают лучшую масштабируемость и сходимость по сравнению с дистанционно-векторными протоколами. Протокол базируется на алгоритме Дейкстры, который часто называют алгоритмом «кратчайший путь – первым» (shortest path first (SPF)). Наиболее типичным представителем является протокол OSPF (Open Shortest Path First).

Маршрутизатор берёт в рассмотрение состояние связи интерфейсов других маршрутизаторов в сети. Маршрутизатор строит полную базу данных всех состояний связи в своей области, то есть имеет достаточно информации для создания своего отображения сети. Каждый маршрутизатор затем самостоятельно выполняет SPF-алгоритм на своём собственном отображении сети или базе данных состояний связи для определения лучшего пути, который заносится в таблицу маршрутов. Эти пути к другим сетям формируют дерево с вершиной в виде локального маршрутизатора.

Маршрутизаторы извещают о состоянии своих связей всем маршрутизаторам в области. Такое извещение называют LSA (link-state advertisements).

В отличие от дистанционно-векторных маршрутизаторов, маршрутизаторы состояния связи могут формировать специальные отношения со своими соседями.

Имеет место начальный наплыв LSA пакетов для построения базы данных состояний связи. Далее обновление маршрутов производится только при смене состояний связи или, если состояние не изменилось в течение определённого интервала времени. Если состояние связи изменилось, то частичное обновление пересылается немедленно. Оно содержит только состояния связей, которые изменились, а не всю таблицу маршрутов.

Администратор, заботящийся об использовании линий связи, находит эти частичные и редкие обновления эффективной альтернативой дистанционно-векторной маршрутизации, которая передаёт всю таблицу маршрутов через регулярные промежутки времени.

Протоколы состояния связи имеют более быструю сходимость и лучшее использование полосы пропускания по сравнению с дистанционно-векторными протоколами. Они превосходят дистанционно-векторные протоколы для сетей любых размеров, однако имеют два главных недостатка: повышенные требования к вычислительной мощности маршрутизаторов и сложное администрирование.

Сходимость.

Этот процесс одновременно и совместный, и индивидуальный. Маршрутизаторы разделяют между собой информацию, но самостоятельно пересчитывают свои таблицы маршрутизации. Для того чтобы индивидуальные таблицы маршрутизации были точными, все маршрутизаторы должны иметь одинаковое представление о топологии сети. Если маршрутизаторы договорились о топологии сети, то имеет место их сходимость. Быстрая сходимость означает быстрое восстановление после обрыва связей и других изменений в сети. О протоколах маршрутизации и о качестве проектирования сети судят главным образом по сходимости.

Когда маршрутизаторы находятся в процессе сходимости, сеть восприимчива к проблемам маршрутизации. Если некоторые маршрутизаторы определили, что некоторая связь отсутствует, то другие ошибочно считают эту связь присутствующей. Если это случится, то отдельная таблица маршрутов будет противоречива, что может привести к отбрасыванию пакетов и петлям маршрутизации.

Невозможно, чтобы все маршрутизаторы в сети одновременно обнаружили изменения в топологии. В зависимости от использованного протокола, может пройти много времени пока все процессы маршрутизации в сети сойдутся. На это влияют следующие факторы:

Расстояние в хопах до точки изменения топологии.

Число маршрутизаторов, использующих динамические протоколы.

Полоса пропускания и загрузка каналов связи.

Загрузка маршрутизаторов .

Эффект некоторых факторов может быть уменьшен при тщательном проектировании сети.

^ Конфигурирование динамической маршрутизации

Для конфигурирования динамической маршрутизации используются две основные команды: router і network. Команда router запускает процесс маршрутизации и имеет форму:

Router(config)# router protocol [keyword]

где Protocol - любой из протоколов маршрутизации: RIP, IGRP, OSPF и т.п., keyword –дополнительные параметры.

Затем необходимы команды network:

Router ( config-router)# network network-number [keyword]

где network-number идентифицирует непосредственно подключенную сеть, добавляемую в процесс маршрутизации, keyword –дополнительные параметры. network-number позволяет процессу маршрутизации определить интерфейсы, которые будут брать участие в отсылке и приёме пакетов актуализации маршрутной информации.

Для просмотра информации о протоколах маршрутизации используется команда show ip protocol., которая выводит значения таймеров процессов маршрутизации и сетевую информацию, имеющую отношение к маршрутизации. Эта информация может использоваться для идентификации маршрутизатора, подозреваемого в поставке плохой маршрутной информации

Содержимое таблицы IP маршрутизации выводится командой show ip route. Она содержит записи про все известные маршрутизатору сети и подсети и указывает на способ получения этой информации.

Протокол RIP

Ключевые характеристики протокола RIP:

  • маршрутизация на основании вектора расстояния;

  • метрика при выборе пути в виде количества переходов (хопов);

  • максимально допустимое количества хопов - 15;

  • по умолчанию пакеты актуализации маршрутной информации посылаются в режиме широковещания каждые 30 секунд.

Выбор протокола RIP як протокола маршрутизации осуществляется командой:

Router(config)# router rip

Команда network назначает IP адрес сети с которой маршрутизатор имеет непосредственное соединение.

Router(config-router)# network network-number

Процесс маршрутизации связывает интерфейсы с соответствующими адресами и начинает обработку пакетов в заданных сетях.

В примере (рис.2) команды network 1.0.0.0 и network 2.0.0.0 задают непосредственно подключенные к маршрутизатора Cisco А сети.



Рис.2.

Команда debug ip rip выводит содержание пакетов актуализации маршрутной информации протокола RIP в том виде, в котором эти данные посылаются и принимаются.

^ Протокол IGRP

IGRP представляет собою протокол маршрутизации по вектору расстояния разработанный компанией Cisco. Этот протокол посылает пакеты актуализации маршрутной информации с 90-секундным интервалом, в которых содержатся сведения о сетях для конкретной автономной системы. Этот протокол характеризует универсальность, позволяющую автоматически справляться со сложными топологиями, и гибкость в работе с сегментами, имеющими разные характеристики по полосе пропускания и величины задержки. Используемая им метрика не имеет свойственных протоколу RIP ограничений по количеству переходов. Она включает следующие составляющие: Ширина полосы пропускания; Величина задержки; Уровень загрузки; Надёжность канала; Размер максимального блока передачи в канале.

Выбор протоколу IGRP в качестве протокола маршрутизации осуществляется с помощью команды:

Router (config)# router igrp autonomous-system

где параметр Autonomous-system называют номером автономной системы и он идентифицирует вычислительный процесс IGRP- маршрутизации. Процессы в маршрутизаторах сети с одинаковым номером autonomous-system будут коллективно использовать маршрутную информацию.

Команда network задаёт непосредственно присоединённые сети, которые подлежат включению в данный процесс маршрутизации:

Router( config-router)#network network-number

В показанном примере на рис.3 на маршрутизаторе Cisco A запущен маршрутизирующий процесс, организующий IGRP маршрутизацию в автономной системе с номером 109. В маршрутизции будут участвовать сети 1.0.0.0 и 2.0.0.0.



Рис.3.

Команда debug ip igrp transactions и debug ip igrp events выводят содержание пакетов актуализации маршрутной информации протокола IGRP в том виде, в котором эти данные посылаются и принимаются

^ Протокол OSPF

OSPF это динамический, иерархический протокол состояния связи, используемый для маршрутизации внутри автономных систем. Он базируется на открытых стандартах и был спроектирован как замена протоколу RIP. Он является развитием ранних версий протокола маршрутизации IS-IS. OSPF - устойчивый протокол, поддерживающий маршрутизацию с наименьшим весом и балансировку загрузки. Кратчайший путь в сети вычисляется по алгоритму Дейкстры. Cisco поддерживает свою версию стандарта OSPF.

Как только маршрутизатор настроен на работу с OSPF, он начинает процесс изучения окружения, проходя несколько фаз инициализации. В начале маршрутизатор использует Hello для определения своих соседей и создания отношений для обмена обновлением маршрутной информацией с ними. Затем маршрутизатор начинает фазу ExStart начального обмена между базами маршрутов. Следующей является фаза обмена, в которой назначеный маршрутизатор отсылает маршрутную информацию и получает подтверждения от нашего нового маршрутизатора. В течение стадии загрузки, новый маршрутизатор компилирует таблицу маршрутов. По окончании вычислений маршрутизатор переходит в полное состояние, в котором он является активным членом сети.

Для запуска OSPF маршрутизации служит команда

Router(config)#router ospf N,

где N-номер вычислительного процесса OSPF. В отличие от IGRP он может быть различным для разных маршрутизаторов автономной системы. OSPF область Area организуется командой

Router(config-router)# network network-number area Area

и определяет автономную систему.

В OSPF network-number имеет особый формат. Для подключаемой в процесс маршрутизации сети используетя инверсная маска. Так, чтобы сеть 212.34.0.0 255.255.0.0 поместить в область 7 OSPF маршрутизации следует дать команду

Router(config-router)# network 212.34.0.0 0.0.255.255 area 7

Команда show ip ospf interface для каждого интерфейса выводит всю OSPF информацию: IP адрес, область, номер процесса, идентификатор маршрутизатора, стоимость, приоритет, тип сети, интервалы таймера.

Команда show ip ospf neighbor показывает важную информацию, касающуюся состояния соседей.

Практическая часть

  1. Загрузите в симулятор топологию и конфигурацию, использованную практической части лабораторной работы №2.

  2. Если сделано всё правильно вы сможете пропинговать из любого маршрутизаторы адреса непосредственно соединённых интерфейсов других маршрутизаторов. На каждом устройстве, используя команды CDP show cdp neighbors detail, получите IP адреса соседних устройств и пропингуйте их.

  3. В лабораторной работе №2 мы не смогли пинговать дальние интерфейсы. Из Router2 была недоступна сеть 172.16.10.0/24, а из Router4 была недоступна сеть 10.1.1.0/24. В лабораторной работе №3 с помощью статической маршрутизации мы решили проблему. В этой работе для решения проблемы используем разные формы динамической маршрутизации.



Рисунок 4.

  1. Посмотрим таблицы маршрутов

Router2# sh ip route

Нет маршрута на сеть 172.16.10.0/24.

Поэтому в эту сеть из Router2 не идут пинги.

Router4# sh ip route

Нет маршрута на сеть 10.1.1.0/24.

Поэтому в эту сеть из Router4 не идут пинги.

RIP

1. Включим RIP на всех маршрутизаторах

Router1(config)# router rip

Router1(config-router)# network 172.16.10.0

Router1(config-router)# network 10.1.1.0

Router2(config)# router rip

Router2 (config-router)# network 10.1.1.0

Router4(config)# router rip

Router4 (config-router)# network 172.16.10.0

2. На каждом роутере командой show running-config посмотрим как маршрутизаторы поняли наши команды. Видим, что сеть 10.1.1.0/24 воспринята как сеть 10.0.0.0/8, а сеть 172.16.10.0/24 воспринята как сеть 172.16.0.0/16. Это связано с классами IP адресов.

3. Командой show ip protocols посмотрим с какими параметрами работает протокол RIP. Например, для Router1 имеем



Переведите сообщение.

4. Посмотрим таблицы маршрутов

Router2# sh ip route



Есть маршрут на сеть 172.16.10.0/24 через интерфейс Ethernet на адрес 10.1.1.1.

Пинги в эту сеть из Router2 пойдут. Проверьте

Router2#ping 172.16.10.1

Router2# ping 172.16.10.2

5. Перейдём на другой маршрутизатор

Router4# sh ip route



Есть маршрут на сеть 10.1.1.0/24 через интерфейс Serial на адрес 172.16.10.1.

Пинги в эту сеть из Router4 пойдут. Проверьте

Router4#ping 10.1.1.1

Router4# ping 10.1.1.2.

  1. Командой debug ip rip посмотрим как маршрутизаторы обмениваются маршрутной информацией. Например, для Router1 имеем повторяющиеся каждые 30 секунд сообщения



Router1# debug ip rip



Выключим трассировку

Router1# no debug ip rip

Сохраните конфигурацию.

EIGRP

Остановим на всех маршрутизаторах RIP командой

Router(config)#no router rip.

1. Включим EIGRP на всех маршрутизаторах, образуя автономную систему с номером 100

Router1(config)# router eigrp 100

Router1(config-router)# network 172.16.10.0

Router1(config-router)# network 10.1.1.0

Router2(config)# router eigrp 100

Router2 (config-router)# network 10.1.1.0

Router4(config)# router eigrp 100

Router4 (config-router)# network 172.16.10.0

2. На каждом маршрутизаторе командой show running-config посмотрим как маршрутизаторы поняли наши команды. Видим, что сеть 10.1.1.0/24 воспринята как сеть 10.0.0.0/8, а сеть 172.16.10.0/24 воспринята как сеть 172.16.0.0/16. Это связано с классами IP адресов.

3. Командой show ip protocols посмотрим с какими параметрами работает протокол EIGRP. Например, для Router1 имеем



Переведите сообщение.

4. Посмотрим таблицы маршрутов

Router2# sh ip route



Есть маршрут на сеть 172.16.10.0/24 через интерфейс Ethernet на адрес 10.1.1.1.

Пинги в эту сеть из Router2 пойдут. Проверьте

Router2#ping 172.16.10.1

Router2# ping 172.16.10.2

5. Перейдём на другой маршрутизатор

Router4# sh ip route



Есть маршрут на сеть 10.1.1.0/24 через интерфейс Serial на адрес 172.16.10.1.

Пинги в эту сеть из Router4 пойдут. Проверьте

Router4#ping 10.1.1.1

Router4# ping 10.1.1.2.

  1. Командами debug ip eigrp transactions и debug ip eigrp events посмотрите как маршрутизаторы обмениваются маршрутной информацией.

Сохраните конфигурацию.

OSPF

Остановим на всех маршрутизаторах EIGRP командой

Router(config)#no router eigrp 100

  1. Включим OSPF на всех маршрутизаторах. Дадим процессу OSPF номер 100. Образуем OSPF область 0


Router1(config)#router ospf 100

Router1(config-router)# network 172.16.10.0 0.0.0.255 area 0

Router1(config-router)# network 10.1.1.0 0.0.0.255 area 0

Router2(config)#router ospf 100

Router2(config-router)# network 10.1.1.0 0.0.0.255 area 0

Router4(config)# router ospf 100

Router4(config-router)# network 172.16.10.0 0.0.0.255 area 0

2. Команда show running-config показывает, что маршрутизаторы поняли наши команды в том же виде, как мы их и задавали.

3. Командой show ip protocols посмотрим с какими параметрами работает протокол OSPF. Например, для Router1 имеем



Переведите сообщение.

4. Посмотрим таблицы маршрутов

Router2# sh ip route



Есть маршрут на сеть 172.16.10.0/24 через интерфейс Ethernet на адрес 10.1.1.1.

Пинги в эту сеть из Router2 пойдут. Проверьте

Router2# ping 172.16.10.1

Router2# ping 172.16.10.2

5. Перейдём на другой маршрутизатор

Router4# sh ip route



Есть маршрут на сеть 10.1.1.0/24 через интерфейс Serial на адрес 172.16.10.1.

Пинги в эту сеть из Router4 пойдут. Проверьте

Router4# ping 10.1.1.1

Router4# ping 10.1.1.2.

  1. Команды show ip ospf interface, show ip ospf database и debug ip igrp neighbor покажут вам всю информацию о параметрах протокола OSPF.

Сохраните конфигурацию.


Контрольные вопросы

  1. Что такое автономная система.

  2. Что такое метрика?

  3. Какие существуют два класса протоколов динамической маршрутизации.

  4. Объясните работу дистанционно-векторных протоколов.

  5. Объясните работу протоколов состояния связи.

  6. Как узнать, какие протоколы маршрутизации запущены на маршрутизаторе?

  7. В чём преимущества и недостатки дистанционно-векторных протоколов и протоколов состояния связи?

  8. Что такое сходимость протоколов маршрутизации?

  9. Какие параметры влияют на скорость сходимости?

Ход работы

  1. Изучить теоретическую и практическую часть.

  2. Ответить на контрольные вопросы.

  3. Выполнить в Packet Tracer практическую часть.

  4. Используя вариант из предыдущей лабораторной работы, выполните задание для получения повышенного бала.

  5. Выполнить п. 7, 10, 14 и 18 задания для получения повышенного бала.

  6. Оформите отчёт.

Задание для получения повышенного бала

1. Используйте топологию своего варианта из предыдущей лабораторной работы, представленную на рисунке 5.




Рисунок 5.

В сети шесть подсетей. Вы видите, что каждый маршрутизатор подключён к трём подсетям.

2. Отредактируйте вручную сохранённую конфигурацию предыдущей успешно выполненной лабораторной работы: уберите в rtr файлах маршрутизаторов команды статической маршрутизации.

3. Загрузите отредактированную конфигурацию в симулятор.

4. На каждом маршрутизаторе проверьте правильность загрузки конфигурации командами show cdp neighbors и show ip interface brief.

Если последовательный интерфейс не поднялся, проверьте командой show running-config, что на интерфейсе DCE стороны последовательной связи задана команда clock rate! Если не задана, то задайте её.

5. Настройте на каждом маршрутизаторе динамическую маршрутизацию по протоколу RIP.

6. На каждом маршрутизаторе посмотреть таблицу маршрутизации командой show ip route. Сделать скриншоты. Например, для маршрутизатора router1 для варианта 1 (v=1) имеем



7. На каждом компьютере выполните команды трассировки tracert других компьютеров. Сделайте скриншоты. Всего шесть скриншотов. Например, трассировка из PC1 на PC2 для варианта 1 (v=1) имеет вид



Видим, что путь для пакетов из PC1 на PC2 (1.1.5.2) лежит последовательно через Router1 (Ethernet 1.1.4.1) и затем через Router2 (serial0 1.1.1.2)

  1. Отключим на маршрутизаторе router1 последовательный интерфейс serial 0

Router1(config)#interface serial 0

Router1(config-if)#shutdown

  1. Через пару минут, когда в сети пройдут обновления маршрутной информации, на каждом маршрутизаторе посмотреть таблицу маршрутизации командой show ip route. Сделать скриншоты. Например, для маршрутизатора router1 для варианта 1 (v=1) имеем



Видим, что таблица изменилась: пропала сеть 1.1.1.0/24 и все пакеты теперь маршрутизируются на адрес 1.1.3.2 через интерфейс Serial1.

  1. На каждом компьютере выполните команды трассировки tracert других компьютеров. Сделайте скриншоты. Всего шесть скриншотов. Например, трассировка из PC1 на PC2 для варианта 1 (v=1) имеет вид



Видим, что теперь путь для пакетов из PC1 на PC2 (1.1.5.2) лежит последовательно через Router1 (Ethernet 1.1.4.1) , затем через Router3 (serial0 1.1.3.2) и затем через Router2 (serial1 1.1.2.1).

  1. Сохраните конфигурацию.

  2. Отключите RIP и настройте на каждом маршрутизаторе динамическую маршрутизацию по протоколу IGRP.

  3. На каждом маршрутизаторе посмотреть таблицу маршрутизации командой show ip route. Сделать скриншоты. Например, для маршрутизатора router1 для варианта 1 (v=1) имеем



  1. Проверьте, что вы всё сделали правильно. На каждом компьютере выполните команд трассировки tracert других компьютеров.

  2. Сохраните конфигурацию.

  3. Отключите IGRP и настройте на каждом маршрутизаторе динамическую маршрутизацию по протоколу OSPF.

  4. На каждом маршрутизаторе посмотреть таблицу маршрутизации командой show ip route. Сделать скриншоты. Например, для маршрутизатора router1 для варианта 1 (v=1) имеем



  1. Проверьте, что вы всё сделали правильно. На каждом компьютере выполнените команд трассировки tracert других компьютеров.

  2. Сохраните конфигурацию.

Содержание отчёта.

1. Скриншот топологии, созданной при выполнении практической части.

2. Конфигурации трёх маршрутизаторов из .txt файлов, созданных при выполнении практической части для каждого протокола маршрутизации. Итого содержимое 9 (девяти) файлов.

3. Скриншот топологии из рисунка 5 с адресами своего варианта

4. Таблицу 2 предыдущей лабораторной работы с адресами своего варианта

5. Конфигурации трёх маршрутизаторов из .txt файлов, созданных при выполнении задание для самостоятельной работы для каждого протокола маршрутизации. Итого содержимое девяти файлов.

6. Все скриншоты, указанные в задании для получения повышенного бала




Скачать 153.01 Kb.
оставить комментарий
Дата29.09.2011
Размер153.01 Kb.
ТипЛабораторная работа, Образовательные материалы
Добавить документ в свой блог или на сайт

отлично
  3
Ваша оценка:
Разместите кнопку на своём сайте или блоге:
rudocs.exdat.com

Загрузка...
База данных защищена авторским правом ©exdat 2000-2017
При копировании материала укажите ссылку
обратиться к администрации
Анализ
Справочники
Сценарии
Рефераты
Курсовые работы
Авторефераты
Программы
Методички
Документы
Понятия

опубликовать
Загрузка...
Документы

Рейтинг@Mail.ru
наверх