Курсовая работа по дисциплине «Локальные вычислительные сети» тема: «Проектирование лвс» icon

Курсовая работа по дисциплине «Локальные вычислительные сети» тема: «Проектирование лвс»


Смотрите также:
Курсовая работа по дисциплине «Локальные вычислительные сети» тема: «Проектирование лвс»...
Работа по дисциплине «Локальные вычислительные сети» На тему: «Проектирование лвс»...
Программа по дисциплине «Сетевые технологии» по направлениям: «Математика. Компьютерные науки»...
Контрольная работа по дисциплине «Компьютерные сети» на тему: «Проектирование лвс для...
Курсовая работа по дисциплине Сети ЭВМ и средства коммуникаций...
«Проектирование лвс»...
Тема: 12. Локальные вычислительные сети. Виды связи, используемой в системе фтс россии...
Вопрос№6 «Современные технические средства»...
Техническое задание 5 анализ технического задания 6 обзор литературы 7...
Техническое задание 5 анализ технического задания 6 обзор литературы 7...
Техническое задание 6 анализ технического задания 7 обзор литературы 8...
Техническое задание...



Загрузка...
скачать

Министерство образования и науки Российской Федерации

Московский государственный институт электроники и математики


Кафедра ИКТ


Курсовая работа


по дисциплине

«Локальные вычислительные сети»
тема: «Проектирование ЛВС»


Выполнил:

студент группы С-74

Кузьменко А.В.


Проверил:

Харламов А.Г.

Оглавление


Техническое задание 3

Проектирование ЛВС 4

Введение 4

Схема 4

Конфигурация маршрутизаторов 6

Маршрутизатор R1 6

Маршрутизатор R2 6

Маршрутизатор R3 6

Маршрутизатор R4 6

Маршрутизатор R5 7

Конфигурация коммутаторов 7

Сегмент I 7

Сегмент IV 8

Конфигурация конечных узлов сети 8

Сегмент I 8

Сегмент II 9

Сегмент III 9

Сегмент IV 9

Сегмент V 10

Сегмент VI 10

Пример настройки коммутатора 11

Литература 12



Техническое задание





  1. В проекте необходимо разработать канальный и сетевой уровни.

  2. ЛВС должна состоять из нескольких сегментов сетевого уровня.

  3. Внутри сети должно быть несколько различных путей между некоторыми узлами.

  4. У ЛВС должно быть подключение к глобальной сети. 

  5. Канальный уровень предлагается построить на основе технологий Ethernet и VLAN на одном или нескольких управляемых коммутаторах.

  6. Сетевой уровень предлагается построить на основе протокола IP.

  7. Для спроектированной сети необходимо построить схемы, используя какое-либо программное обеспечение для эмуляции вычислительных сетей.

  8. Для разрабатываемой сети требуется составить таблицы маршрутизации для каждого маршрутизатора и для произвольного узла внутри каждого сегмента сетевого уровня. Таблицы маршрутизации должны быть представлены в формате того программного обеспечения, которое используетcя маршрутизаторами.

  9. На выбор, или для одного из маршрутизаторов, или для одного из управляемых коммутаторов требуется привести команды для его настройки.



Проектирование ЛВС

Введение


Рассматриваемая сеть будет состоять из 6 сетевых сегментов. В двух из них будет применена технология VLAN для разбиения сети на канальном уровне. В работе представлена единственная схема, которая отображает топологию сетевого уровня. Для лучшего восприятия, а также для того, чтобы подчеркнуть наличие виртуальных сетей, устройства, относящихся к одному сегменту, графически сгруппированы.

В некоторых сегментах сети присутствуют хосты, предоставляющие DHCP сервис, а также двое один из них организуют поддержку DNS. Для некоторых сегментов существует несколько маршрутов. Все хосты, не нуждающиеся в статическом адресе, при наличии в их сегменте поддержки DHCP сервиса, используют его для автоматической настройки параметров соединения. Все хосты сети, пользуются сервисом DNS, если обладают физическим доступом к соответствующему серверу.

Схема






Схема нумерации

Для перечисления сегментов сети и активного сетевого оборудования, они будут пронумерованы следующим образом(сегменты сети – римскими цифрами, маршрутизаторы – большими арабскими цифрами, коммутаторы – малыми арабскими цифрами):



^ Построение таблиц маршрутизации

Конфигурация маршрутизаторов

Маршрутизатор R1


Адрес сети

Маска сети

Адрес шлюза

Интерфейс

Метрика

0.0.0.0

0.0.0.0

172.16.0.1

172.16.0.1

1

192.168.1.0

255.255.255.0

192.168.1.1

192.168.1.1

-

192.168.2.0

255.255.255.0

192.168.2.1

192.168.2.1

-

192.168.3.0

255.255.255.0

192.168.3.1

192.168.3.1

-

192.168.4.0

255.255.252.0

192.168.3.3

192.168.3.1

1



Маршрутизатор R2


Адрес сети

Маска сети

Адрес шлюза

Интерфейс

Метрика

0.0.0.0

0.0.0.0

192.168.3.1

192.168.3.3

1

192.168.3.0

255.255.255.0

192.168.3.3

192.168.3.3

-

192.168.4.0

255.255.255.0

192.168.4.1

192.168.4.1

-

192.168.5.0

255.255.255.0

192.168.4.2

192.168.4.1

1

192.168.5.0

255.255.255.0

192.168.4.3

192.168.4.1

2

192.168.6.0

255.255.255.0

192.168.4.3

192.168.4.1

1

192.168.6.0

255.255.255.0

192.168.4.2

192.168.4.1

2



Маршрутизатор R3


Адрес сети

Маска сети

Адрес шлюза

Интерфейс

Метрика

0.0.0.0

0.0.0.0

192.168.4.1

192.168.4.2

1

0.0.0.0

0.0.0.0

192.168.5.2

192.168.5.1

3

192.168.4.0

255.255.255.0

192.168.4.2

192.168.4.2

-

192.168.4.0

255.255.255.0

192.168.5.2

192.168.5.1

3

192.168.5.0

255.255.255.0

192.168.5.1

192.168.5.1

-

192.168.5.0

255.255.255.0

192.168.4.3

192.168.4.2

3

192.168.6.0

255.255.255.0

192.168.4.3

192.168.4.2

1

192.168.6.0

255.255.255.0

192.168.5.2

192.168.5.1

1

Маршрутизатор R4


Адрес сети

Маска сети

Адрес шлюза

Интерфейс

Метрика

0.0.0.0

0.0.0.0

192.168.4.1

192.168.4.3

1

0.0.0.0

0.0.0.0

192.168.6.2

192.168.6.1

3

192.168.4.0

255.255.255.0

192.168.4.3

192.168.4.3

-

192.168.4.0

255.255.255.0

192.168.6.2

192.168.6.1

2

192.168.5.0

255.255.255.0

192.168.4.2

192.168.4.3

1

192.168.5.0

255.255.255.0

192.168.6.2

192.168.6.1

1

192.168.6.0

255.255.255.0

192.168.6.1

192.168.6.1

-

192.168.6.0

255.255.255.0

192.168.4.2

192.168.4.3

2




Маршрутизатор R5


Адрес сети

Маска сети

Адрес шлюза

Интерфейс

Метрика

0.0.0.0

0.0.0.0

192.168.6.1

192.168.6.2

1

0.0.0.0

0.0.0.0

192.168.5.1

192.168.5.2

1

192.168.5.0

255.255.255.0

192.168.5.2

192.168.5.2

-

192.168.5.0

255.255.255.0

192.168.6.1

192.168.6.2

2

192.168.6.0

255.255.255.0

192.168.6.2

192.168.6.2

-

192.168.6.0

255.255.255.0

192.168.5.1

192.168.5.2

2



Конфигурация коммутаторов


Настройка большинства коммутаторов сети тривиальна, поэтому рассмотрим настройку только тех коммутаторов, которые связаны с организацией VLAN. VLAN с номером 1 является сетью по умолчанию.

Сегмент I

Коммутатор 1


Интерфейс

Режим

Номер VLAN

0/1

Trunk

1,2

0/2

Access

2

0/3

Access

1

0/4

Access

1



Коммутатор 2


Интерфейс

Режим

Номер VLAN

0/1

Trunk

1

0/2

Access

1

0/3

Access

1

Коммутатор 3


Интерфейс

Режим

Номер VLAN

0/1

Trunk

2

0/2

Access

2

0/3

Access

2

0/4

Access

2

Коммутатор 4


Интерфейс

Режим

Номер VLAN

0/1

Access

1

0/2

Trunk

1,2

0/3

Trunk

1

0/4

Trunk

2



Сегмент IV

Коммутатор 1


Интерфейс

Режим

Номер VLAN

0/1

Access

1

0/2

Access

1

0/3

Access

2

0/4

Access

2

0/5

Access

2

0/6

Access

2



Конфигурация конечных узлов сети


Как уже было упомянуто ранее, в некоторых сегментах сети организован сервис DHCP для автоматизации процесса настройки сети, поэтому в процессе описания настройки конечных узлов может присутствовать описание конфигурации соответствующего сервиса для всего сегмента сети.

Для уменьшения объема далее представленного материала, записи о широковещательных маршрутах отсутствуют.

Сегмент I

Узел 1


Адрес сети

Маска сети

Адрес шлюза

192.168.1.0

255.255.255.0

192.168.1.1

Узел 2


Адрес сети

Маска сети

Адрес шлюза

0.0.0.0

0.0.0.0

192.168.1.1

192.168.1.0

255.255.255.0

192.168.1.3

DNS: 192.168.3.2

Узел 3


Адрес сети

Маска сети

Адрес шлюза

0.0.0.0

0.0.0.0

192.168.1.1

192.168.1.0

255.255.255.0

192.168.1.2

DNS: 192.168.3.2

Узел 4


Адрес сети

Маска сети

Адрес шлюза

0.0.0.0

0.0.0.0

192.168.1.1

192.168.1.0

255.255.255.0

192.168.1.5

DNS: 192.168.3.2

Узел 5


Адрес сети

Маска сети

Адрес шлюза

0.0.0.0

0.0.0.0

192.168.1.1

192.168.1.0

255.255.255.0

192.168.1.4

DNS: 192.168.3.2

Узел 6


Адрес сети

Маска сети

Адрес шлюза

192.168.1.0

255.255.255.0

192.168.1.2

Узел 7


Адрес сети

Маска сети

Адрес шлюза

192.168.1.0

255.255.255.0

192.168.1.3

Узел 8


Адрес сети

Маска сети

Адрес шлюза

192.168.1.0

255.255.255.0

192.168.1.4



Сегмент II


Параметры DHCP сервиса

Параметр

Значение

Адрес шлюза по умолчанию

192.168.2.1

DNS сервер

192.168.3.2

Начало диапазона IP-адресов

192.168.2.10

Конец диапазона IP-адресов

192.168.2.100

Сегмент III


Параметры DHCP сервиса

Параметр

Значение

Адрес шлюза по умолчанию

192.168.3.1

DNS сервер

192.168.3.2

Начало диапазона IP-адресов

192.168.3.10

Конец диапазона IP-адресов

192.168.3.100

Сегмент IV


Параметры DHCP сервиса

Параметр

Значение

Адрес шлюза по умолчанию

-

DNS сервер

192.168.1.1

Начало диапазона IP-адресов

192.168.1.10

Конец диапазона IP-адресов

192.168.1.100

Сегмент V


Параметры DHCP сервиса

Параметр

Значение

Адрес шлюза по умолчанию

192.168.5.1

DNS сервер

192.168.3.2

Начало диапазона IP-адресов

192.168.5.10

Конец диапазона IP-адресов

192.168.5.100



Сегмент VI

Узел 1


Адрес сети

Маска сети

Адрес шлюза

0.0.0.0

0.0.0.0

192.168.6.1

192.168.6.0

255.255.255.0

192.168.6.3

DNS: 192.168.3.2

Узел 2


Адрес сети

Маска сети

Адрес шлюза

0.0.0.0

0.0.0.0

192.168.6.1

192.168.6.0

255.255.255.0

192.168.6.4

DNS: 192.168.3.2

Пример настройки коммутатора


Рассмотрим процесс настройки коммутатора 1 из сегмента I:


Switch#vlan database

Switch(vlan)#vlan 1 name default

Switch(vlan)#vlan 2 name VLAN2

Switch(vlan)#exit


Switch#configure terminal

Switch(config)#interface vlan 1

Switch(config-if)#ip address 192.168.1.0 255.255.255.0

Switch(config-if)#end


Switch#configure terminal

Switch(config)#interface vlan 2

Switch(config-if)#ip address 192.168.1.0 255.255.255.0

Switch(config-if)#end


Switch#configure terminal

Switch(config)#interface fastethernet 0/1

Switch(config-if)#switchport mode trunk

Switch(config-if)#switchport trunk allowed vlan add 1

Switch(config-if)#switchport trunk allowed vlan add 2

Switch(config-vlan)#end


Switch#configure terminal

Switch(config)#interface fastethernet 0/2

Switch(config-if)#switchport access vlan 2

Switch(config-vlan)#end


Switch#configure terminal

Switch(config)#interface fastethernet 0/3

Switch(config-if)#switchport access vlan 1

Switch(config-vlan)#end


Switch#configure terminal

Switch(config)#interface fastethernet 0/4

Switch(config-if)#switchport access vlan 1

Switch(config-vlan)#end


Switch#write memory

Литература





  1. Олифер В.Г., Олифер Н.А. Компьютерные сети. Принципы, технологии, протоколы.




Москва, 2010г.




Скачать 147.35 Kb.
оставить комментарий
Кузьменко А.В
Дата09.05.2012
Размер147.35 Kb.
ТипКурсовая, Образовательные материалы
Добавить документ в свой блог или на сайт

Ваша оценка этого документа будет первой.
Ваша оценка:
Разместите кнопку на своём сайте или блоге:
rudocs.exdat.com

Загрузка...
База данных защищена авторским правом ©exdat 2000-2017
При копировании материала укажите ссылку
обратиться к администрации
Анализ
Справочники
Сценарии
Рефераты
Курсовые работы
Авторефераты
Программы
Методички
Документы
Понятия

опубликовать
Загрузка...
Документы

Рейтинг@Mail.ru
наверх