“Компьютерное моделирование работы схемы усилителя” icon

“Компьютерное моделирование работы схемы усилителя”


Смотрите также:
Всероссийская научно-практическая конференция Прикладная информатика и компьютерное...
Программа дисциплины дпп. Дс. 01 Компьютерное моделирование в химии цели и задачи дисциплины...
Ля высших учебных заведений по специальности i-39 02 01 моделирование и компьютерное...
Учебно-методический комплекс Дисциплины «Компьютерное моделирование и проектирование электронных...
Уроки русского языка. 5 КиМ...
Учебно-методический комплекс учебной дисциплины дпп ф...
Методические указания к лабораторной работе практикума по радиоэлектронике Новосибирск, 1997...
План Лекций по теме “Компьютерное моделирование макромолекулярных систем и нанообъектов”...
Лабораторная работа №18...
Учебная программа. Наименование тем, их содержание...
Курсовая работа по дисциплине «Моделирование»...
Программа дисциплины Компьютерное имитационное моделирование для решения задач логистики и...



Загрузка...
скачать


Министерство образования Российской Федерации



ВОРОНЕЖСКИЙ ГОСУДАРСТВЕННЫЙ ТЕХНИЧЕСКИЙ УНИВЕРСИТЕТ


Радиотехнический факультет


Кафедра радиотехники


КУРСОВая работа


по дисциплине “Компьютерное проектирование и моделирование РЭС


Тема: “Компьютерное моделирование работы схемы усилителя”


Разраб. студенты группы РТ-002

подпись, дата


Руководитель Ю. Э. Корчагин

подпись, дата


Нормоконтролер Ю. Э. Корчагин

подпись, дата


Защищена ____________________________ Оценка ________________________

дата


2004

Замечания руководителя

Воронежский государственный технический университет

^
Кафедра радиотехники


Задание

на курсовой проект

по дисциплине “Компьютерное проектирование и моделирование РЭС


Тема проекта: Компьютерное моделирование работы схемы усилителя


Техническое задание:

  • произвести компьютерное моделирование работы схемы управления;

  • разработать чертёж печатной платы моделируемого устройства;

  • составить принципиальную электрическую схему и перечень элементов рассматриваемого устройства.



^ Студент группы РТ-002 Каширский Антон Юрьевич

фамилия имя отчество


Руководитель Ю. Э. Корчагин

подпись инициалы фамилия


Дата __ .__ .__ .


^ Задание принял студент А. Ю. Каширский

подпись инициалы фамилия


Дата __ .__ .__ .


Содержание

Введение 6

1.Графический ввод схем 7

2.Анализ уровня шума 12

3.Разработка печатной платы 14

Заключение 16

Список используемой литературы 17


Введение

Математическое моделирование электронных схем с помощью персональных компьютеров является универсальным инструментом разработки и оценки качества проектных решений. Математическое моделирование имеет ряд преимуществ перед физическим макетированием, в том числе:

  • повторяемость эксперимента; отсутствие возможности "сжечь" математический макет;

  • гибкость и быстрота получения результатов;

  • отсутствие монтажных работ и необходимых для этого инструментов и материалов (паяльника, припоя, флюса, монтажной платы, электрорадиоэлементов и др.);

  • ненужность дорогостоящих контрольно-измерительных приборов.

К последним относятся осциллографы, вольтметры, амперметры, измерители частотных и переходных характеристик, измерители нелинейных искажений и др. Суммарная стоимость этих приборов существенно превышает стоимость высокопроизводительного персонального компьютера. Не менее важным является фактор обучения студентов технике построения электронных схем (схемотехнике). С помощью компьютерного моделирования можно "проследить" любой ток и напряжение в схеме, оценить влияние температуры и технологического разброса параметров электрорадиоэлементов, рассчитать уровень собственных шумов и многое другое, что невозможно или требует значительных усилий при физическом макетировании.

На платформе персональных компьютеров в настоящее время имеется единственная система, обеспечивающая сквозное проектирование аналого-цифровой аппаратуры – система ORCAD. Ядром пакета является программа, в которой используются SPICE -алгоритмы (Simulation Program with Integrated Circuit Emphasis). Первая программа семейства SPICE создана в Калифорнийском университете Беркли в начале 70-х годов. Популярность различных версий SPICE привела к тому, что производители полупроводниковых приборов и интегральных схем прилагают к выпускаемой ими продукции параметры spice-моделей. Разработчики аналоговых и смешанных электронных устройств сопровождают свои разработки spice-моделями для подтверждения качества проектирования. SPICE-программа стала своеобразным эталоном программ схемотехнического проектирования. Многие разработчики программ моделирования электронных схем обеспечивают возможность экспорта проекта в программу PSpice. Списки соединений схемы в формате SPICE составляются большинством пакетов САПР (Micro-Cap, Dr.Spice, OrCAD, P-CAD, ACCEL EDA, Viewlogic, COMPASS, Design Architect и др.).

В рамках данной работы будет проведено моделирование электрической схемы на базе пакета OrCad 9.2 и разработан пакет конструкторской документации на соответствующее изделие.

  1. ^ Графический ввод схем

Графический редактор Capture CIS пакета OrCAD позволяет создавать чертежи принципиальных схем и передавать управление программам PSpice A/D, PLogic, StmEd, Probe, Parts PSpice Opimizer, PLSyn , PCBoard.

Возможность редактирования символов – условных графических обозначений отдельных компонентов – и нанесения надписей на схему по-русски позволяет создавать чертежи принципиальных схем в соответствии с отечественными стандартами. Поддерживаются иерархические и многостраничные структуры. Информация о принципиальных схемах, созданных в редакторе Capture CIS, в виде списка соединений передается в системы разработки печатных плат CADStar, PADS, Protel, P-CAD, Tango, Scicards и в собственный редактор PCBoard для упаковки на печатные платы; поддерживается международный стандарт EDIF /3/. Редактор управляется с помощью системы ниспадающих меню. Имеется встроенное средство помощи для получения краткой информации о правилах работы с редактором.

Библиотеки программы Capture содержат в себе символы компонентов, источников питания и «земли». Они размещаются на схеме по команде Place>Part, активизируемой также нажатием на пиктограмму меню инструментов. В диалоговом окне этой команды сначала в списке Libraries выбирается имя одной или нескольких библиотек, содержание которых отображается на панели Part (для выбора нескольких библиотек нажимается и удерживается клавиша Ctrl). После этого на панели Part выбирается имя компонента, символ которого должен быть помещен на схему (если выбрано несколько библиотек, то после имени каждого компонента помещается символ / и затем имя библиотеки). В разделе Graphic выбирается обычное (Normal) или эквивалентное изображение логических компонентов в стиле DeMorgan (Convert). В разделе Packaging указывается номер секции компонента, после чего в расположенном ниже окне выводится изображение выбранной секции компонента с указанием номеров цоколевки его выводов (на строке Parts per Pkg. указывается общее количество секций компонента). Нажатием на кнопку Add Library открывается диалоговое окно для добавления библиотек в список Libraries, нажатие на кнопку Remove Library удаляет выбранную библиотеку из списка. Кнопка Part Search предназначена для поиска конкретного компонента в библиотеках из списка Libraries. После нажатия на кнопку ОК символ выбранного компонента переносится на схему. Движением курсора компонент перемещается в нужное место схемы и фиксируется нажатием левой кнопки мыши. После этого на схему может быть размещена еще одна копия этого же символа. Нажатие правой кнопки мыши открывает всплывающее меню в котором дублируется вызов команд основного меню для вращения (Rotate), зеркального отображения (Mirror), изменения масштаба изображения (Zoom), редактирования параметров компонента (Edit Properties) и ряд других. Завершение размещения на схеме символа выбранного компонента производится после выбора в этом меню команды End Mode или нажатия на клавишу Esc.

^ Part Value - номинальное значение параметра простого компонента (сопротивление,-емкость и т.п., принимаемые во внимание при моделировании) или наименование сложного компонента (программой моделирования во внимание не принимается);

^ Part Reference — позиционное обозначение компонента. Оно проставляется здесь вручную, если на закладке Miscellaneous команды Options>Preferences не выбран параметр Automatically reference placed parts — автоматическое присваивание позиционных обозначений размещаемым на схеме компонентам (см. подробности ниже). На панели РСВ Footprint можно выбрать или скорректировать имя корпуса компонента. Выбор панели Power Pins Visible указывает на необходимость отображения на схеме выводов «земли» и питания. На панели Primitive выбирается тип компонента: Yes — элементарный (примитивный) компонент; No — компонент, имеющий иерархическую структуру, Default — устанавливается по умолчанию (в соответствием с настройкой конфигурации на закладке Hierarchy команды Options>Design Template. На панели Packaging указывается общее количество однотипных секций компонента и имя (номер) текущей секции (к сожалению, на этой закладке номер секции размещаемого символа компонента изменять нельзя).

Нажав на панель ^ User Properties открывает диалоговое окно просмотра и редактирования параметров компонента: в графе Name указывается имя параметра, в графе Value — его значение, в графе Attributes — характеристики (атрибуты) его отображения на схеме (R — только для чтения, V — видимые на схеме, последний признак задается на панели Display, см. ниже). После выбора параметра его имя выводится в нижней части окна, а в расположенной рядом панели производится ввод его значения (после нажатия на клавишу Enter введенное значение отображается в графе Value) — таким образом вводятся, в частности, необходимые для моделирования с помощью PSpice значения параметров компонентов (на рис. 2.23, б изображено диалоговое окно параметров источника гармонического напряжения VSIN); их можно ввести или отредактировать позже, по команде Edit>Properties.

Нажав на панель Display открывает диалоговое окно для задания видимости на схеме выбранного параметра:

  • Do Not Display — ничего не отображать на схеме;

  • Value Only — отображать только значение параметра;

  • Name and Value — отображать и имя, и значение параметра;

  • Name Only — отображать только имя параметра;

  • Both if Value Exists — отображать и имя, и значение параметра, если его значение существует.

Нажатие на панель Attach Implementation открывает диалоговое окно просмотра и редактирования типа объекта, присоединенного к текущему компоненту :

  • Implementation type — тип присоединенного объекта, принимающего значения:

    • PSpice Model — математическая модель компонента для программы PSpice;

    • PSpice Stimulus — описание внешнего сигнала для программы PSpice;

    • Schematic View — схема объекта;

    • VHDL — описание компонента на языке VHDL;

    • EDIF — список соединений в формате EDIF;

    • Project — схема проекта (для него необходимо дополнительно задать выводы иерархических блоков);

  • Implementation — имя присоединенного объекта; -

  • Path and filename, — полное имя файла присоединенного объекта.

По команде ^ Place>No connect или нажатием на кнопку Ц панели инструментов наносятся символы отсутствия соединений No-connect (NC), которые на схеме отображаются в виде символов «X», подсоединенных к выводам компонентов. Выводы, помеченные такими символами, не включаются в отчеты сообщений об ошибках и в списки соединений. Символы NC не могут быть удалены нажатием на клавишу [Delete], для их удаления нужно поверх символа NC разместить еще один такой же символ.

По команде ^ Place>Off-Page Connector или нажатием на кнопку панели инструментов открывается диалоговое окно для нанесения на схему символов соединителей страниц. В штатной библиотеке CAPSYM.OLB имеются два символа соединителей страниц L и R. На панели Name диалогового окна вводятся имена соединителей страниц, которые автоматически присваиваются именам подсоединяемым к ним цепей. Цепи, расположенные на одной или разных страницах схемы и имеющие одинаковые имена, считаются электрически соединенными.

Проводники цепей размещаются по команде Place>Wire, нажатием комбинации клавиш Shft+W или нажатием на кнопку панели инструментов. Начало ввода цепи отмечается щелчком левой кнопки мыши, поле чего курсор изменяет свою форму, приобретая вид креста. Цепь прокладывается движениями курсора. Каждый излом проводника фиксируется щелчком левой кнопки мыши. Таким образом, в цепи можно сделать ортогональные изломы под углами, кратными 90°. Ввод проводника под произвольным углом производится при нажатой клавише Shift. Ввод текущей цепи завершается, если ее конец совпадает с выводом компонента или любой точкой другой цепи. Принудительное завершение ввода цепи выполняется двойным щелчком левой кнопки мыши, после чего можно провести другой проводник. Режим ввода цепей завершается нажатием клавиши Esc или выбором строки End Wire во всплывающем меню, открываемом щелчком правой кнопки мыши.

Если цепи начинаются или заканчиваются в любой точке сегмента другого проводника или на выводе компонента, между ними устанавливается электрическое соединение. Признаком подсоединения цепи к выводу является изменение его формы — пропадание квадратика на его конце. Пересекающиеся сегменты проводников не соединяются друг с другом. Их соединение выполняется двояко:

  • при прокладке пересекающего проводника нужно остановиться в точке соединения и дважды щелкнуть левой кнопкой мыши — в результате соединение будет помечено специальной точкой (junction);

  • для соединения пересекающихся проводников курсор устанавливается в точку пересечения и выполняется команда Place>Junction, нажимается комбинация клавиш Shft+J или кнопка на панели инструментов; для отмены электрического соединения необходимо поверх точки соединения разместить другую такую точку.

Если при размещении компонентов на схеме один или несколько выводов соприкасаются, между ними устанавливается электрическое соединение, и если потом эти компоненты раздвинуть, автоматически прокладывается проводник.

На рисунке 1 представлена полная электрическая принципиальная схема макета для анализа рассматриваемого управителя.




Рисунок 1 – Электрическая принципиальная схема управителя.

  1. ^ Анализ уровня шума

Задание на моделирование для программы PSpice заносится в в текстовые файлы. При графическом вводе схем с помощью программы Capture CIS создается три файла с одинаковым именем и расширениями .opj, .dsn и .dbk. При составлении этого задания непосредственно с помощью текстового редактора достаточен один файл с расширением .opj. Имена узлов могут быть целыми числами или алфавитно-цифровыми символами не более 131 символа. В качестве этих символов используются буквы латинского алфавита от A до Z, цифры 0-9, и знаки “$”, “_”, “*”, “/”, “%”.

Предложением входного языка PSpice делается на описания компонентов и директив.

Описание компоненты считается любая строка, не начинающаяся с символа “.”. Описание компонента имеет следующую структуру /4/:

<имя компонента> <номера двух или более узлов> [<имя модели>] <числовые данные>

Имя компонента состоит из последовательности символов латинского алфавита и цифр, общая длина имени не должна превосходить 131 символ. Первый символ – одна из букв латинского алфавита от A до Z, далее в любом порядке – алфавитно-цифровые символы и знаки “$”, “_”, “*”, “/”, “%”. Первый символ имени компонента определяет его тип. При графическом вводе схем с помощью программы CAPTURE CIS пользователь может вводить первый символ имени компонента по своему усмотрению, а при составлении текстового описания схемы для передачи его в PSpice к именам всех компонентов будут добавлены префиксы – это выполняется в соответствии с шаблонами символов компонентов TEMPALE. Поэтому на схемах можно именовать элементы, не придерживаясь приведенных правил. Например, транзисторы всех типов можно согласно ЕСКД именовать как V1, V2, V3 …, а при составлении текстового описания схемы биполярный транзистор получит имя Q_V1, полевой – J_V2, МОП-транзистор – M_V и так далее.

Анализ спектральной плотности внутреннего шума производится по директиве:

.NOISE М(<узел>[,<узел>]) <имя>

Директива .NOISE указывается совместно с директивой .АС, в которой зада­ется диапазон частот анализа. Источниками шума служат резисторы, ключи и по­лупроводниковые приборы. На каждой частоте а рассчитывается спектральная плотность выходного напряже­ния Suвых(f), В2/Гц, обусловленная наличием статистически независимых источ­ников внутреннего шума. Точки съема выходного напряжения указываются по спецификации V(<узел> [,<узел>]). К входным зажимам цепи подключается не­зависимый источник напряжения или тока, <имя> которого приводится в списке параметров директивы .NOISE. Этот источник не является источником реального сигнала, он служит лишь для обозначения входных зажимов цепи, к которым пе­речитывается выходной шум. Уровень шума пересчитывается с выхода на вход делением спектральной плотности выходного напряжения Suвых на квадрат модуля соответствующей передаточной функции.

Результат моделирования уровня шума представлен на рисунке 2. На рисунке ось ординат приведена в децибелах относительно напряжения 1 мкВ. Из приведённого графика видно, что среднее значение уровня шума составило -20.8 дБ/мкВ



Рисунок 2 – Уровень собственных шумов.

  1. Разработка печатной платы

Разработка печатной платы осуществлена на базе пакета P-CAD 2001. Это обусловлено двумя причинами:

  1. Редактор печатных плат и средства вывода на периферийные устройства наиболее удобно организованы в пакете P-CAD.

  2. Информация о принципиальных схемах, созданных в редакторе Capture CIS, в виде списка соединений передается в P-CAD.

Поэтому для автоматизированной разводки печатной платы достаточно создать список соединений с помощью стандартной функции Capture CIS, а затем передать его в среду разработки P-CAD.

Исходными данными для разводки печатной платы являются схема электрическая принципиальная и максимальные габаритные размеры, а также требования ГОСТ . Поэтому необходимо определиться с вариантом расположения радиоэлементов (одно- или двухстороннее), а также количеством слоёв, на которых будут располагаться печатные проводники (соответственно одно-, двух- или многослойные печатные платы).

При разработке печатной платы для рассматриваемого устройства было выбрано двухстороннее расположение радиоэлементов и печатных проводников, что обусловлено применением безкорпусных элементов. Такой подход позволяет при одинаковом количестве элементов схемы существенно улучшить массо-габаритные показатели по сравнению с применением элементов с гибкими выводами.

Чертежи верхнего и нижнего слоёв печатной платы приведены соответственно на рисунках 3 и 4.



Рисунок 3.

На рисунке видно, что часть слоя, на котором располагается выводные элементы, не «залита» землёй. Такой подход обусловлен тем, что фольга, из которой выполняются проводники, играет роль распределённой ёмкости по отношению к элементам.



Рисунок 4.

На заключающем этапе разработки устройства составляется пакет конструкторских документов, виды и комплектность которых устанавливает ГОСТ 2.102-68. Порядок разработки, оформления и обращения конструкторской документации установлен комплексом государственных стандартов Единой системы конструкторской документации (ЕСКД, группа Т52, указатель государственных стандартов СССР ГОСТ 2001-70, ГОСТ 2.804-84).

В рамках данной работы необходимо предоставить полную принципиальную электрическую схему устройства, а также перечень элементов, содержащихся в ней. Данные документы представлены соответственно в приложении.

Заключение

В ходе проделанной работы было проведено компьютерное моделирование реального устройства, применяемого на одном из предприятий города Воронежа, а также разработан пакет конструкторских документов.

Значительный интерес в проделанной работе представляют результаты компьютерного моделирования, показавшие уровень внутренних шумов схемы управления


Список используемой литературы

  1. Платы печатные. Основные параметры конструкции. ГОСТ 23751-86.

  2. Платы печатные. Общие технические условия. ГОСТ 23752-79 (СТ СЭВ 2742-80, СТ СЭВ 27443-80).

  3. Хайнеман Р. PSPICE. Моделирование работы электронных схем: Пер. с нем. – М.: ДМК Пресс, 2002. – 336 с.

  4. Разевиг В. Д. OrCad 2002: М.: Солон-Р, 2001. – 528 с.










Скачать 127,89 Kb.
оставить комментарий
Дата30.04.2012
Размер127,89 Kb.
ТипРеферат, Образовательные материалы
Добавить документ в свой блог или на сайт

Ваша оценка этого документа будет первой.
Ваша оценка:
Разместите кнопку на своём сайте или блоге:
rudocs.exdat.com

Загрузка...
База данных защищена авторским правом ©exdat 2000-2017
При копировании материала укажите ссылку
обратиться к администрации
Анализ
Справочники
Сценарии
Рефераты
Курсовые работы
Авторефераты
Программы
Методички
Документы
Понятия

опубликовать
Загрузка...
Документы

Рейтинг@Mail.ru
наверх