Учебное пособие Рекомендовано учебно-методическим советом угаэс уфа-2006 icon

Учебное пособие Рекомендовано учебно-методическим советом угаэс уфа-2006



Смотрите также:
Учебное пособие Рекомендовано учебно-методическим советом угаэс уфа 2006...
Учебное пособие Рекомендовано учебно-методическим советом угаэс уфа-2006...
Учебное пособие Часть 3 Рекомендовано учебно-методическим советом угаэс уфа-2006...
Учебное пособие Рекомендовано учебно-методическим советом угаэс уфа-2006...
Учебное пособие Рекомендовано учебно-методическим советом угаэс уфа-2010...
Учебное пособие Рекомендовано учебно-методическим советом по анатомии и гистологии...
Учебное пособие Рекомендовано Дальневосточным региональным учебно-методическим центром...
Учебное пособие для студентов специальности 5B050200 «Политология» Павлодар...
Учебное пособие Часть I рекомендовано научно-методическим советом университета белгород...
Учебное пособие Изд. 2-е, перераб и доп. Петрозаводск Издательство Петргу 2006...
Учебное пособие Изд. 2-е, перераб и доп. Петрозаводск Издательство Петргу 2006...
Учебное пособие Рекомендовано Учебно-методическим объединением по образованию в области водного...



страницы: 1   2   3   4   5   6   7   8
вернуться в начало
скачать
^

2.4. Создание стандартного проекта приложения



Для запуска Microsoft Visual Basic 6.0 (файл VB6.exe) выполните команду главного меню Пуск, Программы, Microsoft Visual Basic 6.0, Microsoft Visual Basic 6.0. При настройках по умолчанию, на экране появляется диалоговое окно New Project (Новый проект).





Окно New Project имеет вкладки:


  • New (Новый) - содержит шаблоны и мастера для создания нового проекта;

  • Existing (Существующий) - позволяет открыть ранее созданный проект или проекты-примеры, поставляемые с Visual Basic

  • Recent (Недавно созданный) - содержит список проектов, открывавшихся в последнее время;

Рис. 2.3. Окно создания проекта


Используйте значок Standard EXE для создания стандартного проекта.
^

2.5. Интегрированная среда разработки приложений Visual Basic



Интегрированная среда проектирования Microsoft Visual Basic предназначена для разработки различных приложений и позволяет конструировать интерфейс приложения, редактировать исходный код программы, компилировать и отлаживать приложения. Совокупность файлов, создаваемых в процессе разработки приложения, принято называть проектом.
^

2.5.1. Компоненты рабочей среды


После выбора типа проекта открывается среда проектирования Visual Basic.

Компоненты среды:

  • главное меню;

  • стандартная панель инструментов Standard, а также Debug, Edit, Form Editor, Shortcut Menus;

  • панель элементов управления General;

  • окно конструктора форм Form;

  • окно редактора исходного кода Code;

  • окно просмотра объектов Object Browser;

  • окно свойств Properties;

  • окно проводника проекта Project;

  • окно макета формы Form Layout.





Рис. 2.4. Инструментальная среда проектирования Visual Basic 6.0

^

2.5.2. Главное меню


Главное меню среды Visual Basic 6.0 содержит пункты: File (Файл), Edit (Правка), View (Вид), Project (Проект), Format (Формат), Debug (Отладка), Run (Запуск), Query (Запрос), Diagram (Диаграмма), Tools (Сервис), Add-Ins (Надстройки), Window (Окно), Help (Справка).
^

2.5.3. Стандартная панель инструментов


Для отображения стандартной панели инструментов на экране выберите команду меню View, Toolbars (Вид, Панели инструментов), а затем значение Standard (Стандартная).

Команда меню View, Toolbars позволяет также открыть панели инструментов: Debug (Отладка), Editor (Редактор), Form Edit (Редактор форм) и окно Customize (Настройка).

На вкладке Options окна Customize параметр Show ScreenTips on ToolBars устанавливает вывод всплывающих подсказок для кнопок стандартной панели инструментов.





Рис. 2.5. Стандартная панель инструментов


На стандартной панели инструментов отображены наиболее часто используемые команды меню в виде кнопок: Add Standard EXE Project (Добавить стандартный проект), Add Form (Добавить форму), Menu Editor (Редактор меню), Open Project (Открыть проект), Save Project (Сохранить проект), Cut (Вырезать), Copy (Копировать), Paste (Вставить), Find (Найти) , Can't Undo (Отмена предыдущего),. Can't Redo (Отмена повторного), Start (Запустить), End (Закончить) , Break (Прервать), Project Explorer (Проводник проекта), Properties Window (Окно свойств), Form Layout Window (Окно макета форм), Object Browser (Браузер объектов), Toolbox (Панель элементов управления), Data View Window (Окно просмотра данных), Visual Component Manager (Менеджер визуальных компонентов).
^

2.5.4. Окно конструктора форм


Окно конструктора форм (Form) предназначено для визуального проектирования приложения. Открыть окно можно командой меню View, Object (Вид, Объект), либо двойным щелчком в проводнике проекта Project.





В окне конструктора форм размещаются объекты приложения. Для точного позиционирования объектов в форме в окне имеется сетка. Размер ячеек сетки можно менять командой меню Tools, Options, на вкладке General. Размеры формы можно изменять мышкой, при этом автоматически меняются свойства формы Height и Width.


Рис. 2.6. Окно конструктора форм

^

2.5.5. Окно макета формы


Окно Form Layout (Макет формы) предназначено для расположения формы на экране на этапе конструирования проекта. Окно Form Layout вызывается командой меню View, Form Layout Window, либо кнопкой Form Layout Window на стандартной панели инструментов. Окно можно перемещать мышкой, при этом автоматически меняются свойства формы Left, Тор, а свойство StartUpPosition принимает значение VbManual.





В окне макета формы показывается изображение проектируемой формы на экране монитора после запуска проекта. Размеры формы в окне макета формы пропорциональны размерам монитора.



Рис. 2.7. Окно макета формы
^

2.5.6. Окно проводника проекта


Окно проводника проекта Project (Проект) предназначено для отображения "крупных" объектов, входящих в проект (форм, модулей), двойным щелчком можно открыть нужное окно. Окно проводника проекта открывается командой меню View, Project Explorer (Вид, Проводник проекта), либо кнопкой Project Explorer на стандартной панели инструментов.





Панель управления окна проводника содержит три кнопки:

  • View code – показывает окно редактора кода программы для выделенного в проводнике объекта;

  • View Object – показывает объект в конструкторе формы;

  • Toggle Folders – включает/ выключает отображение папок.


Рис. 2.8. Окно проводника проекта
^

2.5.7. Панель элементов управления


Панель элементов управления General открывается командой меню View, Toolbox (Вид, Панель элементов управления), либо кнопкой Toolbox на стандартной панели инструментов. Контекстное меню панели элементов управления имеет команды: Components (Компоненты), Add Tab (Добавить вкладку), Dockable (Прикрепить), Hide (Спрятать).

















Указатель - Pointer -

- Графическое окно - PictureBox

Надпись - Label -

- Текстовое поле - TextBox

Рамка - Frame -

- Кнопка - CommandButton

Флажок - CheckBox -

- Переключатель - OptionButton

Поле со списком – ComboBox -

- Список - ListBox

HScrollBar - горизонтальная

полоса прокрутки -

- вертикальная полоса
прокрутки - VScrollBar

Timer - Таймер -

- Список дисков - DriveListBox

Список папок - DirListBox -

- Список файлов - FileListBox

Shape - Фигура -

- Линия - Line

Image - Изображение -

- Данные - Data

OLE - Объект OLE -





^ Рис. 2.9. Панель элементов управления


Чтобы поместить на панель элементов управления новые компоненты, нужно выполнить команду меню Project, Components, затем в окне Components указать нужные компоненты (установить флажки) и нажать ОК.








Controls

(Средства управления) – основные и дополнительные компоненты.

Designers

(Проектировщики) - подключение динамических библиотек

Insertable Objects

(Встраиваемые объекты) - компоненты программных приложений.


Рис. 2.10. Вкладки окна Components
^

2.5.8. Размещение элементов управления в форме


Все элементы управления формы образуют семейство Controls.

Для размещения элемента управления в форме, в рамке, на вкладке выполните следующие действия:

  1. Кликните мышкой на элементе управления в панели элементов управления

  2. В окне конструктора форм установите указатель мыши на местоположение размещаемого объекта. Нажмите левую кнопку мыши и, удерживая кнопку, переместите указатель до требуемого размера объекта.

Для размещения (по умолчанию) элемента управления в активной форме выполните двойной щелчок мышкой на элементе управления в панели элементов управления.

После размещения элементов управления в форме для выравнивания группы объектов, а также для установки размеров используются команды меню Format и свойства категории Position окна Properties. По умолчанию размеры объектов измеряются в твипах (свойство формы ScaleMode) - 1440 твипов =1 дюйму=2,54см.





^ Рис. 2.11. Форма с элементами управления


Для одновременной работы с несколькими объектами их необходимо выделить. Выделение объектов производится нажатием кнопки мыши при нажатой клавише Shift, а также рисованием рамки с помощью указателя – элемента на панели элементов управления General. Выделение объектов, команды выравнивания, установки размеров, интервалов и центрирования, относятся к объектам, расположенным на одном общем объекте-собственнике. Команды меню Format выравнивают и устанавливают размеры выделенных объектов, по границе и размерам последнего выделенного объекта группы.
^

2.5.8.1. Команды меню Format


  • Align (Выровнять) – содержит команды выравнивания выделенных объектов

  • Make Same Size (Установить одинаковый размер) – содержит команды управления размерами выделенных объектов

  • Horizontal Spacing (Горизонтальный интервал) - Устанавливает между выделенными объектами интервал в горизонтальном направлении

  • Vertical Spacing (Вертикальный интервал) - Устанавливает между выделенными объектами интервал в вертикальном направлении

  • Center in Form (Центрирование в форме) - Центрирует объекты в форме.

  • Order (Порядок) - помещает объект в нижний или верхний слой объекта-собственника

  • Lock Сontrols (Закрепить объект) - Фиксирует положение объектов в форме.
^

2.5.9. Окно свойств


Окно Properties (Свойства) предназначено для отображения и настройки свойств активного объекта (формы, элементов управления). В нижней части окна выводится подсказка, поясняющая назначение выбранного свойства объекта.






Окно Properties вызывается командой меню View, Properties Window (Вид, Окно свойств), либо кнопкой Properties Window на стандартной панели инструментов. Свойства объекта можно упорядочить в алфавитном порядке на вкладке Alphabetic (По алфавиту) или по группам на вкладке Categorized (По категориям).

В окне Properties можно вводить, либо выбирать из списков значения свойств объектов.


^ Рис. 2.12. Окно свойств


Геометрические свойства объекта можно также задать перемещением объекта и изменением его размеров с помощью мыши в конструкторе форм.

Если выделить сразу несколько объектов, то в окне свойств можно ввести общие для этих объектов свойства.

Свойства можно изменять также при выполнении приложения, написав соответствующие коды в процедурах.
^

2.5.10. Основные свойства элементов управления


Приведем некоторые общие свойства элементов управления. Все свойства логического типа, возвращающие или устанавливающие режимы работы элементов управления имеют значение True, либо False.


Таблица 2.16

Свойство

Возвращает или устанавливает

Name

имя объекта

Caption,

либо Text

надпись, отображаемую в элементе управления, либо

текст, содержащийся в поле элемента управления

Font

характеристики шрифта текста (наименование, размер, начертание, цвет и т.п.)

Appearance

вид формы в период выполнения кода – плоский (Flat), либо объемный (3D)

Visible

режим визуализации объекта при выполнении программы

Enabled

режим доступа к объекту при выполнении программы.

Height и Width

геометрические размеры объекта (высоту и ширину).

Left и Тор

координаты левого верхнего угла объекта, в области формы.

ToolTipText

текст в окне всплывающей подсказки

MousePointer

вид указателя мыши, когда он находится над объектом:
(VbDefault, VbCross, VbHourglass, VbArrowQuestion и др.)

Picture

растровое изображение, отображаемое в объекте

Некоторые особенные свойства элементов управления.


Таблица 2.17

^ Элемент

управления

Свойства

Возвращает или устанавливает

Label

AutoSize

режим автоматического изменения размеров надписи в соответствии с размерами текста

WordWrap

режим автоматического переноса текста

TextBox

MultiLine

режим многострочного ввода данных в текстовое поле

PasswordChar

символ, отображаемый при вводе текста.

Locked

режим блокировки ввода данных

Command-Button

Style

вид кнопки – стандартный (Standard), либо графический (Graphical)

DownPicture

изображение, отображаемое при нажатой кнопке

Cancel

действие клавиши Esc при установке True

Default

действие клавиши Enter при установке True

^ Окончание табл. 2.17

ComboBox

Style

вид списка – раскрывающийся (DropDown Combo), простой (Simple Combo), раскрывающийся блокированный (DropDown List)

ListBox

Style

вид списка – стандартный (Standard), либо с флажками (CheckBox)

ListCount

число элементов списка.

TopIndex

номер элемента списка, отображаемого в верхней позиции

NewIndex

номер последнего элемента, занесенного в список.

Text

выбранный в списке элемент.

MultiSelect

способ выделения элементов списка: None или 0 - одного; Simple или 1 - нескольких (мышкой, либо клавишей Пробел); Extended или 2 - нескольких (с клавишами Shift и Ctrl) .

Selected

режим выделения элемента списка. Применяется, когда свойство MultiSelect равно 1 или 2

ComboBox

и

ListBox

List

элемент списка Синтаксис: List(номер элемента)

ListIndex

номер текущего элемента списка. Нумерация начинается с нуля. Если список пуст, то -1

Sorted

режим автоматической сортировки строк

HScrollBar

и

VScrollBar

Value

текущее значение полосы прокрутки (целое > 0)

SmallChange

и

LargeChange

шаг изменения значения свойства Value при щелчке на стрелке и на поле полосы прокрутки

Max и Min

минимальное и максимальное значение полосы прокрутки

Option-Button

Style

вид переключателя – стандартный (Standard), либо графический (Graphical)

Value

режим переключателя – включен, либо выключен

CheckBox

Style

вид флажка – стандартный (Standard), либо графический (Graphical)

Value

значение флажка – включен (Checked), выключен (UnChecked), затененный (Grayed)

Picture

AutoSize

режим автоматического изменения размеров элемента в соответствии с размерами рисунка

Image

изображение, содержащееся в свойстве Picture

Image

Stretch

режим автоматического масштабирования рисунка в соответствии с размерами элемента

Установим некоторые свойства элементов управления на форме. Общее начало пути к графическим файлам: C:\Program Files\Microsoft Visual Studio\Common\ Graphics\, окончание указывается для каждого конкретного случая.


Таблица 2.18


Элемент

Свойство

Значение

Label

Caption

Надпись

TextBox

Text

Текстовое поле

MultiLine

True (увеличьте высоту элемента)

Command-

Button

Style

Graphical

Picture

...\Bitmaps\OffCtlBr\Small\Color\Open.bmp

ComboBox

Style

Simple Combo

ListBox

Style

CheckBox, свойство MultiSelect - None

Sorted

True

ComboBox и

ListBox

List

Строки: строка4, строка3, строка2, строка1

HScrollBar

и

VScrollBar

LargeChange

1

SmallChange

1

Max

3

Min

0

OptionButon

Caption

Picture1 - для Option1,

Image1 - для Option2,

Picture1 и Image1 - для Option3

Style

Standard

Value

True для третьего переключателя

CheckBox

Caption

опция Picture1 - для Check1,

опция Image1 - для Check2,

опция Picture1 и Image1 - для Check3

Style

Standard

Value

Checked (для всех)

Picture

AutoSize

False

Picture

\Metafile\Business\ Quarter.wmf

Image

Stretch

True

Picture

\Metafile\Business\ Dollar.wmf


После установки некоторых свойств элементов управления на форме и запуска программы на выполнение приложение будет иметь вид (рис. 2.13).







Рис. 2.13. Окно программы
^

2.5.11. Редактор исходного кода программы

2.5.11.1. Окно редактора


Редактор кода Code (Код) – встроенный редактор исходного кода программы.

Окно редактора кода открывается командой меню View, Code (Вид, Код), либо двойным щелчком на объекте или форме в окне конструктора формы.







Раскрывающиеся списки Object и Procedure позволяют выбрать для объекта процедуру-событие, в которой программируется обработчик события.

Рис. 2.14. Окно редактора кода


В левой нижней части окна расположены кнопки режимов редактирования: Procedure View (код процедуры) и Full Modul View (код всего модуля).
^

2.5.11.2. Настройки редактора


Редактирование исходного кода программы выполняется в окне редактора кода (Code). Для написания кода обработки события объекта выберите в окне редактора кода в списке Object – имя объекта, а в списке Procedure имя процедуры. Каждый объект имеет свою процедуру-событие "по умолчанию", вызываемую двойным щелчком мыши на объекте в окне конструктора формы.

Для набора текста на русском языке на вкладке ^ Editor Format установите шрифт (Font): Courier New Cyr.

Некоторые настройки редактора позволяют упростить написание кода программы и облегчают поиск синтаксических ошибок.

Выделение красным цветом строки кода с синтаксической ошибкой производится в редакторе кода автоматически.


Таблица 2.19


Параметры Code Settings
^
Назначение параметров
установки редактора кода

Auto Syntax Check (Автоматический контроль синтаксиса)

автоматический контроль синтаксиса при вводе исходного кода приложения в редакторе

^ Require Variable Declaration (Требование объявления переменных)

обязательное объявление типов всех переменных, используемых в программе

^ Auto List Members (Автоматический вывод списка свойств и методов)

автоматическое отображение в позиции курсора свойств и методов объекта при вводе текста программы

^ Auto Quick Info (Автоматический вывод синтаксиса функций)

разрешение или запрет вывода информации о функциях и их параметрах при вводе текста программы

Auto Data Tips (Автоматическое отображение значений)

при отладке приложения отображает значение переменной, находящейся под указателем мыши

^ Auto Indent (Автоматический отступ)

автоматический отступ при нажатии Enter для перехода на новую строку текста программы






Рис. 2.15. Окно параметров Options


Окно параметров вызывается командой меню Tools, Options.

На вкладке Editor – устанавливаются параметры настройки редактора кода.






Рис. 2.16. Меню свойств и методов


Установлен флажок Auto List Members - выводится список со свойствами и методами объекта.

Команда с клавиатуры - Ctrl+J



Рис. 2.17. Окно сообщения об ошибке


Установлен флажок Auto Syntax Check– выводится окно диалога с комментарием синтаксической ошибки законченной строки кода.






Рис. 2.18. Всплывающая подсказка


Установлен флажок Auto Quick Info – выводится строка подсказки синтаксиса процедур и функций.

Команда с клавиатуры - Ctrl+I


Для вызова подсказки используются команды меню Edit и контекстного меню.






- список со свойствами объекта

- список констант

- строка подсказки синтаксиса процедуры

- строка подсказки параметров процедуры

- список возможных слов по первым буквам

Рис. 2.19. Команды для вызова подсказки
^

2.5.12. Основные события и методы элементов управления


Приведем некоторые общие события элементов управления


Таблица 2.20

Событие

Происходит

Click, DblClick

при щелчке и двойном щелчке на объекте

MouseDown, MouseUp

при нажатии и отпускании кнопки мыши

KeyPress

после ввода символа на клавиатуре

^ Key Down, KeyUp

при нажатии и отпускании клавиши на клавиатуре

Change

при изменении данных (значений) объекта


Методами называются процедуры, позволяющие преобразовать объект при выполнении программы.


Таблица 2.21

Метод
Позволяет

Clear

удалить все элементы из списка – очистить список

RemoveItem

удалить элементы с указанным номером из списка

Синтаксис: RemoveItem(номер удаляемого элемента)

AddItem

добавить элемент в список

Синтаксис: Addltem(элемент списка, номер элемента)

Move

переместить элемент управления

SetFocus

установить фокус на вызвавшем этот метод элементе управления

Zorder

расположить объект над или под другими объектами


Пример программного кода, реализующего работу элементов управления (рис.2.13).

Использование флажка для управления доступом к переключателю, например:

Private Sub Check1_Click()

Option1.Enabled = Check1.Value

End Sub


Использование переключателя для управления изображениями,

например:

Private Sub Option1_Click()

Picture1.Visible = True

Image1.Visible = False

End Sub

Использование полосы прокрутки для управления текущей строкой в списке, например:

Private Sub HScroll1_Change()

Combo1.ListIndex = HScroll1.Value

Combo1.SetFocus

End Sub


Установка обратной связи между полосой прокрутки и текущей строкой в списке, например:

Private Sub Combo1_Click()

HScroll1.Value = Combo1.ListIndex

End Sub

Установим полосы прокрутки в исходном положении при загрузке формы:

Private Sub Form_Load()

Show

Call HScroll1_Change ' вызов события для полосы прокрутки

Call VScroll1_Change

End Sub


Использование кнопки для закрытия формы:

Private Sub Command1_Click()

Unload Me

End Sub

Событие HScroll1_Scroll происходит при перемещении ползунка, что позволяет использовать его для немедленного реагирования на перемещение ползунка, например

Private Sub HScroll1_Scroll()

Call HScroll1_Change

End Sub
^

2.5.13. Сохранение и выполнение проекта


Завершив этап программирования можно сохранить проект на диске командой меню Save Project (Сохранить проект), либо нажав кнопку Save Project на стандартной панели инструментов. При сохранении проекта Visual Basic создает несколько файлов с именами по умолчанию, например: для формы – Form1.frm, для проекта – Project1.vbp и возможно другие, поэтому при сохранении каждого проекта необходимо создавать отдельные папки.

Команда меню ^ File, Make Project позволяет создавать исполнимый файл проекта – приложение, который Вы можете также сохранить в папке проекта.

Запустить проект на выполнение можно командой меню ^ Run, Start , либо нажав кнопку Start на стандартной панели инструментов, либо клавишей F5.

Закончить выполнение проекта можно: закрыв приложение, либо командой меню Run, End, либо нажав кнопку End на стандартной панели инструментов. Если нет другой возможности прервать выполнение проекта нажмите комбинацию клавиш Ctrl+Break.




оставить комментарий
страница4/8
Дата04.03.2012
Размер1,3 Mb.
ТипУчебное пособие, Образовательные материалы
Добавить документ в свой блог или на сайт

страницы: 1   2   3   4   5   6   7   8
отлично
  1
Ваша оценка:
Разместите кнопку на своём сайте или блоге:
rudocs.exdat.com

Загрузка...
База данных защищена авторским правом ©exdat 2000-2017
При копировании материала укажите ссылку
обратиться к администрации
Анализ
Справочники
Сценарии
Рефераты
Курсовые работы
Авторефераты
Программы
Методички
Документы
Понятия

опубликовать
Документы

наверх