Лабораторная работа Тема. Создание шаблонов и форм. Создание документа сложной структуры icon

Лабораторная работа Тема. Создание шаблонов и форм. Создание документа сложной структуры


1 чел. помогло.
Смотрите также:
Изучение макрокоманд программы ms excel с выполнением контр...
Лабораторная работа №2 «Создание текстового документа в ms word»...
Учебно-тематический план п п Раздел Количество часов теория...
Создание колонок...
Лабораторная работа №1. Освоение приемов работы с электронными таблицами. 5...
Методические указания к лабораторным работам Лабораторная работа №1...
Лабораторная работа №2 Тема: Создание сложных документов и их защита в текстовом редакторе...
Курсы дополнительного образования наименование...
Урока предпрофильной подготовки по информатике и икт в 9 классе по теме «Создание и применение...
Создание таблиц. Лабораторная работа по созданию вычисляемой таблицы. Луткова Т. В...
Лабораторная работа №4 Тема: Навигационный доступ к записям таблицы...
Лабораторная работа №2 Тема: Создание приложение в Borland Delphi. Работа с формами...



Загрузка...
скачать
Лабораторная работа

Тема. Создание шаблонов и форм. Создание документа сложной структуры.


Шаблон можно рассматривать как стандартный бланк, подготовленный для заполнения. После запуска Word 2000 открывается пустой документ, базирующийся на шаблоне Обычный, который представляет собой чистый лист бумаги формата А4 и содержит все стандартные стили форматирования.

1. Создание нового шаблона


1. Создайте шаблон для титульного листа отчета по лабораторной работе.

Выбрать команду Файл ~ Создать, в поле Создать включить параметр Шаблон. Нажать кнопку ОК или клавишу Enter. Далее ввести текстовую информацию, которая будет оставаться неизменной для всех документов, используя для оформления шаблона команды форматирования, связанные с данным шаблоном как показано на рисунке 1.

2. Сохраните шаблон с именем Титульный лист.



Министерство образования и науки
^

Российской Федерации


Владивостокский государственный университет

экономики и сервиса

ИНСТИТУТ


Кафедра

ОТЧЕТ

По лабораторной работе №

на тему

Выполнил (а): студент(ка)

гр.

Научный руководитель:


Владивосток, г.



Рисунок 1.

^ 2. Создание форм для заполнения в Microsoft Word. Форма может содержать поля, элементы управления, таблицы, вложенные таблицы и надписи.

Чтобы создать формы для просмотра и заполнения в Microsoft Word, выполните некоторые из следующих действий.

В меню ^ Вид, Панели инструментов выберите Формы, чтобы открыть панель инструментов Формы.





1. Добавьте поля формы для раскрывающегося списка (в строке КАФЕДРА) и надписей (текстовые поля) с затененением и защитой как показано на рисунке 16.

2. Сохраните шаблон с полями формы и закройте его.

Краткие сведения. Поля формы используются, когда в текст необходимо включить переменную информацию (название темы, номер группы, срок сдачи работы и т.п.). Для ввода такого рода информации в позиции ввода переменного поля следует нажать соответствующую кнопку (Текстовое поле, Флажок или Поле со списком) на панели Формы. При необходимости можно задавать специальные атрибуты поля, например, тип поля: обычный текст, число, дата. Для этого следует установить в область поля курсор и нажать на панели инструментов Формы кнопку Параметры поля формы или нажать правую кнопку мыши и выбрать команду Свойства.

Для текстового поля можно задать вид вводимой информации, максимальную длину, автоматически появляющийся текст. (рис. 14)


Р
ис.14. Диалоговое окно Параметры текстового поля



Для поля Флажок можно задать его точный размер, а также начальное состояние (включен или выключен).

Для поля со списком задаются элементы, входящие в список (рис.15).


Р
ис.15 Диалоговое окно Параметры поля со списком



Для любого вставленного поля, выделив его, можно задать нужный размер, шрифт; тогда вводимые в него символы будут изображаться в указанном формате. Для лучшего выделения полей на экране и печати может быть нажата кнопка Затенение полей формы на панели Формы.

После создания форма может быть защищена от изменений, т.е. ввод информации возможен только в поля формы. Для этого надо нажать кнопку Защита формы на панели Формы или задать команду Сервис, Установить защиту и включить параметр Разрешить ввод данных в поля форм. Для снятия защиты с документа задать команду Сервис, Снять защиту. Вид готовой формы с затемненными полями для ввода представлен на рис.16.


Р
ис.16. Вид формы с затененными полями для ввода


^ 3. Создании главного и вложенных документов.

Создайте папку для хранения главного и вложенных документов под именем Сложный документ.

В этой папке создайте документ Word c именем Элементы языка.

Введите следующий текст:

2.1. Элементы языка и структура программ

2.1.1. Переменные

Переменная — это область машинной памяти, кото­рой для удобства обращения с ней присвоено сим­вольное имя.

2.1.2. Константы

Константа — это область памяти, которая имеет не­изменяемое значение.

2.1.3. Последовательность выполнения операций

Если выражение содержит несколько операций, то они выполняются в порядке уменьшения уровня старшинства.

Создайте документ Word c именем Объектное программирование.

Введите следующий текст:

    1. Несколько слов об объектном программировании

В язык Visual Basic добавлены элементы и средства объектно-ориентированного программирования.

2.2.1. Объекты

Объект представляет элемент приложения, как на­пример лист, ячейка, диаграмма, форма или отчет.

2.2.2. Свойства

Объекты характеризуются свойствами. Например, линия характеризуется цветом и длиной, окружность -радиусом.

Закройте документы. Эти документы будут вложенными.

Создайте структуру нового главного документа следующим способом.

На панели инструментов Стандартная нажмите кнопку Создать. В меню Вид выберите команду Структура. Введите заголовки для главного документа Язык Visual Basic. После ввода заголовка необходимо нажимать клавишу ENTER. Microsoft Word выполнит форматирование заголовка встроенным стилем заголовка Заголовок 1.

Сохраните документ под именем Язык Visual Basic. Закройте документ.

Выполните^ Добавление вложенных документов в главный документ. Откройте главный документ и выберите пункт Структура в меню Вид. Если вложенные документы свернуты, нажмите кнопку Развернуть вложенные документы на панели Структура. Щелкните место, куда следует вставить документ (после заголовка Язык Visual Basic). Это должна быть пустая строка. На панели инструментов Структура нажмите кнопку Вставить вложенный документ. В поле Имя файла введите имя документа, который требуется вставить Элементы языка, и нажмите кнопку Открыть. Перед документом будет вставлен разрыв на следующей странице, а после него — разрыв на текущей странице. Аналогичным образом вставьте документ Объектное программирование.

^ Сохранение главного документа. В меню Файл выберите команду Сохранить как. Выберите расположение, указанное в начале данной процедуры, введите имя файла для главного документа и нажмите кнопку Сохранить. При сохранении главного документа Word автоматически сохраняет и все вложенные документы и каждому вложенному документу автоматически присваивается имя файла, состоящее из первых знаков заголовка документа. Например, вложенный документ, который начинается с заголовка «Элементы языка», будет назван «Объектное программировани».

Создание вложенного документа из заголовка структуры. Для создания вложенного документа из заголовка структуры необходимо, чтобы у главного документа была структура. В меню Вид выберите команду Структура.

Введите после заголовка главного документа следующий текст:

1. Введение

Эта книга посвящена языку Visual Basic и способам его применения для программирования макроопределений в про­дуктах пакета Microsoft Office.

Заголовок 1. Введение понизьте до уровня 2, отформатированного стилем «Заголовок 2», в выделенном тексте для нового заголовка, отформатированного стилем «Заголовок 2», будет создан отдельный вложенный документ. Выделите в главном документе заголовок и текст, которые должны быть размещены во вложенном документе. На панели Структура нажмите кнопку Создать вложенный документ. Microsoft Word вставляет в начале и в конце каждого вложенного документа сплошной разрыв раздела. Если кнопка Создать вложенный документ недоступна, необходимо сначала нажать кнопку Развернуть вложенные документы. После добавления вложенного документа в главный документ не перемещайте и не удаляйте его без предварительного удаления из главного документа. Переименовывать вложенные документы можно только из главного документа.

Аналогичным образом добавьте в конец документа вложенный документ, содержащий следующий текст:

3. Приложение А

Список функций Visual Basic (к пунктам 2.1.1. Переменные и 2.1.2. Константы).


Сохраните главный документ.

Закройте его.

Перейдите в папку Большой документ и посмотрите какие файлы там сохранены.

Создайте новый документ на базе шаблона Титульный лист и заполните поля форм для своей лабораторной работы. Сохраните его в отдельном файле.

Предъявите работу преподавателю.




Скачать 68,9 Kb.
оставить комментарий
Дата29.09.2011
Размер68,9 Kb.
ТипЛабораторная работа, Образовательные материалы
Добавить документ в свой блог или на сайт

плохо
  2
не очень плохо
  1
хорошо
  2
отлично
  1
Ваша оценка:
Разместите кнопку на своём сайте или блоге:
rudocs.exdat.com

Загрузка...
База данных защищена авторским правом ©exdat 2000-2017
При копировании материала укажите ссылку
обратиться к администрации
Анализ
Справочники
Сценарии
Рефераты
Курсовые работы
Авторефераты
Программы
Методички
Документы
Понятия

опубликовать
Загрузка...
Документы

Рейтинг@Mail.ru
наверх