Создание колонок icon

Создание колонок


Смотрите также:
Задание параметров в окне пользовательских пропущенных значений 9 > 2 Формат колонок 9 2...
А жизнь так коротка...
Реферат По технологии На тему: «Про сайт»...
Курсы дополнительного образования наименование...
Лабораторная работа для студентов очной и формы обучения...
«Синхронізація музичних інструментів з комп'ютером»...
Реферат по биологии на тему: «Генная инженерия»...
“Создание модели здоровьесберегающего иноязычного образования”...
Создание презентации PowerPoint...
Автоматизация банковской деятельности...
Автоматизация банковской деятельности...
«Гипертекстовые документы»...



Загрузка...
скачать
Лабораторная работа №5

Использование встроенных средств рисования, OLE-технологии, шаблонов и форм текстового процессора Microsoft Word.

Цель работы: изучение особенности работы в текстовом редакторе Microsoft Word, инструментов панели «Рисование» и методов создания рисунков, приемов разработки формы на базе сложного документа, работы с разрывами, а так же технологии создания OLE-объектов.

Теоретические сведения

Создание колонок


Оформление текста в несколько колонок улучшает его читабельность и часто используется в газетах и журналах. Для организации колонок следует выделить часть текста или весь текст и обратиться к меню Формат/Колонки... В открывшемся диалоговом окне надо выбрать количество колонок и указать необходимость задания разделителя. Если колонки организуются для части текста, то эта часть оформляется как новый раздел, т.е. как область с отличающимися от остального текста параметрами форматирования.

Если текст, оформляемый в несколько колонок невелик по объему, то Word может распределить его по колонкам неравномерно. Для балансировки текста следует установить курсор в позицию разрыва колонки и выполнить команды меню Вставка/Разрыв/Новую колонку.

Если при организации двухколоночного раздела допущена ошибка, то его следует не только преобразовать в одноколоночный, но и удалить знаки начала и конца раздела. Эти знаки мешают дальнейшей работе с разделами в документе. Границы раздела лучше видны, если из режима "Разметка страницы" переключиться в режим "Обычный".

Процедуру удаления границ разделов во всем документе можно автоматизировать. Для этого обратитесь к меню Правка/Замена, в поле "Что:" через кнопку "Специальный" вставьте "Разрыв раздела" (поле "Заменить на:" должно быть пустым) и нажмите кнопку "Заменить все".
^

Создание разделы


Некоторые виды форматирования текста требуют организации специальной области, в которой параметры форматирования будут отличаться от других областей. Эти области называются разделами. Выше было показано, что если документ содержит одновременно обычный (одноколоночный) текст и двухколоночный, то каждый из них должен содержаться в отдельном разделе. При оформлении многоколоночного текста раздел организуется автоматически.

Другой ситуацией, когда требуется создание раздела, является применение книжной и альбомной ориентации страниц внутри одного документа. Например, в документ с книжной ориентацией страниц требуется добавить страницу с альбомной ориентацией, содержащую таблицу.
^

Создание рисунков средствами панели «Рисование»


Панель «Рисование» вызывается кнопкой «Рисование» на основной панели инструментов. Принципиальная особенность рисунков, создаваемых инструментами панели «Рисование», в отличие от рисунков в графическом редакторе Paint в том, что это векторная графика. Ее отличие от растровой графики в том, что рисунки хранятся в памяти компьютера не в виде отдельных точек (пикселей), а в виде математических зависимостей. Поэтому векторные рисунки масштабируются без искажения, могут быть разделены на отдельные независимые детали и, обычно, требуют меньше памяти для хранения, чем растровые.


^

Общая методика создания рисунка


Общая методика создания рисунка заключается в подготовке отдельных элементов рисунка и в их последующей сборке. Рисование элементов лучше выполнять на свободном участке страницы, причем мелкие элементы - в увеличенном масштабе.

По мере создания, детали рисунка необходимо группировать в блоки (кнопка «Действия»), а перед сборкой регулировать размеры блоков протяжкой за маркеры области рисунка.

Любые операции по изменению имеющихся объектов (размеров, заливки и т.д.) выполняются с предварительным выделением объекта. Если редактируемый элемент сгруппирован с другими элементами рисунка, то этот блок следует разгруппировать. Выделение нескольких несгруппированных деталей выполняется щелчками мыши при нажатой клавише Shift или протяжкой мыши с помощью инструмента «Выбор объекта».

Заливка для объектов векторной графики выполняется иначе, чем для растровой. В редакторе Paint при заливке не имело значения, каким инструментом нарисован объект: важно, чтобы заливаемый контур был замкнут. Для заливки объектов, создаваемых средствами панели «Рисование», необходимо использовать инструменты, предусматривающие эту операцию: прямоугольник, овал, полилиния и некоторые другие. Замкнутый контур, созданный обычной линией, заливаться не будет. С другой стороны, даже не замкнутый контур, созданный полилинией, может быть закрашен инструментом «Заливка». При этом граница заливки на не замкнутом участке проходит по линии, образованной отрезком прямой, соединяющей начальную и конечную точки полилинии.
^

Вставка и редактирование изображений из файлов


Вставка в текст рисунка из файла выполняется командой Вставка/Рисунок/Из файла. В окне «Добавить рисунок» следует указать файл и установить режим вставки:

  • связать с файлом — сам рисунок не копируется, но на него делается ссылка;

  • вставить файл — файл вставляется в документ.

^ Word допускает вставку рисунков различных форматов: wmf, jpeg, bmp, pcx, tiff, gif и некоторых других. Иногда возникает необходимость обработки рисунка в профессиональном графическом редакторе, а затем вставке его в документ Word.

Другим способом вставки рисунков является вставка через буфер обмена. При этом можно воспользоваться меню Правка/Вставить или Правка/Специальная вставка. В последнем случае доступны дополнительные варианты вставки рисунка.
^

Взаимное расположение рисунка и текста


Рисунок может быть расположен поверх текста, за текстом или с обтеканием текста. Чаще всего, рисунки располагаются в одном из режимов обтекания. Однако, иногда требуется поместить рисунок за текстом, например, для задания фона. Изменить взаимное расположение рисунка и текста можно через меню Формат/Рисунок и с помощью инструмента Действия/Порядок. Иногда требуется применить оба способа.
^

Работа с фигурным текстом (WordArt)


Cредства для создания фигурного текста содержатся в инструменте "Добавить объект WordArt". В некоторых версиях текстового процессора Word этот инструмент назывался "Фигурный текст". Наиболее полный набор инструментов для работы с фигурным текстом дает панель "WordArt", доступ к которой выполняется через меню Вид/Панели инструментов.

^

Создание форм и шаблонов

Основные понятия


Шаблон — это файл, содержащий настройки Word. Любой документ Word создается на основе некоторого шаблона. Большинство создается на основе шаблона Normal.dot, который загружается автоматически, например, при нажатии кнопки "Создать" на стандартной панели инструментов. При открытии документа, основанного на некотором шаблоне, последний загружается автоматически.

Форма — это защищенный документ, содержащий поля для ввода информации и применяемый для заполнения бланков, таблиц и других типовых документов.

Шаблоны и формы служат для автоматизации разработки типовых документов и для организации работы с ними неквалифицированных пользователей ЭВМ.

В редакторе Word имеется набор шаблонов для часто используемых документов. Как правило, эти шаблоны хранятся в папке MSOffice\Шаблоны. Однако, пользователь может создавать и свои собственные шаблоны.

В шаблоне может храниться следующая информация:

  • стили;

  • параметры страницы и бумаги;

  • обычный текст, таблицы, рисунки;

  • формы;

  • макросы;

  • пользовательские меню;

  • панели инструментов и другая информация.

Стиль — это набор форматирующих команд, сохраняемых под своим именем для многократного использования. Стиль определяет внешний вид документа. Шаблон Normal.dot содержит несколько стилей, в том числе стиль "Обычный", используемый при создании большинства документов.
^

Создание форм


Формой может быть любой документ, содержащий поля. Существует три типа полей: для ввода текста; флажок; раскрывающийся список. Порядок вставки полей достаточно прост: установите курсор в позицию для ввода поля формы, обратитесь к меню Вид/Панели инструментов/Формы. На панели "Формы" выберите один из трех типов полей. Поскольку формы очень часто создаются для быстрой разработки типовых документов, на панели "Формы" имеются инструменты для вставки и редактирования таблиц и для защиты формы.

Построение формы проходит в 3 этапа:

  • создание текстовой основы (структуры) формы;

  • вставка и настройка полей формы;

  • защита и сохранение формы.

Первый этап является обычным оформлением документа. Для форматирования сложных документов часто используются таблицы.

О вставке полей формы говорилось выше, поэтому остановимся на их настройке.

Для настройки поля следует на панели "Формы" выбрать "Параметры поля формы". В зависимости о того какое поле выделено, откроется одно из трех окон для настройки.

Окно "Параметры текстового поля" содержит следующие основные поля:

  • "Тип" — позволяет выбрать тип поля формы. Если, например, выбрать числовой тип, то при вводе текста в него будет выдано сообщение об ошибке;

  • "Текст по умолчанию" — задает текст, который будет появляться в поле перед его заполнением;

  • "Максимальная длина" — максимальное количество символов, которое разрешается вводить в поле;

  • "Формат текста" — позволяет выбрать различные форматы текста для более жесткого контроля за вводом.

Окно "Параметры флажка" позволяет настроить размер флажка и его состояние по умолчанию: "Снят" или "Установлен". Флажок может быть связан с макросом, текстом справки и т.д.

Окно "Параметры поля со списком" позволяет задать раскрывающийся список, содержащий до 25 значений, из которых пользователь может выбирать нужное значение при заполнении поля формы. Имеется возможность добавления, удаления и изменения порядка следования значений.

Во всех окнах для настройки параметров полей имеется кнопка "Текст справки", с помощью которой можно подготовить справку по каждому из полей (в печатных документах этой цели служат подстрочные надписи). В окне "Текст справки для поля формы" имеются две вкладки: "Строка состояния" и "Клавиша F1". Текст справки, введенный на первой вкладке будет автоматически выводиться в строке состояния при активизации соответствующего поля. Справка, введенная на второй вкладке, выводится в отдельном окне при нажатии клавиши F1.

Созданный документ можно назвать формой, если он имеет поля формы и защищен. В незащищенном документе поля не будут проявлять необходимых свойств. Кроме того, защищенная форма отличается тем, что ее нельзя редактировать, а можно только заполнять поля формы. Защитить форму можно двумя способами.

Первый способ:

  • выбрать меню Сервис/Установить защиту... ;

  • в окне "Защита документа" установить метку "Запретить любые изменения, кроме ввода данных в поля форм" и нажать "Ok";

  • при необходимости ввести текст пароля для открытия документа.

Второй способ заключается в выборе инструмента "Защита формы" на панели "Формы".

Для редактирования структуры формы защиту следует снять повторным нажатием на инструмент "Защита формы".
^

Технология связывания и внедрения объектов (технология OLE)


Теоретические сведения по технологии OLE находятся в лабораторной работе под названием «^ Стандартные приложения Microsoft Windows. Архивация данных»

Задание

Изучить элементы панели «Рисование» на примере создания рисунка. Создать личную печать при помощи инструмента WordArt, а также шаблон для новых документов, содержащий формы. Получить практические навыки внедрения OLE-объектов.


Порядок выполнения

  1. Работа с элементами панели «Рисования»:

    • Откройте программу Microsoft Word.

    • Если панель «Рисования» отсутствует при создании документа Word то обратитесь к меню Вид/Панели инструментов/Рисование.

    • Используя возможности фигурного текста WordArt, оформить заголовок Вашего отчета. Написать тему лабораторной работы.

    • Сохранить документ под именем «Отчет№5.doc»

    • Нарисовать рисунок согласно своему варианту (см. «Приложение 1», «Варианты задания к лабораторной работе»), используя средства панели «Рисования».

    • Сгруппировать элементы рисунка, используя контекстное меню.

    • Подготовить печать, аналогичной показанной на рисунке ниже. Для этого на панели WordArt следует нажать кнопку «Добавить объект WordArt», а в окне «Коллекция WordArt» выбрать образец стиля, расположенный в верхней левой ячейке и нажать Ok.



  • В окне «Изменение текста WordArt» задайте тип шрифта Arial, размер – 12, удалите имеющийся текст и впишите три абзаца:

  Белгородский государственный университет
ФИО студента
Л и ч н а я   п е ч а т ь


  • В начале и в конце первого абзаца добавьте по два пробела. В третьем абзаце буквы запишите через пробел, а между словами сделайте три пробела. Нажмите Ok.

  • На панели WordArt щелкните по значку «Форма WordArt» («Текст – Автофигура») и в открывшейся таблице выберите форму «По кнопке». Растяните полученный фигурный текст до требуемых размеров и выполните заливку черным цветом. Черные точки на печати добавьте инструментом «Овал» с заливкой;

  • Откройте окно «Формат объекта WordArt» через контекстное меню на личной печати. Поставьте объекту произвольное «Обтекание» во вкладке «Положение»;

  • Сгруппируйте два овала с объектом WordArt.

  1. Работа с разрывами: формирование разделов, колонок и др:

  • После того как печать нарисована, ставим курсор в конец документа и выполняем следующие действия:

  • Вставка/Разрыв/Новый раздел со следующей страницы;

  • Файл/Параметры страницы/Размер бумаги/Ориентация – альбомная;

  • На созданном разделе наберите на память любое стихотворение.

  • Выделить весь текст и обратиться к меню Формат/Колонки.... В открывшемся диалоговом окне надо выбрать количество колонок (на ваше усмотрение) и указать необходимость задания разделителя. В случае если текст не расположился в две колонки, искусственно добавьте в его середину разрыв колонки;

  • Вставить в начало текста «Буквицу» через меню Формат/Буквица....

  • Выбрать меню Вставка/Разрыв/Новый раздел со следующей страницы;

  • Выбрать меню Файл/Параметры страницы/Размер бумаги/Ориентация – книжная;

  1. Использование редактора формул и других OLE-объектов:

  • В новом разделе верните отображение содержимого в одну колонку и с помощью редактора формул Вставка/Объект…/Microsoft Equation 3.0 записать формулу согласно своему варианту (см. «Приложение 2», «Варианты задания к лабораторной работе»).

  • Сделайте Скриншот окна Вставка объекта.

  • Зайдите в Вставка/Объект…/Bitmap Image (Точечный рисунок) появится OLE-объект Paint. Вставить в него изображение из буфера обмена, которое необходимо отредактировать следующим образом: на экране должно остаться только окно Вставка объекта размером 14х10 см. Примерный вид изображения представлен на рисунке ниже.



  1. Создание шаблонов и форм:

  • Выполнить Файл/Создать.... В окне "Создание документа" зайдите в общие шаблоны и установите метку «Шаблон», найти и выделите шаблон «Новый документ», на основе которого будет создан личный шаблон. Нажать «Ok».

  • Зайти в Файл/Параметры страницы и сделайте все поля по 2 см. Задать 14 размер шрифта типа Arial.

  • Обратиться к меню Вид/Панели инструментов/Формы.

  • Необходимо создать документ, используя все возможности панели инструментов Формы. Для этого создадим таблицу «Данные сотрудников ФУП» рисунок приведен ниже:



  • Название таблицы и ее разделов записываются, используя текстовое поле инструмента Формы. Двойным кликом мыши по текстовому полю войти в его свойства, где ввести исходный текст и убрать галочку в поле «Разрешить изменения». Нажмите «Ok».

  • После названия таблицы вставить еще одно текстовое поле, где выбирать тип «Текущая дата». Нажмите «Ok».

  • В столбце «ФИО» и «Домашний адрес» в каждой ячейке так же вставить текстовое поле и ничего в его настройках не изменять, то есть оно будет разрешено к изменению.

  • В столбце «Должность» напротив каждой фамилии вставьте поле со списком в который добавить все известные ВАМ должности сотрудников. Нажать «Ok».

  • В столбце «Наличие ученой степени» в каждой ячейке необходимо вставить флажок, оставив его свойства без изменения.

  • Убирать затемнение полей формы и устанавливаете защиту формы.

  • Выберите меню Файл/Сохранить как... и папку, в которой нужно сохранить шаблон. В поле «Имя файла» введите название «Мой шаблон.dot» и нажмите "Ok". Расширение .dot будет добавлено к имени шаблона автоматически, если вы правильно выбрали тип документа;

  • Выберете меню Файл/Создать.... В окне «Создание документа» выберите Выбор документа, укажите путь к Вашему шаблону, выделите его и нажмите «Ok».

  • Сохранить документ с именем «На основе шаблона.doc» в вашей личной папке.

  1. Доложить преподавателю об окончании выполнения работы.

Содержание отчета

  1. Название и цель лабораторной работы;

  2. Рисунок по варианту и Личная печать;

  3. Произвольное стихотворение, оформленное при помощи разрывов и колонок;

  4. Результаты выполнения П.3. «Порядка выполнения работы»

  5. Лист документа На основе шаблона.doc с результатом создание документа-формы на основе шаблона Мой шаблон.dot;

  6. Выводы.


Контрольные вопросы

  1. Как можно оформить текст в несколько колонок?

  2. В каких случаях в документе оформляется новый раздел?

  3. Как можно сбалансировать текст в колонках?

  4. Как следует поступить, если при организации двухколоночного раздела допущена ошибка?

  5. Как можно удалить границы разделов?

  6. В каких случаях в документе должны быть оформлены разделы?

  7. Как можно добавить страницу с альбомной ориентацией в документ с книжной ориентацией страниц?

  8. Как вызвать панель "Рисование"?

  9. В чем отличие рисунков, создаваемых инструментами панели "Рисование" от рисунков в графическом редакторе Paint?

  10. Чем отличается векторная графика от растровой?

  11. Как хранятся в памяти компьютера векторные рисунки?

  12. Какова общая методика создания рисунка?

  13. Как сгруппировать детали рисунка?

  14. Каковы особенности редактирования рисунка?

  15. Как выполняется заливка объектов, созданных средствами панели "Рисование"?

  16. Как вставить в текст рисунок из файла?

  17. Рисунки каких форматов можно вставить в документ Word?

  18. Как может быть расположен рисунок по отношению к тексту в документе?

  19. Как изменить взаимное расположение рисунка и текста?

  20. Как получить доступ к средствам для создания фигурного текста?

  21. Какова общая методика использования фигурного текста?

  22. Что такое шаблон?

  23. На основе какого шаблона создается большинство документов?

  24. Что называется формой?

  25. Для чего служат шаблоны и формы?

  26. Какая информация может храниться в шаблоне?

  27. Что называется стилем?

  28. Какие типы полей может содержать документ?

  29. Как вставить поле?

  30. Через сколько этапов проходит построение формы?

  31. Как выполняется создание текстовой основы формы?

  32. Каковы возможности настройки формы?

  33. Как защитить форму?

  34. Как создается шаблон?

  35. Как загрузить шаблон?

  36. Что такое технология OLE?

  37. Что такое OLE-объект, OLE-сервер, OLE-клиент?

  38. Какими способами можно внедрять и связывать внешние объекты с документом-приемником?

  39. Перечислите и охарактеризуйте способы связи объекта OLE-сервера с документом-приемником.

  40. Сравните способы внедрения и связывания объектов.

  41. В какой степени поддерживают технологию OLE различные приложения Windows? Приведите примеры.

  42. Каковы возможности OLE-технологии?

Варианты задания к работе

Приложение 1


Вариант

рисунка

1

C10

2

B10

3

A10

4

C9

5

B9

6

A9

7

C8

8

B8

9

A8

10

С7

11

B7

12

A7

13

C6

14

B6

15

A6

16

C5

17

B5

18

A5

19

C4

20

B4

21

A4

22

C3

23

B3

24

A3

25

C2

26

B2

27

A2

28

C1

29

B1

30

A1


Приложение 2

Вариант

Формула

Вариант

Формула



































































































Скачать 171.8 Kb.
оставить комментарий
Дата28.09.2011
Размер171.8 Kb.
ТипЛабораторная работа, Образовательные материалы
Добавить документ в свой блог или на сайт

Ваша оценка этого документа будет первой.
Ваша оценка:
Разместите кнопку на своём сайте или блоге:
rudocs.exdat.com

Загрузка...
База данных защищена авторским правом ©exdat 2000-2017
При копировании материала укажите ссылку
обратиться к администрации
Анализ
Справочники
Сценарии
Рефераты
Курсовые работы
Авторефераты
Программы
Методички
Документы
Понятия

опубликовать
Загрузка...
Документы

Рейтинг@Mail.ru
наверх