Лекция 5 icon

Лекция 5



Смотрите также:
Вводный семинар, вводная лекция, занятия по целе-полаганию, лекция-беседа...
Лекция 20. 03. 12. Модели для исследования и оценки в pr лекция 27. 03. 12...
Лекция Фьючерсные контракты Лекция Фьючерсы на акции...
Курс лекций Лекция Введение в земледелие. Лекция Научные основы земледелия...
Лекция Историография как научная дисциплина Лекция Исторические знания в Древней Руси...
Лекция Сионизм в оценке Торы Лекция Государство Израиль испытание на прочность...
Лекция Введение в социологию 6 Лекция Становление и основные этапы развития социологии. 20...
План лекционных занятий Лекция Развитие аудиальных средств информации. Лекция 2...
Курс лекций Москва 2008 Содержание Лекция Введение 4 Лекция Научные знания в средневековой Руси...
Лекция Историография как научная дисциплина Лекция Исторические знания в Древней Руси...
Лекция №2 от 25. 09. 2008г. Упанишады...
Лекция Введение в бд и субд. Модели данных 2 Лекция Инфологическая модель «Сущность-связь»...



скачать

Лекция 5

Техника выделения.
Использование инструментов выделения.


В Photoshop практически ни одна серьезная операция не обходится без выделения некоторой области. Поэтому для выделения предусмотрены сразу несколько инструментов панели инструментов и отдельный пункт верхнего меню — "Выделение (Select)". 

Инструменты выделения областей.
1.
Rectangular marquee (Прямоугольная область)
Действие инструмента: щелчок мышкой в точке, от которой хотите начать выделение, и не отпуская мышь, тянуть до тех пор, пока не посчитаете нужным закончить выделение. В результате видите на экране прямоугольную область, по краям которой "бегают муравьи" - значит, эта область выделена. Если необходимо выделение, имеющее форму квадрата, необходимо в процессе выделения держать нажатой клавишу SHIFT. Если вместо SHIFT нажата клавиша ALT, то выделение будет начинаться с точки первого щелчка мышью и далее "во все четыре стороны" относительно этой точки.
Допустим, мы хотим выделить "рамочкой" снежинку. Выбираем инструмент ,нажимаем ALT, ставим курсор (он, кстати у нас теперь в виде крестика) в центр снежинки, нажимаем левую кнопку мыши и ведем вправо вниз (как бы на юго-восток), отпускаем мышку, когда полученная рамка зайдет за края снежинки. Получилось? Если нет, попробуйте еще; гарантирую, что получится. А если вместе с ALT держать еще и SHIFT, то выделение будет в форме квадрата. А если еще и ПРОБЕЛ удерживать (можно и не одновременно с ALT и SHIFT), то во время создания выделения (когда "тянем") можно корректировать его расположение. После того, как появилась область выделения, можно создать новую, не потеряв предыдущую. Для этого нужно второе выделение производить с нажатой клавишей SHIFT. И если две области выделения пересекаются, то они объединяются в одно. Вот сколько возможностей!
2. Elliptical marquee (Эллиптическая область).
См. п.1. Всё то же самое, за исключением формы выделения (она будет овального/круглого вида).
3.  Single row (Одиночная строка).
Выделяет очень тонкую горизонтальную полоску вдоль всего документа.
4. Single columm (Одиночный столбец). 

Чтобы избавиться от выделения, необходимо
а) создать новое выделение.
б) нажать CTRL+D, что равноценно выбору меню Выделение>Убрать выделение (Select>Deselect). 


^ Создание выделений произвольной формы

Это были инструменты для создания выделений правильной формы. Они используются не так часто, как следующие: 
1. Lasso (Лассо). 
Принцип действия тот же, что и у любого из инструментов рисования. Этим инструментом можно обвести некоторую область. Замыкая ее, получаем, что все, что попадет внутрь этой области, будет выделено. И даже если не замкнуть "линию", выделение будет создано автоматически (туда попадет максимальное количество пикселей, которое, по мнению Photoshop, должно быть выделено, судя по вашим движениям).
^ 2. Poligon lasso (Полигональное лассо).
Выделение осуществляется щелчками, и имеет вид любого многоугольника (выпуклого или вогнутого), причем вершины этого многоугольника образованы именно щелчками. В отличие от лассо, выделение не состоится, пока первая точка не совпадет с последней, т.е. пока не замкнется фигура (либо замкнуть выделение двойным щелчком).
^ 3. Magnetic lasso (Магнитное лассо).
Штука хитрая. Но неудобная (хотя многим нравится). Допустим, у нас картинка с черной кляксой на белой бумаге. С помощью этого инструмента можно выделить кляксу. Выбираем , первый щелчок мышкой делаем на "стыке" кляксы с бумагой. Отпускаем мышку и далее, ничего больше не делаем, кроме того, что просто обводим курсором кляксу. Лассо само "цепляется" по контуру черного, действуя по цветовому принципу. Иногда можно щелкать кое-где по контуру, как бы создавая опорные точки. В завершение остается только опять же вернуться к начальной точке и щелкнуть по ней мышкой.
4. Pen. Инструменты группы "перо"



Перо (Pen) предназначен для создания новых контуров.

  • Стрелка (Direct Selection): этот инструмент применяется для выделения и перемещения узлов и управляющих маркеров контура. Нажмите и удерживайте клавишу Cmd (в системе Mac OS) или Ctrl (в системе Windows) в то время, как активен любой другой инструмент из данной группы, и этот инструмент временно превратится в инструмент Стрелка (Direct Selection).

  • Перо+ (Add Anchor Point): используется для добавления новых узлов в состав контура.

  • Перо- (Delete Anchor Point): используется для удаления узлов из состава контура.

  • Угол (Convert Anchor Point): с помощью данного инструмента можно изменять тип узлов контура после их создания. Например, можно превратить угловой узел в сглаженный, сглаженный - в точку перегиба, и т. д. В следующем разделе вы подробнее узнаете об этом инструменте.

Можно использовать два способа переключения между перечисленными инструментами: либо щелкнув на кнопке активного инструмента работы с контурами и удержав кнопку мыши некоторое время нажатой, что ведет к появлению дополнительной панели инструментов, либо последовательно нажимая на клавишу P в латинском регистре, в результате чего происходит циклическая активизация инструментов группы Перо (Pen).
Лучший способ изучить данные инструменты - это испытать их на практике, так что приступим к выполнению упражнения. Я думаю воспользоваться примером изображения объекта с криволинейными границами: вам придется потрудиться и отделить от фона изображение головы и плеч персонажа книжной графики, представленного на рис. ниже.


Тестовое изображение: сможете ли вы создать контур вокруг головы этого странного парня?

  1. Начинаем с работы с инструментом Перо (Pen) и вручную рисуем контур, более или менее точно воспроизводящий форму силуэта объекта, который требуется выделить, как показано на рис.ниже. Тем не менее, как видно из рисунка, в области шеи линии легли неаккуратно, да и в остальных местах некоторые участки контура отклонились от границ рисунка как внутрь, так и наружу.


Начальный вид контура, созданного с помощью инструмента Перо (Pen)

  1. Сначала надо посмотреть, насколько возможна коррекция формы контура за счет простого перемещения узлов и маркеров, управляющих свойствами узлов. Выбираем инструмент Стрелка (Direct Selection) и сосредотачиваемся на участке контура в верхней части головы, где линия контура располагается недостаточно ровно. Выделяю самый верхний узел, установив на него указатель и щелкнув кнопкой мыши. Квадратик, обозначающий выделенный узел, заливается цветом в отличие от остальных узлов, квадратики которых остаются прозрачными.

ЗАМЕЧАНИЕ Если вы построили контур, но не видите ни одного узла, это просто означает, что контур не выделен. Выберите инструмент Стрелка (Direct Selection), щелкните на любой точке линии контура, и узлы станут видны.

  1. По обе стороны выделенного узла появятся управляющие маркеры. Щелкаем на правом маркере и пробуем перетаскивать его в разные стороны, как показано на рис. ниже, следя, каким образом это сказывается на форме кривой. Когда линия контура точно ложится на край объекта, отпускаем кнопку мыши.


Перемещение управляющих маркеров помогает исправить форму одних частей контура, но неблагоприятно сказывается на других

  1. Исправили форму одной стороны контура головы, но, к сожалению, другая сторона контура из-за этого стала еще хуже прилегать к краю объекта. Хорошо еще, что можно щелкнуть на втором маркере того же узла и переместить его независимо от первого, слегка подправив форму контура. Затем аналогичным образом отредактируем остальные кривые, выделяя узел за узлом и перемещая управляющие маркеры рис. ниже.


После перемещения некоторых маркеров контур выглядит несколько лучше

  1. Инструмент Стрелка (Direct Selection) позволяет делать нечто большее, чем перемещение маркеров узлов. С его помощью можно перемещать и сами узлы контуров. При активном инструменте Стрелка (Direct Selection) вы можете щелкнуть на узле и перетащить его в новое положение. Переместив самый верхний узел контура немного вправо, а узел, располагающийся слева от верхнего, - чуть-чуть вверх, можем добиться того, что контур будет прилегать к краю головы достаточно хорошо рис. ниже.



Перемещение узлов и управляющих маркеров обычно позволяет решить большую часть проблем подгонки формы контура


ЗАМЕЧАНИЕ Программа Photoshop позволяет также перемещать одновременно несколько узлов. Чтобы выделить более одного узла, удерживайте клавишу Shift во время щелчка на очередном узле или растяните рамку вокруг группы узлов. После этого все выделенные узлы можно перемещать как одно целое.

  1. Теперь контур выглядит гораздо лучше, однако на правой щеке персонажа все еще остается дефектный фрагмент, который, казалось бы, невозможно исправить. На самом деле все, что требуется, - это добавить еще один узел в районе щеки, чтобы дополнительно изогнуть фрагмент контура. Нет проблем! Выбираем инструмент Перо+ (Add Anchor Point), щелкаем на участке контура, где должен появиться узел, и перетаскиваем указатель, чтобы узел стал сглаженным. Затем слегка перемещаем узел наружу, настраиваю положение маркеров - и кривая контура замечательно повторяет изгиб щеки персонажа, как показано на рис. ниже.


Иногда лучшим решением проблемы является вставка дополнительного узла

Используя инструмент Перо+ (Add Anchor Point), помните, что, если вам нужен угловой узел, он добавляется простым щелчком. Но если вам нужен сглаженный узел, необходимо щелкнуть и протащить мышь. Кроме того, учитывайте, что нельзя сразу же создать узел - точку перегиба. Вместо этого следует добавить сглаженный узел, а затем преобразовать его в точку перегиба с помощью инструмента Угол (Convert Anchor Point). Подробнее речь об этом пойдет в следующем разделе.
Если вам потребуется удалить узловую точку, то это очень просто сделать при помощи инструмента Перо- (Delete Anchor Point). Просто щелкните на узле, и он тут же исчезнет. При этом кривая контура изменит форму в соответствии со свойствами оставшихся узлов.

^ Команды меню при работе с выделениями. "Горячие" клавиши.

Трудно работать в Photoshop, не используя клавиатуру. И особенно это касается техники выделения. Иногда просто необходимо совмещать два действия, и тогда уже без специальных сочетаний клавиш не обойтись.
Каждый пункт верхнего меню соответствует набору определенных (тематически связанных) операций. Так и меню Выделение\Select отвечает за различные действия, связанные с выделением.

Далее приведена таблица соответствия команд выделения клавиатурным комбинациям. В нижней ее части вы найдете сочетания клавиш, не связанные с верхнем меню, то есть некоторые действия осуществимы только с их помощью и их (сочетания клавиш) можно назвать незаменимыми.

Действие

^ Команда меню

"Горячие" клавиши

Выделить всё.
(весь активный слой)

Выделение > Все

Select > Select All

CTRL+A 

Примечание. Этой командой можно выделить все содержимое лишь одного слоя — активного на данный момент. Если вы хотите выделить несколько слоев, то необходимо выполнить следующее:
1. выделяем первый слой (CTRL+щелчок по имени слоя);
2. при нажатой клавише SHIFT (указывает на добавление) еще один CTRL+щелчок по имени следующего слоя.

Отменить выделение

Выделение > Убрать выделение

Select > Deselect 

CTRL+D

Вернуть последнее отмененное выделение. Используется редко. 

Выделение > Выделить заново

Select > Reselect

SHIFT+CTRL+D 

Инвертировать выделение. Допустим была выделена красная рожица на зеленом фоне, будет выделено все, кроме рожицы. Т.е. фон.

Выделение > Инвертировать выделение

Select > Inverse

SHIFT+CTRL+I

Выполнить выделение по цветовому диапазону.

Выделение > Цветовой ряд

Color Range

Нет комбинации. 

Растушевка выделения.

Выделение > Перо\Растушевать

Select > Feather

Нет комбинации. 

Равномерное увеличение выделенной области во все стороны.

Выделение > Увеличить

Select > Grow

Нет комбинации. 

Использование операции можно оценить в такой ситуации: на бесцветном фоне (Transparent) нарисуем "размазанной" кистью какую-нибудь бяку (неважно). CTRL+D по имени слоя с бякой — выделилась бяка, но размазанные края остались без выделения. Выбираем Select > Grow. Выделение увеличилось, захватив всю "размазанность".

То же, но более чувствительное к цвету выделение

Выделение > Подобно

Select > Similar

Нет комбинации.

Трансформирование выделения. Именно выделения! Сама область "под ним" остается неизменной.

Выделение > Преобразовать выделение

Select > Transform Selection

Нет комбинации.

Очень полезная команда и пригодится вам не раз. Принцип действия такой. Создаем необходимое выделение и выполняем эту команду. Наше выделение (будь оно правильной или произвольной формы) окажется охваченным прямоугольным контейнером (габаритной рамкой), форму которого можно изменять по горизонтали/вертикали. CTRL+ щелчок по маркерам (угловым точкам) контейнера +тянем мышь = меняем прямоугольную форму контейнера на форму выпуклого/вогнутого четырехугольника. Нажатием ENTER применяем изменения выделения. ESC — выход из контейнера (выделение не изменится).

Сохранение выделения в виде Альфа-канала

Select > Save Selection

Нет комбинации.

Загрузка выделения из Альфа-канала

Select > Load Selection

Нет комбинации.

Модификация выделения

Select > Modify

Нет комбинации.

^ Команды модификации выделений.

Команда

Назначение

Select > Modify > Border
(выделение — модификация — граница)

Заменяет выделенную область на область в виде полосы заданной ширины, следующей вдольграницы исходной области.

Select > Modify > Smooth
(выделение — модификация — сгладить)

Скругляет острые углы выделения с заданным радиусом.

Select > Modify > Expand
(выделение — модификация — расширить)

Равномерно увеличивает выделенную область во все стороны на заданное число пикселей.

Select > Modify > Contract
(выделение — модификация — сжать) 

Равномерно уменьшает выделенную область по всем направлениям на заданное число пикселей. 

Панель параметров для выделения.




  • Обычное выделение

  • Добавление к выделенному

  • Вычесть из выделенного

  • Пересечь с выделенным

  • Ширина лассо (Lasso Width) определяет, насколько близко к краю картинки должен перемещаться курсор, чтобы правильно позиционировать выделяемый контур. Если обрабатываются слабоконтрастные изображения или создаются максимально точные контуры, то нужно установить наименьшую ширину. Причем этот параметр можно изменять непосредственно в процессе выделения с помощью клавиш <[> и <]>, а если удерживать , то его значение будет варьировать от минимального (1 пиксел) до максимального (40 пикселов).

  • ^ Частота (Frequency) определяет плотность автоматического расположения опорных точек. Обычно не нужно изменять данный параметр, но при работе со слабоконтрастными изображениями эта опция бывает полезной.

  • ^ Контрастность края (Edge Contrast) позволяет редактировать уровень контрастности между элементами, входящими в контур выделения, и элементами заднего фона. При выборе части из слабоконтрастной картинки значение этой опции следует уменьшать, а при работе с сильноконтрастными изображениями, напротив, полезно увеличить

^ Стратегии выделения.

Выбор средств выделения.

Выбор средств выделения прежде всего зависит от преследуемых целей. В Photoshop существует три разных метода выделения:

- с использованием Контуров.
- с использованием Инструментов Выделения Областей.
- с использованием Масок.

Два последних метода являются взаимно дополняющими и их разумно использовать совместно. Так как Маски трудны в создании, то черновую работу можно выполнить инструментами выделения.

В зависимости от того, как выглядит объект, который необходимо отделить от фона, и как выглядит фон, существует две основные стратегии выделения: "выделить и удалить" и "выделить и скопировать". 

^ 1. Выделить и удалить.
Пример.



Вот такая веточка. Надо избавиться от черного фона. На одном слое у нас фотография ветки — советую работать с ней (в принципе, неважно, что за фотография, главное, чтобы объект находился он однотонном слое, который нам совершенно не подходит — то есть его необходимо удалить). Создаем следующий слой (см.Слои), и заливаем его белым цветом (CTRL + BACK). Новый слой должен находиться под слоем с веткой (его можно просто перетащить).
Возвращаемся к слою с веткой. 

Для удаления фона используем инструмент ^ Wand ("Волшебная палочка"). Этот инструмент предназначен для выделения по цветовому принципу. После того, как вы выбрали "волшебную палочку", обратите внимание на меню инструмента (под верхним меню). Очень важный параметр — Обратная чувствительность\Tolerance (величина допуска). Чем больше Обратная чувствительность (Tolerance), тем больший диапазон цветов будет охватывать этот инструмент.
Для нашего примера: При активном инструменте  щелкаем мышкой на любом месте фона (поэкспериментируйте с Tolerance — если значение допуска слишком велико, выделение "заползает" на ветку; если мало — область выделения недостаточна; поэтому оптимальное значение - 32). Итак, Tolerance = 32, щелкаем по фону. Выделился фон, точнее часть фона. Можно продолжить выделение, снова щелкнув по черному фону, но уже с нажатой клавишей SHIFT. И так далее. В любой момент, когда вам кажется , что вы ошиблись, можно нажать CTRL+Z (отмена последнего действия) или обратиться к палитре История\History.  

Когда, по вашему мнению, выделение завершено, можно смело нажимать клавишу Delete, тем самым удалив все, что попало в область выделения. Ну как? Понравилось? Сомневаюсь. Ветка-то обглоданная получилась. 

Для таких случаев существует другой, более подходящий способ выделения. Это выделение по цветовому диапазону Цветовой ряд (Color Range). 

^ 2. Выделить и скопировать. 

Сначала создается выделение по границе объекта, а затем выделение копируется на новый слой командой Слой > Новый > Стой через копирование (Layer>New>Layer via Copy). На новом слое у нас будет тот самый объект, который необходимо было выделить. В основном эта стратегия удобна для сравнительно простых форм объектов или для однотонных объектов. 
Способ выделения зависит опять же от типа объекта. Если вам нужно выделить "Черный квадрат" Малевича, то вы вполне можете обойтись прямоугольным выделением . Если перед вами опять же квадрат Малевича, можете использовать и волшебную палочку . Ну а если выделению необходимо подвергнуть объект сложной формы и разнообразных цветов, то тут не обойтись без инструмента "перо" .

^ Цветовой ряд (Color Range). (Выделение по цветовому диапазону).



Выполняем команду Выделение > Цветовой ряд (^ Select> Color Range). С помощью этой команды можно выделить все пиксели изображения, цвета которых попадают в заданный цветовой диапазон.

Открывается диалоговое окно «Цветовой ряд». На картинке окошка светло-серым (почти белым) обозначаются те пиксели, которые мы выделяем. У нас это черный фон. Если справа поставить галочку напротив Инверся, белым обозначится то, что останется (ветка).

Выделение Photoshop предлагает выбрать, какой цвет будем выделять и по умолчанию указан параметр ^ Отобранные цвета, что и является самым верным решением. В данном случае, конечно, можно было бы в строке Выбор выбрать Черный, выделился бы черный цвет фона. Но черных пикселей на картинке довольно много. И после их выделения с последующим удалением (нам же ветка нужна), елочка получилась бы "ободранная" и довольно несимпатичная. Можете попробовать и убедиться в этом сами. 
^ Разброс (Fuzziness): Этот параметр увеличивает число пикселей, которые будут выделены. Тут главное не переусердствовать, кажется, что всю "черноту" убрали, а потом окажется, что ветка получилась объеденная. Лучше не устанавливать значение слишком высоким, а потом подправить.
Три пипетки справа: Пипетка с + опять же увеличивает число выделенных пикселей, пипетка - сокращает это число. Так что в принципе можно вообще обойтись без Fuzziness и просто щелкать пипетками.
^ Выбор просмотра (Selection Preview): Выбрать вариант предосмотра. Различные способы, но, как мне кажется, они только усложняют и так не самый простой способ выделения. Оставьте None.
Под картинкой в окне Color Range два варианта этой самой картинки. Selection: вы увидите будущее выделение. Image: ничего не увидите, кроме оригинала (смысла в чем я, лично. не вижу).
И последнее, при нажатии на клавишу ALT в окне Color Range кнопка Cancel меняется на Reset, нажав на которую(ALT в это время нажата) вернемся к исходному состоянию.
Итак, если вы считаете, что произведенные вами манипуляции в Color Range верны, нажимаете ОК.
Не обещаю, что вам понравится то, что вы увидите. Нужна практика, вернитесь на шаг назад (CTRL+Z) и попробуйте еще раз. Не со второго, так с пятого раза получится лучше. Дополнительная коррекция скорее всего тоже понадобится.

^ Работа в режиме Быстрой маски (Quick Mask).

Quick Mask используется для создания выделений. Происходит это при помощи практически всех инструментов Photoshop, а особенно с использованием инструментов рисования. (Маска просто рисуется градациями серого). 

Переход в режим Quick Mask осуществляется нажатием клавиши Q. Выход из режима Quick Mask также происходит после нажатия Q. Попробуйте открыть какой-либо файл с неким изображением и нажать Q.



Единственное, что вы заметите, это появление на панели History строки "Ввод быстрой маски (Enter Quick Mask)" — значит, вы вошли в режим быстрой маски. Выберем какой-нибудь инструмент рисования, например, кисть, и что-нибудь нарисуем. Наши труды отображаются красным цветом. Корректировку можно провести с помощью инструмента — "резинка"



Выйдем из быстрой маски (клавиша Q). Выделилась область, не затронутая нашим рисованием. Можно удалить выделение (клавиша Del), чтобы оценить результат.



Напомню, что для получения обратного выделения можно выполнить операцию Выделение > Инвертировать (Select> Inverse)



Можно лишь добавить, что на результат будет влиять показатель инструментов рисования Opacity (Непрозрачность), и сама структура кисти (жесткая кисть или "размазанная"). К примеру, установим прозрачность кисти 30%. Результат будет таким:



А если еще и кисть будет не жесткая, то таким:



Очень интересный эффект получается при использовании градиента . В режиме Quick Mask проведите вдоль картинки линию при активном инструменте  , а затем, выйдя из быстрой маски, удалите выделенное. Вот что получится:



^ Сохранение и загрузка выделений.

Сохранение выделений.

Дабы не потерять созданное нами выделение и не горевать над утраченным горькими слезами, советую выделения сохранять. После их сохранения всегда можно осуществить их загрузку и не выполнять одну и ту же работу дважды.
Сохранять выделения можно в виде контуров и альфа каналов.

^ Сохранить выделение как контур. 

Предполагается, что выделение уже создано. Рассмотрим два способа дальнейших действий.



1. Зайти в меню палитры контуры Пути (Paths) — маленький треугольник-стрелочка в правом верхнем меню палитры и выбрать команду Make Work Path... (Создать рабочий контур). В появившемся окне можно задать максимально допустимое количество пикселей, на которое может отклониться данный контур (чем меньше это число, тем точнее).

2. Второй способ сохранения выделения в виде контура проще. Щелкнуть по кнопке внизу палитры Paths (Создать контур из выделения).

^ Сохранение выделения в виде Альфа-канала.

Альфа-канал является маской, которая сохраняется как отдельный канал в палитре Каналы (Channels).



Пару слов о палитре Channels. Файл, в своем исходном состоянии, имеет 4 или 5 каналов. Если файл создан в режиме RGB, то канал под номером 1 соответствует R (красному цвету изображения), канал под номером 2 — G (зеленому цвету), канал под номером 3 — B (синему цвету). Четвертый канал — канал составляющего цвета. Каждый из них может быть отключен/включен из видимости нажатием на на палитре Channels. Соответственно, для системы CMYK, в палитре Channels будут указаны 5 каналов, каждый из которых соответствует своему цвету C, M, Y или K.

Вернемся к выделению.
Выделение создано. Теперь посредством верхнего меню и последовательности команд Select > Save Selection (сохранить выделение) попадаем в диалоговое окно создания альфа-канала, где мы можем назвать новый канал палитры Channels и указать документ (существующий или новый). После нажатия ОК результат виден в палитре Channels. Новый канал подвержен тем же манипуляциям, что и слой.
Другой способ создания альфа-канала — это нажатие кнопки (Сохранить выделение как канал) на палитре Paths.

ПРЕИМУЩЕСТВА сохранения выделения как КОНТУРА.
1. Контур занимает мало места в файле.
2. Контур может быть преобразован и отредактирован как векторный объект.
3. Обтравочный контур, на сегодня, единственный способ отделения объекта от фона.
НЕДОСТАТКИ сохранения выделения как КОНТУРА.
1. В контуре не сохраняется информация о частичном выделении (прозрачности).
2. Контур менее точно описывает границы объекта с сильно изрезанными границами.
3. Автоматически созданный контур плохо редактируется из-за наличия большого числа управляющих точек.

ПРЕИМУЩЕСТВА сохранения выделения в виде АЛЬФА КАНАЛА.
1. Альфа-канал наиболее точно сохраняет выделение.
2. Можно сохранять информацию о частичном выделении (прозрачности).
3. Редактирование с помощью инструментов рисования (оттенками серого).
НЕДОСТАТКИ сохранения выделения в виде АЛЬФА-КАНАЛА.
1. Довольно большой объем в файле.
2. Количество каналов ограничено (24).

Выбор способа зависит от ваших предпочтений и от конкретных обстоятельств.

Загрузка выделений.

Из контура.

1.Из меню палитры Paths (контуры) вызвать команду Make Selection (создать выделение). В открывшемся меню нужно указать радиус растушевки и сглаженность кромок (Anti Aliased). Проследите за тем, чтобы контур в палитре Paths был активным (подсвечен синим), если нет, то активизировать его можно щелчком мыши по названию контура.
2. Другой способ. Нажать на кнопку на палитре Paths (Загрузить контур как выделение).
3. Третий способ. CTRL+ щелчок по имени контура в палитре Paths.

Из канала.

1.Из главного меню вызвать команду Select> Load Selection (загрузить выделение). В открывшемся меню нужно указать имя канала, из которого необходимо загрузить выделение. 
2. Другой способ. Нажать на кнопку на палитре Channels (каналы) (Загрузить канал как выделение).
3. Третий способ. CTRL+ щелчок по имени канала в палитре Channels.

Из слоя.

Можно загрузить слой, как выделение. Для этого обычно используется такой способ: CTRL+ щелчок по имени слоя в палитре Layers (Слои).




Скачать 171,06 Kb.
оставить комментарий
Дата15.10.2011
Размер171,06 Kb.
ТипЛекция, Образовательные материалы
Добавить документ в свой блог или на сайт

Ваша оценка этого документа будет первой.
Ваша оценка:
Разместите кнопку на своём сайте или блоге:
rudocs.exdat.com

Загрузка...
База данных защищена авторским правом ©exdat 2000-2017
При копировании материала укажите ссылку
обратиться к администрации
Анализ
Справочники
Сценарии
Рефераты
Курсовые работы
Авторефераты
Программы
Методички
Документы
Понятия

опубликовать
Документы

наверх