Учебное пособие Рекомендовано Учебно-методическим объединением по образованию в области физической культуры и спорта в качестве учебного пособия для студентов высших учебных заведений, icon

Учебное пособие Рекомендовано Учебно-методическим объединением по образованию в области физической культуры и спорта в качестве учебного пособия для студентов высших учебных заведений,


3 чел. помогло.
Смотрите также:
Учебное пособие Рекомендовано Учебно-методическим объединением по образованию в области...
Учебное пособие Научный редактор проф д-р техн наук В. Г. Лисиенко...
«Учебники Томского политехнического Университета»...
Учебно-методическое пособие Горки: Белорусская государственная сельскохозяйственная академия...
Учебное пособие допущено Учебно-методическим объединением по образованию в области коммерции в...
Режиссерская школа Товстоногова...
Программа режиссерской школы...
Учебное пособие Г. М...
Курс теоретической механики : Учебное пособие А. В. Чигарев, Ю. В...
Учебное пособие для студентов и преподавателей филологических факультетов, учителей-словесников...
Учебник нового века...
Учебник нового века...



Загрузка...
страницы: 1   ...   8   9   10   11   12   13   14   15   ...   18
вернуться в начало
скачать
^

9. Программные средства обработки

числовой информации


Наиболее популярной программой для обработки числовой информации является программа электронные таблицы Microsoft Excel, которая входит в состав пакета Microsoft Office.

Электронные таблицы – это программы для создания и обработки таблиц, представленных в электронной форме.

Главное преимущество использования электронных таблиц — возможность мгновенного автоматического пересчета всех данных, связанных формульными зависимостями, при изменении любого значения в таблице. Электронные таблицы позволяют получать результаты без проведения расчетов вручную или программирования.

Microsoft Excel – это программа для структурирования данных, автоматизации расчетов по заданным формулам, создания графиков и диаграмм, формирования и печати отчетов.

Эта программа позволяет:

  • при формировании таблицы выполнять ввод, редактирование и форматирование текстовых, числовых данных и формул;

  • автоматически производить итоговые вычисления;

  • обрабатывать результаты экспериментов;

  • осуществлять поиск оптимальных значений параметров;

  • подготавливать табличные документы;

  • строить диаграммы и графики по данным;

  • использовать электронную таблицу как базу данных.

Запуск программы:

  • Пуск, Все Программы, Microsoft Excel;

  • двойной щелчок по ярлычку или значку приложения или документа;

  • файл запуска – excel.exe.

Структурные единицы электронной таблицы:

  • Рабочая книга – документ Excel для хранения и обработки данных, состоящий из одного или нескольких Рабочих листов, количество которых можно изменить;

  • Рабочий лист – это одна электронная таблица, состоящая из строк и столбцов, которые, пересекаясь, образуют ячейки данных;

  • ячейка – это минимальная единица хранения информации и выполнения расчетов в электронной таблице;

  • адрес ячейки задает ее расположение и состоит из имени столбца и номера строки, активная (текущая) ячейка выделена рамкой;

  • диапазон (блок, интервал) ячеек – прямоугольная область смежных ячеек;

  • обозначение диапазона ячеек – адреса верхней левой и нижней правой ячеек этого диапазона, разделенных двоеточием.

В ячейках может содержаться информация трех типов: числовая константа, текст и формула. Вычисления в таблицах производятся с помощью формул. Формула начинается со знака равенства и состоит из констант, адресов ячеек, содержащих данные, и действий, которые надо с этими данными выполнить. Результат помещается в ячейку, в которой находится формула.


^ 9.1. Оконный интерфейс Microsoft Excel

Структура окна Microsoft Excel напоминает окно Microsoft Word и многие элементы окна в этих программах одни и те же. Отличаются рабочие области этих программ. В программе Excel рабочее поле разлиновано на столбцы и строки.

На рисунке 9.1 и в таблице 9.1 представлены названия, расположение и назначение элементов программного окна Excel.




Рис. 9.1. Окно программы Microsoft Excel


^ Таблица 9.1

Элементы окна программы Microsoft Excel


Элемент окна

Расположение

Назначение

заголовок

вверху окна

отображает название программы и имя редактируемого документа (Книга 1, 2… - по умолчанию)

строка меню

под строкой заголовка

для выполнения команд приложения

панели инструментов (осн. панели: Стандартная и Форматирования)

под строкой меню

для выполнения команд приложения (вызов: меню ^ Вид-Панели инструментов)

строка формул:

  • левая часть;

  • правая часть;




под панелями инструментов

  • содержит адрес текущей ячейки;

  • для ввода, просмотра и редактирования содержимого ячейки

строка состояния

внизу окна

отображение информации о текущем документе (вызов: меню ^ Вид-Строка состояния)

полосы прокрутки (вертикальная и горизонтальная)

справа и внизу окна

для просмотра содержимого окна

Рабочие листы

внутри окна

для выполнения операций с данными

ярлычки Рабочих листов

Слева внизу окна

для перемещения по Рабочим листам


Краткое содержание команд меню:

  • меню ^ Файл содержит команды, управляющие обработкой документа: создать, открыть, сохранить, печатать др.;

  • меню Правка предназначено для редактирования фрагментов и структурных элементов документа: вырезать, копировать, вставить, удалить и др.;

  • меню Вид содержит команды, изменения представления документа на экране и отдельных элементов окна приложения;

  • меню Вставка позволяет вставлять в документ различные объекты: разрыв страницы, номера страниц, примечания, файлы, рисунки и др.;

  • меню Формат позволяет форматировать фрагменты документа: изменять шрифт, размер шрифта, начертание; изменять межстрочное расстояние в тексте и т.п.;

  • меню Сервис предназначено для настройки окна приложения;

  • меню Данные содержит команды, используемые для создания и организации работы с базами данных, т.е. команды предназначены для манипуляции с содержимым ячеек таблицы;

  • меню Таблица позволяет вставлять и выполнять различные операции с таблицами;

  • меню Окно содержит команды, позволяющие работать с несколькими документами;

  • меню Справка позволяет получить справочную информацию о работе приложения.


^ 9.2. Основные операции в программе Microsoft Excel

Основные операции с файлами Excel выполняются аналогично операциям с файлами Word. При сохранении файлу по умолчанию присваивается имя Книга 1(2,3) и расширение xls.

Основные операции с Рабочей книгой и описание их выполнения представлены в таблице 9.2.

^ Таблица 9.2

Операции с Рабочей книгой в программе Microsoft Excel


Название

операции

Описание выполнения

перемещение по Рабочей книге

  • щелчок по ярлыку листа внизу окна;

  • с помощью кнопок прокрутки ярлыков

выделение Рабочих листов

  • щелчок по ярлыкам листов при нажатой клавише Ctrl;

  • щелчок правой кнопкой по ярлыку, команда Выделить все листы

вставка листов

  • меню Вставка-Лист;

  • щелчок правой кнопкой по ярлыку, команда Добавить

удаление листов

  • меню Правка-Удалить лист;

  • щелчок правой кнопкой по ярлыку, команда Удалить лист

переименование листа

  • двойной щелчок по ярлыку, ввести новое имя;

  • щелчок правой кнопкой по ярлыку, команда Переименовать

перемещение листа

Перетащить лист мышью


Ввод данных в электронную таблицу можно осуществлять как с клавиатуры, так и автоматически.

Ввод данных с клавиатуры: выделить ячейку, ввести данные, нажать Enter. Полное содержимое ячейки можно увидеть в строке формул.

В электронной таблице имеется возможность автоматического заполнения ячеек последовательностями или прогрессиями данных. Для этого необходимо ввести первые два элемента последовательности, выделить эти две ячейки и перетащить мышью маркер заполнения (правый нижний угол второй ячейки) по ячейкам. Для ввода последовательностей с известным следующим элементом (месяцы, дни недели и т.д.) достаточно ввести только первый член последовательности. Можно задавать свои последовательности для автозаполнения (меню Сервис-Параметры, вкладка Списки).


При редактировании данных необходимо:

  • выделить ячейку, ввести новые данные и нажать Enter;

  • выделить ячейку, щелкнуть мышью в строке формул, изменить содержимое и нажать Enter;

  • двойной щелчок по ячейке, изменить содержимое и нажать Enter.

В электронных таблицах можно обрабатывать данные трех типов: текст, число, формула, представленные в разных форматах. По умолчанию при вводе в ячейку числа выравниваются по правому краю, а текст – по левому краю. Числа в отличие от текста могут участвовать в вычислениях.

Число может состоять только из следующих символов: цифры от 0 до 9 (0 1 2 3 4 5 6 7 8 9), знаки плюс (+) и минус (-), круглые скобки ( ), запятая (,), косая черта (/) (в рациональных дробях, например ½), знак процента (%), точка (.), знак мантиссы (Е е). Первыми символами в ячейке с числовыми данными могут быть: число, знак числа (плюс или минус) и левая круглая скобка. Если число не помещается в ячейке электронной таблицы, то вместо числа в ячейке появляются символы ####.

Все другие комбинации, состоящие из цифр и нецифровых символов, интерпретируются как текст. Текстом является любая последовательность, состоящая из цифр, пробелов и нецифровых символов. При необходимости текст можно расположить в ячейке в несколько строк.

Преобразование данных из одного формата в другой происходит с помощью меню Формат-Ячейки, вкладка Число. Операции по форматированию символов происходят так же, как и в программе Word (меню Формат-Ячейки).

Для выполнения различных операций с элементами таблицы необходимо предварительно их выделить.

Способы выделения и выполнения операций с элементами таблицы представлены в таблицах 9.3, 9.4.

^ Таблица 9.3

Выделение элементов таблицы


Диапазон ячеек

Описание

диапазон ячеек

  • протянуть мышью по ячейкам;

  • щелчок мышью по первой ячейке и при нажатой Shift по последней

  • щелчок по ячейкам при нажатой клавише Ctrl

строка

щелчок по номеру строки

столбец

щелчок по заголовку столбца

рабочий лист

щелчок по кнопке пересечения заголовков столбцов и строк

способы выделения можно комбинировать

Таблица 9.4

^ Операции в электронной таблице

Название операции

Описание выполнения операции

изменение ширины столбцов и высоты строк

  • меню Формат-Столбец, Строка;

  • перетащить мышью правую границу столбца, нижнюю границу строки;

  • двойной щелчок по правой границе заголовка столбца или нижней границе заголовка строки автоматически устанавливает ширину столбца или высоту строки

добавление столбцов,

строк, ячеек

меню ^ Вставка-Столбцы, Строки, Ячейки

удаление столбцов, строк, ячеек

  • выделить столбец, строку, ячейки, меню Правка-Удалить;

  • щелчок правой кнопкой по выделенным ячейкам, команда Удалить;

перемещение

  • перемещение (drag and drop) рамки выделенного блока ячеек левой или правой кнопками мыши;

  • с помощью буфера обмена (выделить блок ячеек, команда Вырезать, команда Вставить)

копирование

  • перемещение (drag and drop) рамки выделенного блока ячеек левой при нажатой клавише Ctrl или правой кнопками мыши;

  • с помощью буфера обмена (выделить блок ячеек, команда Копировать, команда Вставить);

  • протянуть мышью маркер заполнения (правый нижний угол ячейки)



^ 9.3. Вычисления в программе Microsoft Excel

Вычисления в электронной таблице представляются в виде формул. Формулы - это арифметические и логические выражения. Формулы можно вводит в любые ячейки. Формулы всегда начинаются со знака равенства (=).

Формула может быть арифметическим выражением, состоящим из чисел, обозначений ячеек и диапазонов, знаков арифметических операций, функций. Порядок выполнения арифметических операций в формуле тот же, что принят в математике. Формула может быть и текстовым выражением, состоящим из текстов, обозначений ячеек, знака сцепления текстов (& или +), текстовых функций.

При вводе формулы адреса ячеек можно набирать на клавиатуре или указывать адрес щелчком мыши по ячейке. После ввода формулы в ячейку в ней сразу появляется результат вычислений, формула видна лишь в строке формул, но при желании ее можно вывести и в ячейку.

Для удобства в формулах часто используют функции. Любая функция представляет собой встроенную формулу, выполняющую операции над указанными данными. Функции могут использоваться отдельно или одна функция может быть вложена в другую.

Правила составления и использования функций:

  • в состав функции входят имя (обязательно) и аргументы (адреса ячеек);

  • аргументы записываются в скобках после имени функции. В качестве аргументов функции могут использоваться числа (константы), адреса ячеек или диапазонов, имена ячеек или диапазонов, текст, другие функции (вложенные), логические значения и др.;

  • некоторые функции используют несколько аргументов, которые разделяются точкой с запятой.

В электронных таблицах Excel встроено несколько категорий функций: Математические, Статистические, Финансовые, Логические, Текстовые и др.

Например, статистические функции выполняют операции по вычислению параметров случайных величин или их распределений, представленных множеством чисел: среднего значения (СРЗНАЧ), стандартного отклонения (СТАНДОТКЛОН) и т.п.

Названия функций можно вводит с клавиатуры или автоматически с помощью мастера функций. Мастер – инструмент, позволяющий выполнить требуемое действие по шагам с уточнением параметров по каждому шагу.

Работа с мастером функций: выделить ячейку, меню Вставка-Функция, выбрать категорию и имя функции, ввести аргументы, если необходимо.

Самой простой функцией является функция суммирования, которая представлена в электронной таблице в виде операции автосуммирования. Эту функцию можно ввести с помощью кнопки Автосумма на Стандартной панели инструментов, которая автоматически производит суммирование соседних строк и столбцов. Для этого: выделить ячейку справа или снизу от диапазона, в котором нужно произвести суммирование, и щелкнуть кнопку Автосумма.

Для указания ячеек в формулах обычно используются относительные адреса. При копировании формулы такие адреса автоматически изменяются в соответствии с новым положением формулы. Чтобы адреса в формуле не изменялись при копировании, используются абсолютные адреса. Если при копировании формулы нужно сохранить фиксированным только один параметр (номер строки или столбца), используются смешанные адреса. Клавиша F4 используется для переключения между относительными, абсолютными и смешанными адресами. Запись абсолютных и смешанных адресов содержит знак $ ($C$2, C$3).

Иногда удобно в некоторых ячейках иметь результат, уже полученный в какой-то ячейке. Таким образом, можно связывать ячейки на одном листе или ячейки разных рабочих листов. Ячейка, содержащая формулу с ссылкой, является зависимой. Значение в этой ячейке пересчитывается при изменении значения ячейки, на которую указывает ссылка. Формула, заданная для связи данных, содержит знак равенства (=) и внешнюю ссылку, которая указывает положение самой ячейки, имя Рабочего листа и имя файла, где она расположена (=[имя файла]имя раб.листа!адрес ячейки).

Данные, представленные в электронной таблице, можно рассматривать как список или базу данных. В базе данных:

  • строки содержат записи базы данных;

  • заголовки столбцов определяют поля.

Возможности Excel позволяют производить обработку и анализ данных в списке.

Сортировка позволяет расположить данные в списке в строго определенной последовательности. Для текстовых данных сортировку можно производить в алфавитном порядке, для числовых данных – в порядке возрастания или убывания. При сортировке по определенному признаку задается блок данных для сортировки и с помощью имен полей определяется критерий сортировки. Имя поля, по которому проводится сортировка, называется ключом сортировки. В процессе сортировки строки переупорядочиваются в соответствии с заданным порядком сортировки и им присваиваются новые порядковые номера.

Сортировка данных в электронных таблицах: текущая ячейка внутри таблицы, меню Данные-Сортировка, выбрать ключ сортировки. Можно использовать более одного критерия сортировки.

Фильтрация данных в таблице позволяет отображать только те строки, содержимое ячеек которых отвечает заданному условию или нескольким условиям. После фильтрации записи, не удовлетворяющие заданному критерию, не удаляются, а становятся невидимыми и порядковые номера строк в списке не являются последовательными.

Фильтрация данных в электронных таблицах: меню Данные-Фильтр-Автофильтр, в заголовках каждого столбца появятся кнопки фильтра, щелкнуть по кнопке фильтра и выбрать критерий фильтрации.

Восстановления всех строк исходной таблицы: щелкнуть по кнопке фильтра и выбрать критерий ^ Все или меню Данные-Фильтр-Отобразить все.

Excel позволяет подводить промежуточные итоги автоматически. Подведение промежуточных итогов можно осуществлять по нескольким показателям: определение количества элементов списка; суммирование; нахождение минимального, максимального, среднего значений и др.

Перед вычислением промежуточных итогов следует выполнить сортировку. При подведении итогов автоматически создается формула, вставляется строка промежуточных итогов. Одновременно можно вычислять промежуточные итоги с помощью нескольких функций. Значения промежуточных итогов пересчитываются автоматически при каждом изменении данных.

Подведение итогов: отсортировать список, текущая ячейка внутри таблицы, меню Данные-Итоги.

При подведении промежуточных итогов создается структура таблицы, с помощью которой можно скрыть исходные данные и оставить в таблице только результаты подведения итогов.

Удаление промежуточных итогов: текущая ячейка внутри таблицы, меню Данные-Итоги, щелкнуть кнопку Убрать все.

Для объединения данных из нескольких источников и вывода итогов в любом месте электронной таблицы используется меню Данные-Консолидация.

Построение диаграмм.

Диаграммы обеспечивают возможность наглядного отображения числовых данных электронных таблиц. Диаграмма связана с данными, на основе которых она построена, и при обновлении этих данных немедленно изменяет свой вид.

Диаграммы можно создавать как на одном Рабочем листе с данными (внедренная диаграмма), так и на отдельном Рабочем листе (лист диаграммы). Удобно предварительно выделять данные для построения диаграмм.

Построение: выделить ячейки с данными, меню Вставка-Диаграмма, выбрать тип и вид диаграммы, задать параметры (рис. 9.2).

Тип создаваемой диаграммы зависит от характера выделенных данных. Для каждого типа диаграмм можно выбрать модификации основного варианта диаграммы. Модификации могут включать линии разметки, заголовки и различные обозначения.

Основные типы диаграмм:

  • линейчатые диаграммы и гистограммы удобны для сравнения величин в рядах данных. Линейчатые диаграммы обычно используют для сравнения по некоторым признакам, а гистограммы – для наблюдения изменений во времени;

  • круговые диаграммы наглядно отображают соотношения частей и целого;

  • диаграммы с областями и графики позволяют наилучшим образом изобразить непрерывное изменение величин во времени.




оставить комментарий
страница12/18
Конюхов В.Г
Дата21.09.2011
Размер2,19 Mb.
ТипУчебное пособие, Образовательные материалы
Добавить документ в свой блог или на сайт

страницы: 1   ...   8   9   10   11   12   13   14   15   ...   18
средне
  1
отлично
  7
Ваша оценка:
Разместите кнопку на своём сайте или блоге:
rudocs.exdat.com

Загрузка...
База данных защищена авторским правом ©exdat 2000-2017
При копировании материала укажите ссылку
обратиться к администрации
Анализ
Справочники
Сценарии
Рефераты
Курсовые работы
Авторефераты
Программы
Методички
Документы
Понятия

опубликовать
Загрузка...
Документы

Рейтинг@Mail.ru
наверх