Использование ms excel при изучении математической логики icon

Использование ms excel при изучении математической логики


Смотрите также:
Использование Mathcad и Excel при изучении школьного курса физики...
«Практическое использование возможностей ms word и excel»...
Отличия человеческой логики от математической логики...
Рабочая программа трудоемкость дисциплины 4 зачетные единицы направление 010400 информационные...
Тема Виды учебной и самостоятельной работы, час...
Рабочая программа дисциплины «Математическая логика и теория алгоритмов»...
«использование ит при изучении искусства модерна в беларуси»...
Методика использование средств информационных технологий при изучении наглядной геометрии в 5-6...
«Использование информационных технологий при изучении международного права»...
Тезисы Тема: Алгебра логики. Сложные высказывания...
Литература. Введение...
Программа дисциплины ен. Ф. 01...



Загрузка...
скачать
Использование MS Excel при изучении математической логики

Плетеня Ольга Николаевна, ассистент кафедры высшей математики и информатики СурГПУ

В настоящее время применение информационных технологий становится неотъемлемой частью образовательного процесса. Компьютер наиболее полно удовлетворяет дидактическим требованиям и позволяет адаптировать процесс обучения к индивидуальным особенностям учащихся.

Компьютерные технологии активно внедряются в процесс обучения и диагностики, позволяют упростить процесс отработки навыков и умений и оценки знаний учащихся.

В данной работе рассматривается применение табличного процессора MS Excel при изучении основ логики.

Существует множество задач, в которых исходные и результатные данные должны быть представлены в табличной форме. Электронные таблицы представляют собой удобный инструмент для автоматизации таких вычислений. Решения многих вычислительных задач на ЭВМ, которые раньше можно было осуществить только путем программирования, стало возможно реализовать. Использование математических формул в электронных таблицах позволяет представить взаимосвязь между различными параметрами некоторой реальной системы. Основное свойство электронных таблиц – мгновенный пересчет формул при изменении значений входящих в них операндов. Благодаря этому свойству, таблица представляет собой удобный инструмент для организации численного эксперимента:

  1. подбор параметров,

  2. прогноз поведения моделируемой системы,

  3. анализ зависимостей,

  4. планирование.

В электронных таблицах предусмотрен также графический режим работы, который дает возможность графического представления (в виде графиков, диаграмм) числовой информации, содержащейся в таблице.

В процессе изучения алгебры логики учащиеся знакомятся с такими понятиями как: высказывание, таблицы истинности, логические функции и логические операции. Алгебра логики является разделом математической логики, в которой изучаются методы доказательства истинности (1) или ложности (0) сложных логических конструкций, составленных из простых высказываний, на основе истинности или ложности последних. Для закрепления полученных знаний возможно использование табличного процессора MS Excel и его функций.

Для реализации функций булевой алгебры используются логические функции: ЕСЛИ, И, ИЛИ, НЕ, ИСТИНА и ЛОЖЬ. При работе с функциями в MS Excel используется мастер функций (Вставка → Функция…), в котором отображается имя функции, ее описание и аргументы.



Первоначально следует создать таблицу основных логических операций:



При составлении таблицы истинности используются следующие формулы:

  1. Инверсия: =ЕСЛИ(A2=1;0;1);

  2. Дизъюнкция: =ЕСЛИ(ИЛИ(A2=1;B2=1);1;0);

  3. Конъюнкция: =ЕСЛИ(И(A2=1;B2=1);1;0);

  4. Импликация: =ЕСЛИ(И(A2=1;B2=0);0;1);

  5. Эквивалентность: =ЕСЛИ(A2=B2;1;0).

В последующей работе данная таблица может использоваться учащимися как основа для выполнения заданий лабораторной работы.

Учащимся может быть предложена следующая работа.

Задание: Построить таблицу истинности для формулы , используя MS Excel.

Алгоритм:

  1. Определить количество наборов входных переменных, по формуле: , где n – количество переменных. .

  2. Внести в таблицу все наборы входных переменных:



  1. Определить количество логических операций и порядок их выполнения:









  2. Заполнить столбцы результатами выполнения логических операций в обозначенной последовательности.

Для этого в ячейку D2 ввести формулу: =ЕСЛИ(B2=1;0;1);

в E2: =ЕСЛИ(И(A2=1;D2=1);1;0);

в F2: =ЕСЛИ(И(E2=1;C2=0);0;1);

в G2: =ЕСЛИ(F2=A2;1;0).

Заполнение остальных строк произвести путем копирования введенной формулы.



Табличный процессор может быть использован для закрепления материала не только математической логики, но и основ теории вероятностей и математической статистики.


Литература:

  1. Информатика: Учебник/ Под ред.проф. Н.В. Макаровой. – М.: Финансы и статистика, 1997. – 768 с.: ил.

  2. Рычков В. Microsoft Excel 2000: краткий курс. – СПб.: Питер, 2001 – 336 с.: ил. Стоцкий Ю. Самоучитель Office 2000. – СПб.: Питер, 2001. – 608 с.: ил.




Скачать 28,94 Kb.
оставить комментарий
Дата21.09.2011
Размер28,94 Kb.
ТипДокументы, Образовательные материалы
Добавить документ в свой блог или на сайт

Ваша оценка этого документа будет первой.
Ваша оценка:
Разместите кнопку на своём сайте или блоге:
rudocs.exdat.com

Загрузка...
База данных защищена авторским правом ©exdat 2000-2017
При копировании материала укажите ссылку
обратиться к администрации
Анализ
Справочники
Сценарии
Рефераты
Курсовые работы
Авторефераты
Программы
Методички
Документы
Понятия

опубликовать
Загрузка...
Документы

Рейтинг@Mail.ru
наверх