Лабораторные работы в Open Office icon

Лабораторные работы в Open Office


Смотрите также:
Учебно-методический комплекс по дисциплине Использование офисного пакета Open Office...
Методические указания / Н. В. Мокрова. М.: Мгуиэ, 2012. 48с.; ил...
Лаб раб 1: Типовые звенья систем автоматического управления (сау)...
Правила рейтинга по курсу «Метрология» для студентов специальности «Стандартизация и...
Рф ргу нефти и газа им. И. М. Губкина Кафедра физики Е. С. Артоболевская, Л. Г. Любутина В. П...
Программа курсов повышения квалификации «Основы работы с программами Microsoft Office 2003»...
1. Microsoft Office издалека...
Задачи: Разработать презентации на каждый теоретический вопрос Разработать лабораторные...
Посещение лекций Лабораторные работы Контрольные работы по модулям Тесты...
Лабораторная работа №1...
Лабораторные работы лабораторная работа 1...
«Кубок Поволжья open race tlt-2012»...



Загрузка...
скачать

Лабораторные работы в Open Office




В текстовых редакторах имеется множество дополнительных функций, ускоряющих и облегчающих работу с текстами:

  • расстановка переносов;

  • изменение масштаба просмотра документа; автоматическая нумерация страниц;

  • создание границ вокруг текста и страниц;

  • разработка своего стиля и использование его в дальнейшем для быстрого форматирования текста;

  • поддержка нескольких словарей для проверки правильности написания;

  • работа с макросами;

  • поддержка нескольких окон; удобная справочная система;

  • проверка орфографии, грамматики и синтаксиса;

  • настройка панелей инструментов (добавление и удаление кнопок и команд);

  • возможность предварительного просмотра перед печатью;

  • настройка параметров страницы и поддержка нестандартных форматов бумаги; вставка в текст специальных символов.

В Linux есть много разных текстовых редакторов: от примитивных вроде gedit до сложных, как Open Office (ОО). Gedit предназначен для набора простых текстов, которым не нужно содержать сложного форматирования и т.п. (например, компьютерных программ). OO – сложная офисная система, предназначенная для набора, редактирования и форматирования текстовых документов любой сложности. Конечно, при помощи этой программы нельзя создавать профессиональные текстовые документы для печати в типографии (такие документы набирают в специальных типографских системах – TeX, LaTeX), но для офисного использования ОО подходит как нельзя лучше.

Помимо текстовых документов, Open Office позволяет создавать электронные таблицы, презентации, векторные рисунки и диаграммы, документы html, сложные составные документы, формулы, наклейки, визитные карточки, письма, базы данных.
^

Знакомство с Open Office Writer

Запуск Open Office Writer


Зайдите в К-меню и выберите из подменю «Офис» → «Open Office.org» пункт «Writer». Запустится текстовый редактор Open Office Writer. В открытом редакторе всегда отображаются две панели инструментов: «Стандартная» и «Форматирование». Панели содержат кнопки редактирования и форматирования текста, а также выпадающие списки, в которых можно выбрать стиль текста, его гарнитуру (шрифт) и размер. Для просмотра описания пунктов панели нужно навести на них курсор мыши, не нажимая никаких клавиш. Через небольшой промежуток времени под курсором загорится описание данной кнопки или списка.

Чтобы добавить или удалить панель инструментов, используется меню «Вид» → «Панели инструментов».

В случае возникновения вопросов по нажатию кнопки появляется окно помощи, где можно найти описания и советы. Кроме того, в новых версиях офисных пакетов существует т.н. «Помощник», дающий советы в процессе работы. На рис. 1 изображено окно программы с написанным в нем текстом.

Ознакомьтесь с меню и панелями инструментов. Сохраните сразу пустой документ в своей рабочей папке, чтобы не потерять набранный текст в случае сбоя компьютера (каждые 15 минут OO Writer автоматически сохраняет документ).

Сохранить документ можно, по крайней мере, тремя способами: во-первых, самый простой - нажать + ; во-вторых - щелкнуть по значку дискеты на панели инструментов; а в-третьих - выбрав из меню «Файл» пункт «Сохранить».

Р
ис. 1. Окно программы Open Office Writer.
^

Навигация по тексту


Под навигацией понимают перемещение курсора внутри текста. Для навигации можно использовать колесо мыши, прокручивающее документ построчно; ползунок навигации, расположенный справа от окна ввода текста (ухватившись за него мышью); или же клавиши управления курсором.

Следует учитывать, что прокручивая текст при помощи мыши, для перемещения курсора в нужное положение следует щелкнуть в этом месте левой клавишей мыши.

Клавиатурная навигация использует следующие клавиши. Клавиши управления курсором позволяют перемещаться на одну строку вверх или вниз, или на один символ влево или вправо. Клавиши
и
перемещают курсор на страницу вверх и вниз, соответственно. Клавиши и перемещают курсор в начало или конец строки, соответственно.

Можно использовать клавиши управления курсором с нажатой клавишей . Тогда курсор перемещается влево или вправо на одно слово, а клавиши
и
перемещают его в начало и конец документа, соответственно.
^

Методы ввода текста


Существует два режима ввода текста: вставка (ВСТ) и замена (ЗАМ), которые отображаются в строке статуса программы (внизу окна). Переключение между режимами осуществляется клавишей . По умолчанию действует режим вставки, когда новые символы при вводе «раздвигают» старые. В режиме замены новые символы заменяют символы, расположенные справа от курсора.

Удобная функция Open Office - автодополнение: при вводе длинных слов Open Office предлагает их окончание. Если оно вас устраивает, нужно нажать клавишу . Параметры автодополнения, также как и многие другие, можно настроить в свойствах Open Office.

Удаление текста осуществляется клавишами (она удаляет символ, расположенный слева от курсора) и (удаляется символ справа). Кроме того, можно выделить мышью или при помощи клавиатуры (удерживая нажатой клавишу и перемещая курсор) фрагмент текста и удалить его весь, нажав или .

Иногда бывает необходимо скопировать или переместить фрагмент текста в другую часть документа или в другой документ. Для этого необходимо выделить нужный фрагмент, а затем скопировать его в буфер обмена. В Linux существует два буфера обмена: в первый автоматически помещается выделенный мышью текст. Для того, чтобы вставить этот текст в другое место, необходимо нажать среднюю клавишу мыши (колесо). Однако, такой способ неудобен, если выделенный фрагмент необходимо вставлять несколько раз. Для этого используется второй буфер обмена. Чтобы поместить в него выделенный фрагмент, нажмите сочетание + . Чтобы вырезать фрагмент в буфер обмена, нажмите + . Затем установите курсор в позицию, куда вы хотите вставить этот фрагмент, и нажмите + . Содержимое второго буфера остается в нем до тех пор, пока вы не поместите в него новую информацию.
^

Форматирование текста


При вводе текста бывает необходимо задать различные способы отображения символов: жирный, курсив, подчеркнутый. Для этого можно использовать кнопки Ж, К и П панели инструментов, либо нажав клавишу и, не отпуская ее,  для жирного,  для подчеркнутого и  для курсивного текста. Вернуть обратно нормальное начертание можно, еще раз нажав соответствующую кнопку, или сочетание клавиш.

Помимо изменения способа начертания вы можете изменять гарнитуру (отображаемый шрифт) текста, его размер и цвет. Для этого используйте соответствующие элементы панелей инструментов.

Помимо символов, существует более крупная единица измерения объема в текстовом документе - абзац. Форматирование абзацев заключается в возможности задания межстрочного интервала (Open Office предлагает три размера: единичный, полуторный и двойной, но из меню «Файл» → «Абзац» можно выбрать и другие интервалы); величины абзацного отступа; выравнивания (по левому краю, по правому краю, по середине или по ширине).
^

Открытие и сохранение документов


Для сохранения документа щелкните изображение дискетки на панели инструментов, выберите из меню «Файл» пункт «Сохранить», или же нажмите сочетание клавиш + . Если документ сохраняется первый раз, появится диалоговое окно, в котором необходимо выбрать путь к сохраняемому файлу и ввести его имя.

Открыть документ можно выбрав из меню «Файл» пукнкт «Открыть», щелкнув по иконке с изображением открытой папки, либо же нажав сочетание + .

Если файл требуется сохранить в другом формате (например, в формате MS-Word), используется пункт меню «Файл» → «Сохранить как».
^

Ввод и редактирование текста


Наберите текст:

Я набираю этот текст не только для того, чтобы получить оценку. Это, прежде всего, необходимо мне самому. Я хочу научиться работать с компьютером не на уровне рядового пользователя, которого программисты снисходительно называют ламером, а на уровне продвинутого пользователя.

Практические занятия имеют огромнейшее значение: я смогу освоить различные программы, которые могут пригодиться мне в дальнейшей жизни не только на работе, но и дома. Ведь в наше время очень тяжело представить себе человека, никоим образом не относящимся к информационно-вычислительной технике.

Выполнение практических заданий носит характер самообучения. Я сам постигаю основы работы с ПК, преподаватель же выполняет роль консультанта в случае, когда что-то мне не понятно. Но стоит заметить, что я учусь все лучше и лучше, и все реже прошу подсказать мне, КАК ВЫПОЛНИТЬ ТУ ИЛИ ИНУЮ ОПЕРАЦИЮ.

Кегль (размер символов), а также гарнитуру (вид шрифта) можно задать, изменяя значения в выпадающих списках на панели инструментов. Начертание символов можно изменить либо нажав кнопки «Ж», «К», «П» на панели инструментов, либо сочетания клавиш: + , + , соответственно для жирного, курсивного или подчеркнутого начертания.

Сделайте надпись, использующую нижние и верхние индексы, спецсимволы, например, Xik=ΣXijk · yi.

Для того, чтобы введенный символ был верхним или нижним индексом, необходимо выделить его и в контекстном меню (по нажатию правой кнопки мыши) выбрать пункт «Формат Символ», где пометить нужный атрибут символа. Второй способ - выделить символ и щелкнуть на панели инструментов кнопку «Верхний индекс» или «Нижний индекс».
^

Использование стилей в документе


Большое удобство представляют стили, позволяющие упростить процесс форматирования документа. Чтобы применить к тексту тот или иной стиль, необходимо выбрать этот стиль из выпадающего меню панели инструментов, либо из окна «Стили», появляющегося при нажатии .

Основным стилем документа является «Основной» (или «Базовый»). Также существуют специальные стили для содержимого таблиц, заголовков, перечней и т.п. Изменяя определенный стиль, вы сразу же изменяете отображение всего текста, имеющего такой же стиль.

Создайте стиль на основе стиля «Основной» со следующими параметрами:

  • Кегль (размер шрифта) - 14 пт;

  • Первая строка - с отступом 1 см;

  • Отступы слева и справа - 0 см;

  • Выравнивание - «По ширине»;

  • Гарнитура - «Urw Bookman».

Дайте стилю название «Мой стиль».

Таким же образом на основе стиля «Заголовок 1» и «Заголовок 2» создайте свои собственные стили заголовков 1-го и 2-го уровня.

Выравнивание обоих уровней заголовков создайте по центру, гарнитура - «Urw Bookman», кегль у заголовка 1-го уровня – 30 пт, у заголовка 2-го уровня – 20 пт. Заголовок 1-го уровня сделайте жирным, а 2-го - курсивным. До и после заголовков оставьте пространство, равное кеглю заголовков.

Назовите заголовки «Уровень 1» и «Уровень 2».

Перед набранным до этого текстом создайте заголовок 1-го уровня: «Практическая работа 1», затем, следом за ним - заголовок 2-го уровня: «Форматирование текста». Весь остальной текст оформите в стиле «Мой стиль».

Таблицы


Начните задание с новой страницы. Для этого вставьте в документ разрыв страницы.

Наберите стилем «Уровень 2» заголовок «Форматирование таблиц».

Создайте и заполните таблицу - часть расписания ваших занятий. Для этого в меню «Вставить» выберите пункт «Таблица». Появится окно, изображенное на рис. 2.

«Имя таблицы» - необязательное поле. В поле «Размер таблицы» установите количество столбцов - 6, количество строк - 9. Поле «Верхний колонтитул» необходимо отметить галочкой, если вы хотите, чтобы заголовок таблицы выделялся жирным шрифтом. Поле «Повторять верхний колонтитул» отметьте, если таблица будет переноситься на следующую страницу, чтобы заголовок повторялся. Поле «Не разбивать таблицу» следует отметить, если вы не хотите, чтобы она переносилась между страницами. Если снять отметку с поля «Обрамление», таблица создастся с прозрачными границами.




№ пары

Понедельник

Вторник

Среда

Четверг

Пятница

1

математика

-

физика

-

рус. язык

2

химия

технология

спец.

предметы

-

физика

3

информатика

спец.

предметы

спец.

предметы

--

литература

4

биология

-

химия

-

экология

5

-

-

-

информатика

-

6








физика




7








рус. язык




8








литература




^ Разрыв страницы можно создать двумя способами: либо выбрав из меню «Вставка» пункт «Разрыв» → «Разрыв страницы», либо нажав сочетание клавиш + .

Для объединения нескольких ячеек выделите их, щелкните внутри выделения правой кнопкой мыши, из контекстного меню выберите «Ячейка» →«Объединить». Аналогично, чтобы разбить ячейку на несколько, выберите пункт «Разбить». Для того, чтобы изменить вид границ таблицы, выделите ячейки, в которых необходимо сменить обрамление, из контекстного меню выберите «Таблица». На появившемся окне откройте вкладку «Обрамление». Здесь можно настроить толщину линии в выбранных ячейках и ее положение (щелкните в нужном месте на схеме, расположенной в левой части окна).

Создайте таблицу:

Расписание дежурства

Время

Понедельник

Вторник

Среда

Четверг

Пятница

8.00 – 10.00

Савельев А.В.

Иванов Б.П.

Петров Г.А.

Жуков С.В.

Кузнецов А.А

10.00 – 12.00

Иванов Б.П.

Петров Г.А.

Савельев А.В.

Кузнецов А.А

Жуков С.В.

12.30 – 13.30

Перерыв

13.30 – 15.00

Петров Г.А.

Жуков С.В.

Кузнецов А.А

Савельев А.В.

Иванов Б.П.

15.00 – 17.00

Жуков С.В.

Кузнецов А.А

Иванов Б.П.

Петров Г.А.

Савельев А.В.


Чтобы задать какое-то выравнивание в ячейках таблицы необходимо выделить эти ячейки, а затем нажать на панели инструментов кнопку, соответствующую желаемому типу выравнивания. Кроме того, можно нажать на выделении правой кнопкой мыши и из контекстного меню выбрать нужный тип выравнивания.

Р
ис. 2. Окно «Вставить таблицу».

Сложные границы можно получить, выделив нужные ячейки, и щелкнув внутри них правой клавишей мыши. Из контекстного меню выберите пункт «Таблица», в открывшемся окне выберите «Обрамление». Слева располагается макет ячейки. Щелкните по тому краю макета, у которого вы хотите изменить тип линии. Затем выберите из выпадающего списка нужный тип линий (или «Нет линий», если хотите сделать линию невидимой). Нажмите ОК.

Колонтитулы


Колонтитулы - элементы, располагающиеся в самой верхней и самой нижней частях страницы. Обычно в колонтитулы заносится такая информация, как номера страниц, названия разделов, сведения об авторе, название книги.

Колонтитулы отображаются на каждой странице, однако, можно настроить их поведение так, чтобы они не отображались на первых нескольких страницах (где обычно располагаются титульный лист и, например, оглавление).

Можно использовать колонтитулы и в других целях. Например, вы хотите, чтобы на каждой странице у вас отображалась чертежная рамка. Для этого необходимо создать в нижнем колонтитуле таблицу, которая будет также выходить и на основной текст. В клетку «страница» рамки можно занести поле «номер страницы» для автоматической нумерации.

Добавьте в документ верхний и нижний колонтитул («Вставить» → «Верхний/Нижний колонтитул» → «Обычный»). На верхнем колонтитуле отобразите общее количество страниц документа («Вставить» → «Поля» → «Количество страниц»), на нижнем - номер страницы (аналогично предыдущему).

Отредактируйте документ, задав размер левого поля 2.5 см, остальных - по 1 см. На колонтитулы отведите по 1.5 см. Для этого в меню «Формат» активируйте пункт «Страница».
^

Автоматические элементы

Использование автоматических списков


Создайте список, содержащий несколько уровней. Для создания списков существуют кнопки . Левая - для создания нумерованного списка, правая – маркированного.

Используйте различные стили.

После ввода каждого элемента списка нажимайте . Тогда автоматически будет увеличиваться счетчик текущего уровня списка.

Менять уровень списка можно клавишей или + . Кроме того, можно воспользоваться кнопками изменения уровня списка панели инструментов «Список».

Для изменения стиля списка из меню «Формат» в верхней части окна выберите пункт «Нумерация и маркировка». На вкладке «Настройки» появившегося окна можно настроить стиль многоуровневого списка. Выберите из списка слева номер уровня, в стилях «Нумерация», «Стиль символа» и, если нужно, «Символы» выберите оформление данного уровня. На вкладке «Положение» можно настроить отступы от края страницы до начала маркера и от маркера до текста (см. рис. 3). Затем нажмите «OK».

Пример:

Животные:

  1. Домашние:

    1. грызуны

      • мышь

      • крыса

    2. хищники

      • собака

      • кошка

  2. Дикие

    1. млекопитающие

      • кенгуру

      • дельфин

    2. земноводные

      • крокодил

      • черепаха

Р
ис. 3. Изменение стиля списка, внешний вид списка после изменения параметров.

Теперь постройте еще один список. Образец - далее. Здесь необходимо пропускать некоторые уровни списка.

Химические элементы:

  1. Кислоты:

    1. Неорганические

      • соляная1

      • серная

    2. Органические

      • аскорбиновая2

      • уксусная3

  2. Щелочи:

      • едкий натр

      • едкое кали

  3. Нейтральные вещества

    1. Растворители

      • вода

      • этанол

Сноски


Добавьте к некоторым элементам автоматические сноски4.

Чтобы вставить сноску, установите курсор в нужном месте текста. Затем из меню «Вставить» выберите пункт «Сноски». На появившемся диалоговом окне выберите обычные автоматические сноски (концевые сноски со всего документа печатаются в его конце). Когда вы нажмете «OK», автоматически появится символ сноски, а курсор переместится в нижнюю область страницы, где вы сможете ввести текст сноски. Чтобы вернуться к редактированию текста, щелкните по основному тексту левой клавишей мыши.

Оглавление


Если в вашем документе не применялись стили «Уровень 1» и «Уровень 2», то создайте в нескольких местах документа заголовки. Желательно, чтобы документ состоял из нескольких страниц, и на каждой было хотя бы по одному заголовку 1-го уровня и 2-3 заголовка 2-го уровня.

Вставьте в самом начале текста автоматический элемент «Оглавление». Для этого воспользуйтесь меню «Вставка» → «Оглавления и указатели» → «Оглавления и указатели». Выберите какой-нибудь стиль оглавления, а также количество уровней, которые будут в нем отображаться.

Можно сменить заголовок (в левой части появившегося окна отображается предварительный просмотр получившегося оглавления). После этого нажмите «OK» (см. рис. 4). На странице появится оглавление.

Попробуйте внести в документ новый заголовок, или изменить старый. Теперь, чтобы оглавление обновилось, щелкните на его тексте правой кнопкой мыши и из контекстного меню выберите «Обновление указателя». Все изменения сразу отразятся в оглавлении.

Добавьте в документ несколько страниц (для создания новой страницы нажмите + ). На каждой странице создайте по 1...2 заголовка, оформленных разными стилями (от «Заголовок 1» до «Заголовок 3»). Обновите оглавление.


Р
ис. 4. Меню вставки оглавления и указателей.
^

Алфавитный указатель


Выделите какое-нибудь слово, например, если вы пользовались классификацией животных, выделите «дикие». Выберите в меню «Вставка» → «Оглавления и указатели» → «Элемент указателя».

В качестве 1-го ключа укажите «Дикие животные». Укажите, что это - основной элемент.

Затем выделите, например, «Кошка». Опять повторите операцию с выделением указателя, но кроме 1-го ключа укажите 2-й ключ - «Хищники».

Проделайте подобное еще с несколькими словами, затем перейдите в конец документа и вставьте алфавитный указатель также, как вставляли оглавление.

Обратите внимание, что элементы указателя содержатся в особой базе данных, из которой сначала в алфавитном порядки собираются все текстовые элементы, а затем для них выбираются соответствующие страницы. Важно не ошибиться при выборе названия элемента указателя, особенно если он встречается на нескольких страницах. Если в одном месте документа вы назовете этот элемент не так, как в другом, он войдет в алфавитный указатель под двумя именами.

Формулы

Простые


На новой странице стилем «Заголовок 1» наберите: «Набор и редактирование формул». Ниже вставьте формулу:



Для того, чтобы вставить формулу, выберите в меню «Вставить» → «Объект» → «Формула». Экран разделится на две части. Вверху отображается ваш документ, внизу расположено командное окно. В него необходимо вводить команды для создания элементов. Однако, некоторые элементы можно вводить, выбирая из плавающего меню. Если его нет, выберите в меню «Вид» → «Выделенное».

Плавающее окно разделено на две части: вверху расположены кнопки групп символов, внизу - кнопки для вставки конкретного символа. После нажатия кнопки, соответствующей выбранному элементу, необходимо в области, помеченные как ввести текст. Изменения автоматически отображаются в верхней части окна Writer. Если вы все сделали правильно, в нижней части экрана должно быть написано: lim from {x toward 0} int from 0 to %pi {sin x over x} dx = int from 0 to %pi dx = %pi.

На первый взгляд кажется сложным создавать формулы таким образом, однако, имея небольшие знания английского и немного практики в наборе формул, вы будете набирать их при помощи клавиатуры значительно быстрее, чем выбирая из меню нужные элементы при помощи мыши.

Обратите внимание, что для обозначения пределов интегрирования, а также условия предела мы использовали from для нижнего и to для верхнего индекса. Эти команды - полные аналоги соответствующих команд csub и csup, однако, в отличие от последних, применимы только к математическим операторам с пределами.

Сложные


Вставьте в текст «многоэтажную» формулу:



Код, соответствующий данной формуле: F(%omega,N) = int_{-infinity}^infinity E(t) cdot {sin {N %omega t} over {2 %pi}} over {sin {%omega t} over {2 %pi}} e^{-i%omega t} dt.
^

Создание визитных карточек


Запустите OO Writer. Вставьте таблицу, состоящую из двух столбцов и шести строк. Обратите внимание на формат страницы. Для того, чтобы на одном листе А4 уместилось 12 визиток, необходимо установить размеры всех полей по 1 см. Зайдите в меню «Формат» → «Страница», активируйте вкладку «Страница» и установите размер всех полей по 1 см, а формат листа – А4.

Теперь для того, чтобы задать фиксированный размер визиток, выделите созданную таблицу целиком и щелкните внутри нее правой клавишей мыши. Из появившегося контекстного меню выберите пункт «Строка» → «Высота». Появится диалоговое окно (см. рис. 5), в котором необходимо задать высоту визитки: 4.5 см. Нажмите «OK». Затем точно так же щелкните правой клавишей мыши внутри таблицы и задайте ширину столбцов (9 см) из меню «Столбец» → «Ширина».

^ Выделить всю таблицу можно, дважды нажав + , когда курсор находится внутри нее.

В итоге у нас получится таблица - эскиз для 12-ти визиток. Перейдем к их заполнению.

Если вы хотите, чтобы текст внутри визиток был отцентрирован, выделите всю таблицу и задайте выравнивание по центру (аналогично для выравнивания по ширине или по правому краю).

Н

ет необходимости заполнять все ячейки. Для начала заполним одну, а затем, выделив ее содержимое, скопируем во все остальные.

Рис. 5. Задание размеров ячеек таблицы.

Можно сделать так, чтобы содержимое ячеек было отцентрировано и по вертикали. Для этого, выделив всю таблицу, щелкните внутри нее правой клавишей мыши и из контекстного меню «Ячейка» выберите пункт «По центру».

Напишите самой первой ячейке крупным жирным шрифтом свое имя. Затем ниже - род деятельности и контактную информацию. В каждую ячейку можно добавить изображение, чтобы сделать визитку более красочной.

Вы можете залить буквы разными цветами, тогда при печати на цветном принтере визитка будет выглядеть значительно лучше, чем простая черно-белая.

Теперь в ячейке с базовой визиткой нажмите + , чтобы выделить все содержимое ячейки. Оно сразу попадет в буфер обмена, но для верности можно еще нажать + (скопировать выделенное в буфер).

Щелкайте мышью внутри пустых ячеек и нажимайте среднюю клавишу мыши (или + ). Содержимое буфера обмена будет вставлено в данную ячейку. В результате вы получите 12 визиток на одном листе (см. рис. 6). В дальнейшем достаточно будет распечатать их на хорошей бумаге на лазерном или струйном принтере.





Рис. 6. Копирование визитных карточек.

В графической оболочке KDE существует поддержка двух независимых буферов обмена: в один помещается то, что вы выделяете мышью, чтобы вставить его содержимое, необходимо нажать среднюю клавишу мыши; во второй помещается скопированное при помощи сочетания + , чтобы вставить его содержимое, необходимо нажать + . Очень удобно работать с первым буфером: вы выделяете часть текста, которую надо скопировать в другое место документа, и щелкаете средней клавишей мыши там, куда необходимо вставить выделенный элемент.


^

Создание деловых писем


Р
ис. 7. Мастер писем.

Деловое письмо легче всего создать при помощи мастера писем. Запустите его из меню «Файл» → «Мастер» → «Письмо». Появится диалоговое окно мастера (см. рис. 7).

Оставьте тип страницы «Деловое письмо». Выберите дизайн страницы (при его смене автоматически обновляется образец письма на фоне). Нажмите «Далее». Установите стандартный формат «Русский» (если такового не окажется, оставьте американский). Установите флажки на элементах, которые должны отображаться в письме (см. рис. 8). Далее заполните поля «Адрес отправителя». В поле «адрес получателя» оставьте отметку на первом пункте. Нажмите «Далее». Вам предложено будет оформить нижний колонтитул. Если вы хотите, чтобы на каждой странице письма отображался какой-нибудь текст, занесите его в поле нижнего колонтитула, для оформления номера, отметьте соответствующий флажок.

После этого будет предложено изменить стандартный шаблон письма. Можете ничего не выбирать, а просто нажать «Готово». По шаблону создастся новое письмо (см. рис. 9).

Теперь заполните письмо. Придумайте какой-нибудь текст для официального послания. Окончательный вариант письма сохраните в своей рабочей папке.


Рис. 8. Второй шаг мастера писем.






Рис. 9. Шаблон письма (слева) и готовое письмо (справа).
^

Создание, редактирование и форматирование таблиц


Для набора табличных данных существует множество специальных программ - электронные таблицы. Конечно, можно набирать таблицы и в текстовом редакторе, но намного удобнее делать это в специальной программе, позволяющей не только набирать и красиво оформлять таблицы, но и производить в них несложные расчеты. Благодаря этому очень удобно создавать различные сметы и отчеты.

Запустите Open Office Calc. Ознакомьтесь с меню программы. Основное рабочее пространство программы покрыто сеткой, в каждую из ячеек которой можно заносить различные данные. Ячейки можно объединять между собой (надо выделить несколько ячеек и выбрать пункт меню «Формат» → «Объединить ячейки». На рис. 10 изображено окно программы.

Р
ис. 10. Окно программы Open Office Calc.

Самая важная функция электронных таблиц - создание формул, включающих функцию и диапазон вычисляемых ячеек. Благодаря этому электронные таблицы получили такое широкое применение. Необходимо отметить также возможность прогнозирования значения с помощью анализа «что-если». Это означает, что можно пересмотреть различные варианты данных для достижения результата. По имеющимся данным можно построить диаграмму. Диаграммы настраиваются по многим параметрам (тип, размер, шрифт, цвет, оформление и др.). Кроме всего перечисленного в OO Calc имеется множество дополнительных функций, ускоряющих и облегчающих работу с таблицами:

  • автоматический подбор высоты строк и ширины столбцов;

  • выполнение условного форматирования таблиц;

  • наложение защиты на документ;

  • поддержка большинства математических, экономических и других функций;

  • возможность сортировки данных таблицы;

  • изменение масштаба просмотра документа;

  • создание границ вокруг ячеек и таблицы;

  • разработка своего стиля и использование его в дальнейшем для быстрого форматирования текста;

  • поддержка нескольких словарей для проверки правильности написания;

  • работа с макросами;

  • удобная справочная система;

  • проверка орфографии и синтаксиса;

  • настройка панелей инструментов (добавление и удаление кнопок и команд);

  • возможность предварительного просмотра перед печатью;

  • настройка параметров страницы и поддержка нестандартных форматов бумаги.
^

Простые таблицы


Создайте таблицу по образцу:

Экзаменационные оценки

№ п/п

Ф.И.О.

Математика

Физика

Химия

1.

Пупкин Вася

2

3

2

2.

Иванов Коля

3

4

4

3.

Сергеев Олег

5

5

4

4.

Никитин Стас

3

3

4

5.

Аверьянов Саша

4

3

3

Отсортируйте таблицу по алфавиту. Оформите ее границы.

Для создания автоматической нумерации поставьте цифру 1 в 1-й ячейке списка, затем выделите ее одним щелчком левой кнопки мыши и протяните на нужное количество ячеек за правый нижний угол. Курсор мыши при этом примет вид крестика. В появившемся окне «Заполнить ряды» в поле «Тип рядов» следует указать «Линейный» и выбрать приращение равным 1. Аналогично можно заполнять любые ряды с равноотстоящими значениями.

Р
ис. 11. Сортировка данных в OO Calc.

Чтобы отсортировать данные таблицы, выделите ее (вместе с заголовками). Выделять колонку с нумерацией не нужно. В окне параметров сортировки (см. рис. 11) укажите, по каким колонкам следует сортировать данные. Т.к. все ряды у нас связаны, будем сортировать только по Ф.И.О. В элементе «Затем по» должно быть значение «-- не определен --». Переключатель направления сортировки - в положение «По возрастанию».

Создайте таблицу по образцу:

^ Расход материалов при строительстве

№ п/п

наименование

по плану

фактически

примечание

1.

кирпич (м3)

3455

3789

брак - 120 шт

2.

цемент (м3)

1756

1997

3.

песок (м3)

3545

4748

4.

перекрытия ж/б (шт)

6

6


Отсортируйте содержимое таблицы по алфавиту. Оформите ее границы, сделайте цветную заливку ячеек таблицы.
^

Таблицы с формулами


В нижней левой части окна программы расположены переключатели рабочих листов. По умолчанию существует 3 листа, однако, можно добавлять, удалять и переименовывать листы по своему усмотрению.

Создайте на другом листе документа таблицу 3х31.

Занесите в ячейки первой строки данные: в A1 - № п/п, в B1 - Х, в C1 - Y. В первый столбец занесите номер ячейки с данными в таблице (как в предыдущих таблицах), во второй столбец занесите значения аргумента Х, начиная от -1.5 и заканчивая +1.5 с шагом 0.1.

Для этого введите в первую ячейку -1.5, в ячейке под ней напишите формулу =Xx + 0.1, где Xx -- координаты предыдущей ячейки. Например, в ячейке B2 должна быть запись =B1+0.1.

Затем протяните ячейку с формулой на нужное число клеток вниз, выбрав в окне «Заполнить ряды» тип «формула».

Можно вместо этого воспользоваться удобными возможностями OO Calc: протянуть вниз на 35-40 ячеек содержимое ячейки B1 и в окне «Заполнить ряды» указать тип - линейный, нач. значение - -1.5, кон. значение - 1.5, приращение – 0.1.

В третий столбец вставьте какую-нибудь формулу, например, =Xx^2+3*Xx^3, где Xx - координаты соседней слева ячейки (т.е. для C1 это - B1). Протяните эту ячейку до конца таблицы.

Вводить цифры удобнее при помощи дополнительных цифровых клавиш, расположенных в левой части клавиатуры, так как десятичный разделитель обозначается либо точкой, либо запятой. При вводе с дополнительной клавиатуры отобразится правильный десятичный разделитель.

Вместо того, чтобы вписывать координаты ячеек или диапазонов, достаточно просто щелкнуть левой кнопкой мыши по данной ячейке (либо выделить левой кнопкой диапазон данных) в процессе ввода формулы.

Создайте на другом рабочем листе таблицу 2х101. В первый столбец занесите координату X от -5 до +5 с шагом 0.1, аналогично тому, как вы делали в предыдущем задании.

Во второй столбец занесите координату Y - какую-нибудь сложную функцию от X, например, exp(sin Xx).

Если с введением формулы возникают проблемы (например, вы не можете найти, как данная функция записывается в этой версии электронных таблиц), можно воспользоваться пунктом меню «Вставка» → «Формула», откуда и выбрать требуемую функцию из предлагаемого списка.
^

Диаграммы и графики


Р
ис. 12.Выбор типа диаграммы.

Построим по предыдущим двум таблицам график.

Выделите в построенной таблице 3х31 второй и третий столбцы и постройте по ней гистограмму и график.

Аналогичным образом постройте график к таблице из задания 4. Учтите, что из-за больших размеров таблицы график может строится долго.

Для построения диаграмм и графиков активируйте пункт меню «Вставить» → «Диаграмма». В появившемся окне «Автоформат таблицы» отметьте галочкой «Первая строка как подпись» и «Первый столбец как подпись», чтобы первый столбец понимался как данные оси Х, а первая строка таблицы - как подписи осей в легенде. Щелкните «Далее». Выберите тип диаграммы (см. рис. 12). Сначала - «Гистограмма», затем, когда вы будете строить график, выберите «Линии». Переключатель «Ряды данных» должен находиться в положении «Столбцы». Нажмите «Далее». В окне «Выбор варианта» укажите «Обычная». Снимите галочки с пунктов «Линии сетки». Нажмите «Далее». Заполните пункты «Название диаграммы», «Заголовок оси». Нажмите «Готово» и на листе появится диаграмма.

Свойства диаграммы можно редактировать и после построения, выбирая нужные пункты контекстного меню диаграммы. Если дважды щелкнуть левой кнопкой мыши по диаграмме, можно будет редактировать ее объекты: менять их параметры, перемещать их внутри области диаграммы. В итоге ваш рабочий лист будет выглядеть как на рис. 13.

Р
ис. 13. Выбор типа диаграммы.

Ссылки


Ссылки на ячейки необходимы для выполнения сложных вычислений, особенно когда рассчитывается функция от содержимого нескольких ячеек.

Вы уже использовали ссылку на соседнюю ячейку при вычислении формул. Здесь мы ознакомимся с видами ссылок: абсолютными и относительными.

На следующем листе документа создайте таблицу «Цены на продуктовые товары». В первый столбец занесите значение номера по порядку. Включите в таблицу несколько товаров (второй столбец), в третьем столбце запишите стоимость товаров в «у.е.», а в четвертом - в рублях.

Для автоматического пересчета введите в 1-ю ячейку третьего столбца формулу =Xx*Yy. Где Xx - соседняя слева ячейка с ценой в рублях, Yy - ячейка, содержащая курс валюты (поместите ее рядом с таблицей).

Теперь протяните ячейку с формулой вниз. У вас получились нули. Это произошло из-за того, что при протягивании ячеек все незащищенные ссылки на другие ячейки изменяются. Т.е. курс «у.е.» во второй строчке будет браться уже из ячейки под действительным курсом.

Чтобы этого не происходило, необходимо защитить знаком $ ту координату, которая должна оставаться неизменной. В данном случае перед координатой строки (т.е. цифрой) необходимо будет поставить знак доллара.

Пример таблицы для данного задания:

Цены на продуктовые товары

п/п

Продукт

Цена ($)

Цена (р.)

1.

Сметана (1кг)

1.22




2.

Хлеб (1 булка)

0.31




3.

Молоко (1л)

0.43




4.

Колбаса копченая (1кг)

4.55




5.

Вареники (0.5кг)

0.95




Чтобы значение цены в «у.е.» бралось каждый раз из ячейки слева от ячейки с ценой в рублях, координаты этой ячейки защищать не нужно. Следовательно, если цена в долларах записывается у нас в столбец B и первое значение расположено в ячейке B1, а курс доллара располагается в ячейке D1, то в ячейку C1 надо будет записать: =B1*D$1
^

Расчеты по электронным таблицам


Постройте статистическую таблицу разрядки конденсатора:

t, мс

I, мкА

t, мс

I, мкА

t, мс

I, мкА

t, мс

I, мкА

0

150.5

6

7.3

11

1.0

16

0.1

1

100.4

7

5.0

12

0.5

17

0.1

2

55.7

8

3.8

13

0.3

18

0.1

3

35.6

9

2.6

14

0.2

19

0.0

4

19.4

10

2.3

15

0.2

20

0.0

Зная, что конденсатор разряжается по закону , а также, что R=22 кОм, найдите емкость конденсатора.

Таблицу следует набирать в два столбца, здесь она дана в восемь столбцов для экономии места.

Для выполнения задания сделаем кое-какие расчеты:

  • Т.к. данные таблицы содержат ошибки, нам придется искать средние значения и. Прологарифмируем формулу : .

  • Построим справа от нашей таблицы дополнительный столбец: (в первую ячейку которого введем формулу =ln(Xx), где Хх - значение тока в 0-й момент времени, и растянем до конца таблицы). В наших вычислениях не надо использовать последние два значения (при t=19 и 20 с), иначе они внесут серьезную ошибку в вычисления.

  • Искомое значение , усреднив все значения C, получим близкую к истине величину. (- обозначение средней величины). Добавим столбец, в который запишем эту формулу: = / 22000/ ( - ), здесь , и - координаты ячеек, в которых содержатся соответствующие значения времени, логарифма нулевого тока и логарифма тока. Т.к. I0 нам пока не известно, введите вместо координаты любой пустой ячейки. Запишите в эту ячейку =ln(150.5). Потом мы внесем в нее более точное значение. Не забывайте, что ссылка на ячейку с адресом ln I_0 не должна изменяться, т.е. это должна быть абсолютная ссылка. Например, если Эта величина находится у вас в ячейке D25, то ссылку на нее в формуле следует писать так: $D$29. Чтобы были видны значимые цифры, следует установить цифровой формат ячеек с шестью знаками после запятой (из контекстного меню «Формат ячейки»).

  • Под заполненным только что столбцом посчитайте среднее значение емкости: =average(xX:yY)*1000000. Здесь (xX:yY) - весь диапазон емкостей (написав =average(, выделите столбец сверху), а функция average возвращает среднее арифметическое значение из выбранного диапазона. Умножать на 1000000 необходимо, чтобы получить значение емкости конденсатора в микрофарадах.

  • Рядом создайте столбец, в котором нужно посчитать среднюю ошибку. В первую его ячейку запишите =(xX*1000000-$y$Y)^2, где Xx - соседняя слева ячейка, $y$Y - ячейка, в которой записано среднее значение емкости. В ячейке снизу запишите сумму ошибок.

  • Перебирайте значения от 145 до 155. Остановитесь на том значении, при котором будет минимальной сумма ошибок.

Теперь вы получили значение емкости конденсатора. Это был пример использования электронных таблиц в физике и математике.

Вообще, для физических и математических расчетов существуют более «продвинутые» электронные таблицы (вроде Origin или LabPlot), в которых намного больше специфических функций: построение и анализ графиков по сложным функциям, выполнение сложных расчетов и т.п.

Для сложных вычислений существует такой «монстр», как Matlab - программа, которая удовлетворит практически все вычислительные и визуализационные потребности современного ученого.
^

Разработка компьютерных презентаций


Для подготовки мультимедийных презентаций можно использовать удобную программу - Open Office Impress, которая позволяет:

  • создавать профессиональные слайдовые демонстрации, включающие графики, изображения, текст, анимации и прочие объекты;

  • добавлять спецэффекты к элементам слайда: тексту, анимациям и изображениям, а также - настраивать эффекты появления самих слайдов на экране;

  • создавать в презентациях векторные изображения;

  • создавать слайды на основе профессионально оформленных шаблонов;

  • создавать различные виды презентации, позволяющие удобно ориентироваться среди уже созданных слайдов в больших презентациях;

  • сохранять презентации не только в «родном» формате, но и экспортировать презентацию в формат MS PowerPoint, pdf-формат (являющийся мировым стандартом файлов документации) и другие форматы.
^

Создание простой презентации


Запустите OO Impress. Появится окно Мастера презентаций. Отметьте «Пустая презентация» и нажмите кнопку «Готово». Откроется пустая презентация (см. рис. 14).

Заполните ее, как описано ниже.

Р
ис. 14. Презентация Open Office Impress.

Основная область программы состоит из трех частей. Слева расположена область предварительного просмотра пиктограмм слайдов, позволяющая выбирать произвольный слайд. В центре - область создания слайда с закладками, позволяющими выбирать различные представления режима отображения презентаций. Справа расположена дополнительная область, из которой можно выбрать фон конкретной страницы, ее оформление, спецэффекты, тип смены слайдов при демонстрации презентации.

Выберите какой-нибудь из фоновых рисунков, выберите оформление слайда «Только заголовок». Запишите заголовок презентации. Например, «Мой колледж», или «Дикие звери».

Далее необходимо создать следующий слайд. Для этого либо щелкните правой кнопкой мыши в области пиктограмм и выберите из контекстного меню пункт «Новый слайд», либо активируйте пункт меню «Вставить» → «Слайд». Выберите оформление слайда по своему усмотрению. Добавьте заголовок слайда, текст, изображение. Вставить картинку можно двумя способами. Если вы выбрали оформление слайда, содержащее изображение или объект, дважды щелкните по этому объекту левой кнопкой мыши. Появится диалоговое окно «Вставка OLE объекта», в котором выберите «Создать из файла». Нажмите кнопку «Обзор» и выберите нужный рисунок. Снимите флажок «Связать с файлом», чтобы ваша презентация не зависела от компьютера, на котором ее показывают.

Второй вариант, наиболее подходящий - из меню «Вставить» → «Изображение» → «Из файла». В этом случае окно выбора изображения будет содержать область предварительного просмотра картинки.

Изображения можно найти в сети на компьютере SGPK в сетевой папке /Big/Pict. Здесь много фотографий различных природных объектов, животных и т.п. Кроме того, можно скачать изображения при помощи браузера Mozilla с адреса www.sgpk → «Разные картинки».

Создайте не менее пяти слайдов. Соблюдайте основные требования к презентациям: фон обязательно должен быть темным. Наилучший вариант - черный фон. В этом случае зрение не будет напрягаться. Текст должно быть хорошо видно на фоне. Не стоит делать красный фон с желтыми буквами - подобные цвета очень плохо сочетаются. И вообще, красным и желтым цветами лучше выделять только важные элементы текста, либо заголовки. Основной текст лучше сделать белым, светло-серым или голубым.
^

Оформление спецэффектов


Для эффективного показа презентации можно настроить особый тип смены слайдов, а также спецэффекты появления и исчезновения отдельных элементов.

В
ызвать настройку смены слайдов можно из меню «Демонстрация» → «Смена слайдов», или же активировав соответственную закладку в правой области окна.

Рис. 15. Настройка смены слайдов.

Выберите желаемый тип смены слайдов, настройте время, если хотите сменять слайды автоматически. Нажмите «Применить ко всем слайдам», если хотите, чтобы все слайды сменялись одинаково (это - наилучший вариант, не утомляющий зрителя) (см. рис. 15).

Для настройки спецэффектов появления или исчезания элементов слайда активируйте вкладку «Эффекты» в правой области окна или меню «Демонстрация» → «Эффекты». Щелкните кнопку «Добавить». Выберите тип спецэффекта и скорость. Нажмите «OK». Чтобы эффекты появлялись автоматически, выберите в пункте настроек «Начать» параметр «After previous» (после предыдущего), укажите желаемые параметры спецэффекта и скорость.

Каждому спецэффекту будет соответствовать одна строчка в списке эффектов. Если щелкнуть правой кнопкой мыши по желаемому эффекту, можно настроить дополнительные параметры: хронометраж, свойства. Настройка хронометража необходима для создания последовательного появления спецэффектов в желаемой последовательности (см. рис. 16).

Р
ис. 16. Настройка спецэффектов.

Если в окне с перечнем спецэффектов щелкнуть по выбранному эффекту правой клавишей мыши, из контекстного меню можно выбрать пункт «Хронометраж», где можно задать временные задержки при появлении спецэффекта (см. рис. 17).

Постарайтесь не перегружать презентацию спецэффектами, а также не размещать на одном слайде большого числа элементов. Элементы должны размещаться рационально, между ними должно быть свободное пространство (около 10\% размера соответствующей стороны слайда).

Анимация не должна утомлять зрение (т.е. элементы не должны «скакать» - они должны перемещаться плавно).

Для создания оглавления презентации можно воспользоваться меню «Вставить» → «Обзорный слайд».

Добавьте спецэффекты к элементам отдельных слайдов.

Запустите презентацию (для этого надо нажать или ). Подправьте спецэффекты, которые работают не так, как вам бы хотелось. Сохраните работу в домашней папке.

Р
ис. 17. Выбор временных задержек спецэффектов.
^

Создание автоматического показа презентации


Активируйте пункт меню «Демонстрация». Настройте автоматическую смену слайдов по времени - подпункт «Настройки демонстрации» и вид смены слайдов - подпункт «Смена слайда». Вид смены слайдов можно настроить отдельно для каждого слайда, также как и паузу между слайдами.

Сделайте задержку между появлением слайдов 3..5 секунд. Задержку спецэффектов для элементов слайдов создайте в диапазоне 1..3 секунд, чтобы можно было успеть прочитать текст слайда и разглядеть изображения. Не переусердствуйте со спецэффектами: для каждого слайда их должно быть не более 3..5, но и не пренебрегайте разнообразить спецэффекты. Например, если заголовок слайда вылетает сверху, текст слайда может выплывать снизу, а изображения - плавно появляться. Системы управления базами данных (СУБД) служат для организации и хранения больших массивов данных, поиска в них необходимой информации и генерации отчетов по заданным критериям. Пакет Open Office содержит встроенные средства для работы с базами данных различных типов. Помимо функций обслуживания установленных на компьютере баз данных, в Open Office есть свой собственный сервер баз данных.
^

Работа с СУБД Open Office Base

Ознакомление с СУБД. Создание таблицы


Р
ис. 18. Мастер баз данных.

Создайте пустую базу данных, как это описано ниже.

Запустите Open Office Database (Базы данных), либо откройте окно любого приложения Open Office и из меню «Файл» → «Создать» выберите пункт «База данных». Появится диалоговое окно мастера баз данных (см. рис. 18).

На первом шаге оставьте переключатель «Что вы хотите сделать?» на пункте «Создать новую базу данных». Нажмите «Далее». Переключатель регистрации базы данных переведите на «Нет». из флажков в поле «Что вы хотите сделать после этого» оставьте отмеченным только флажок «Открыть базу на редактирование». Нажмите «Готово». Появится окно сохранения базы данных, где вам необходимо указать путь к базе (ваша домашняя папка) и ее имя. Нажмите кнопку «Сохранить». Работа с мастером окончена.

Теперь у вас открыта пустая база данных (см. рис. 19).

Обратите внимание на кнопки панели инструментов слева. Первой расположена кнопка «Таблицы». Таблицы представляют собой массивы данных, с которыми вы будете работать. Далее расположен пункт «Запросы». Запросы позволяют организовать доступ к данным по различным критериям. «Формы» позволяют как создавать новые данные, так и отображать существующие. Поле «Отчеты» позволяет вам генерировать документы по имеющимся данным.

Р
ис. 19. Окно пустой базы данных.
^

Создание таблицы в режиме дизайна


Активируйте кнопку «Таблицы». В списке задач активируйте пункт «Создать таблицу в режиме дизайна». Появится окно создания таблицы. Создадим базу данных учета кадров.

В столбце «Имя поля» занесите поля «Фамилия», «Имя», «Отчество», «Должность», «Стаж работы», «Примечание». Для всех полей укажите тип «Текст», кроме поля «Стаж работы», для которого укажите «Число». В свойствах полей укажите «Обязательное» для всех полей, кроме «Примечания» (см. рис. 20).

Активируйте пункт меню «Файл» → «Сохранить». Назовите базу данных «Сотрудники». Программе понадобится первичный ключ, и она запросит подтверждения для его создания. Ответьте «Да». Таблица готова.

Д
важды щелкните по таблице «Сотрудники» в списке таблиц. Она откроется для редактирования.

Рис. 20. Проектирование таблицы.





Рис. 21. Заполнение таблиц.

Заполните вручную 10-15 полей. Чтобы не заполнять первичный ключ вручную, можете щелкнуть на таблице «Сотрудники» правой клавишей мыши и выбрать в поле свойств «Автоназначение». Тогда вам не понадобится изменять данное поле вручную. После заполнения ваша таблица будет выглядеть как на рис. 21. Сохраните базу данных.

Создайте таблицу «Сотрудники», заполните ее.
^

Создание таблиц с помощью «Мастера таблиц»


Теперь мы создадим вторую таблицу при помощи мастера таблиц. Активируйте задачу «Использовать мастер для создания таблицы». Появится диалоговое окно мастера таблиц.

Р
ис. 22. Мастер создания таблиц.

Создадим таблицу «Коллекция DVD». Переключатель «Категория» установите в положение «Персональный» (см. рис. 22). Из списка «Примеры таблиц» выберите «DVD-Collection», а из переменных полей перекиньте в область выбранных полей поля «Actor» (главная роль), «CollectionID» (идентификатор в коллекции) и «Movie Title» (название фильма). Нажмите «Дальше». На следующем шаге сделайте обязательными поля «CollectionID» и «Movie Title». Для поля «CollectionID» можете указать автоназначение. Нажмите «Дальше». Для первичного ключа укажите поле «CollectionID». Нажмите «Дальше». На последнем шаге нажмите «Готово».

Заполните данную таблицу. Не забывайте сохранять базу данных после каждого изменения.

Создайте таблицу «Коллекция DVD».
^

Работа с таблицами, создание запросов


Для быстрого поиска данных удобно использовать запросы. Создадим запросы, отображающие в алфавитном порядке список сотрудников и список коллекции фильмов.
^

Отбор и сортировка данных при помощи запросов


Активируйте задачу «Использовать мастер для создания запроса». Откроется диалоговое окно мастера. На первом шаге необходимо выбрать поля, которые будут отображаться в запросе. Выберите Ф.И.О. сотрудников и должность. Нажмите «Дальше».

На втором шаге необходимо выбрать режимы сортировки данных. В первом поле выберем «Фамилия», затем «Имя» и третьим ключом укажем «Отчество». Везде укажем «По возрастанию». Нажмите «Дальше».

На этом шаге предлагается создать запрос поиска по конкретным данным. Пропустим его. Нажмите «Дальше».

Можете заполнить поля альтернативных названий, а можете сразу нажать «Дальше».

Здесь также можно оставить все как есть, но при желании можете поменять название запроса. Нажмите «Готово». Появится таблица запроса.



Рис. 23. Создание запросов.

Аналогично создайте запрос по коллекции DVD с сортировкой по названию. Таблицы запросов изображены на рис. 23.

Если база данных содержит несколько сотен или тысяч записей, без запросов довольно сложно найти в ней данные, отвечающие определенным критериям.
^

Сортировка и поиск данных


Для сортировки и поиска данных удобно использовать инструментальную панель таблиц. На ней содержатся значки поиска информации (в виде бинокля) и ее сортировки (стрелка вниз с надписью A→Z означает сортировку по алфавиту, стрелка с надписью Z→A - обратную сортировку).
^

Сортировка данных в таблице


Откройте одну из таблиц. Щелкните по заголовку любого поля. Для сортировки данных нажмите на одну из кнопок сортировки: по алфавиту или в обратном порядке. Вся таблица будет отсортирована соответственно выбору. Кроме того, можно указать сложную сортировку, если нажать кнопку A Z без стрелки. Будет предложено выбрать несколько критериев сортировки.

Отсортируйте данные в таблицах по разным критериям.
^

Поиск данных


Нажмите кнопку поиска данных. Появится окно поля записи. Попробуйте, вводя различную информацию из вашей таблицы в поле поиска, найти ячейку, где эта информация хранится.
^

Создание форм для ввода данных


Зайдите на закладку «Формы» и выберите пункт задач «Использовать мастер для создания формы». Появится диалоговое окно мастера.

На первом шаге мастера из таблицы «Сотрудники» выберите все поля, кроме «ID». На втором шаге просто нажмите «Дальше». На третьем шаге необходимо задать расположение полей. Наилучшим будет расположение «Столбцы - подписи слева», но можете выбрать и другое расположение. На следующем шаге оставьте все как есть. Далее выберите стиль оформления формы (можно просматривать его на создаваемой таблице за окном мастера). Задайте имя формы, если не хотите оставить имя по умолчанию.

Появится форма, позволяющая редактировать и создавать записи в более привлекательном виде. Обратите внимание на нижнюю инструментальную панель. Здесь содержатся кнопки навигации между записями и создания новых записей. Создайте несколько записей при помощи формы.

Создайте формы для редактирования записей таблиц (см.рис. 30).






Рис. 24. Формы для редактирования и создания записей.
^

Создание и печать отчетов







Рис. 25. Генерирование отчета.

Отчет - оконечный этап поиска данных, необходимый для их распечатки или иной работы с ними. Зайдите на вкладку «Отчеты» и активируйте задачу «Использовать мастер для создания отчета». Появится диалоговое окно мастера отчетов.

Для начала создадим отчет, отображающий отсортированный по алфавиту список сотрудников и их должностей (т.е. отчет создадим на базе запроса «Сотрудники»). Выберите все поля запроса. На следующем шаге оставьте все как есть. Точно так же поступите на следующем шаге. Следующий шаг - выбор стиля. Выберите понравившийся стиль (просматривать как он будет выглядеть можно в окне предварительного просмотра OO Writer, которое возникло в начале работы мастера. Потом нажмите сразу «Готово». Сгенерируется текстовый документ с требуемым отчетом. Сохраните его под названием «Отчет_сотрудники» в своей рабочей папке.

Создайте отчеты по обеим таблицам (см. рис. 25).

^ Здесь уместно в разметке колонтитулов выбрать «Cinema», но задать книжную ориентацию листа.

Теперь измените несколько записей в обеих таблицах при помощи форм. Посмотрите, что при этом происходит с запросами.

1Широко используется в народном хозяйстве

2А это – всем известный витамин С

3Куда ж без нее на кухне?

4Вроде этой





Скачать 370,43 Kb.
оставить комментарий
Дата07.09.2011
Размер370,43 Kb.
ТипДокументы, Образовательные материалы
Добавить документ в свой блог или на сайт

хорошо
  1
Ваша оценка:
Разместите кнопку на своём сайте или блоге:
rudocs.exdat.com

Загрузка...
База данных защищена авторским правом ©exdat 2000-2017
При копировании материала укажите ссылку
обратиться к администрации
Анализ
Справочники
Сценарии
Рефераты
Курсовые работы
Авторефераты
Программы
Методички
Документы
Понятия

опубликовать
Загрузка...
Документы

наверх